Kodi Community Forum

Full Version: Google Drive for KODI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2018-11-24, 04:08)HatsuneMX Wrote: [ -> ]When I try to open Google Drive add-on this message appears
 Image

It's the official Google Drive add-on. I have it on a PC and an Android device (V 6.0), and only on Android does that error appear.
I updated it, uninstalled and reinstalled the add-on, rebooted the device and nothing worked, I only had the option to reinstall kodi, but first I wanted to ask if there was a less radical solution
Were you connected to VPN? Same thing happened to me when I was, and this error cleared up when I wasn't. It seems the authentication breaks down when coming from a different network identity than the original login.
Hi @cguZZMan,
Some common subtitle formats are not supported by the addon, I have tested and they worked fine. Please consider to add them.
In googledrive.py
Change line 311 from:
if subtitle['name_extension'] == 'srt' or subtitle['name_extension'] == 'sub' or subtitle['name_extension'] == 'sbv':
To:
if subtitle['name_extension'].lower() in ('srt','idx','sub','sbv','ass','ssa'):
Hi @cguZZMan,
I've a doubt with the frecuency of the updates of contents.
"The second option "Watch for changes in the Cloud Folder" will watch every minute for changes in your cloud drive folder. If a change is detected, it will replicate it in the local exported folder." 
Well, if we have more than 200 tv series and 8000 episodes, is this a good option for that case? The number of petitions/second will be a lot, won't?
I use the third option, "Schedule automatic exports" and one time by day
What do you recommend? Can you post a little table with some examples of possible scenarios?

Thank you

Another question:

Do you know what can be this error?

Image
Thanks for replying @cguZZMan.

I do like the idea of using strm files, and they work well, but only if the library is scraped and the artwork etc is next to the strm file.

I'm currently testing out using a Fire TV 4K stick which doesn't have much internal memory so i'm avoiding keeping the library on the Fire TV and I'd also like to have the same library accessible between multiple devices (not a small ask, I know Blush )

The idea is to figure out a way where I can have one of the following:
  • 1) Artwork and Library info in the folders next to the video files on my Google Drive (Not sure how this will perform in terms of speed and access, but I don't mind waiting a second or two every couple dozen movies for these to download)
  • 2) Artwork, Library info and strm files on a network share which multiple devices can access (Currently testing this and it works, but it takes 5X as long for the movies to start after Kodi seems to hang, which I assume is because it's attempting to play across my network instead of straight from Google Drive)
  • 3) Artwork, Library info on a network share and strm files locally (This would mean I could play directly from the Cloud, but have my library files separately)
  • 4) A much better suggestion from someone who is far more competent at this then I am.

In regards to option 2 above, it sort of works, but the hanging is annoying. The other problem then is to manually update the strm files and library.
I've also attempted Option 1 by choosing the folder as a source (as per your recommendation), all the folders have artwork and data in their respective folders, but Kodi won't scan or see it. It will just say "library empty'.

Any advice or suggestions are definitely welcomed.
it looks like the addon has stopped serving google drive as a source....

I'm having the same problem many other people have, I didnt change anything on my box

EDIT: Also, it looks like the herokuapp page is not working
@keithcq71 I'm not sure if I'm understanding, but there is no plan and I don't see why it should be a way to put a limit for how many times you can add an account. If you are getting a ban from google because you are over sharing your drives, then it's easy to know that you should stop sharing it.

@Kahn10 the addon has nothing to do with the buffer and there is no handling of the advancedsettings.xml. That's a Kodi thing. If you are getting buffer may be you should select a lower stream format to play.

@alfredo.perez you will get the media info if you add your videos to the library and play them from the library. At least in Kodi 18 it's working as expected. Let me know.

@GGATEV same as the answer for @Kahn10

@HatsuneMX it's a known issue. Try removing your account (context menu / Delete account). Let me know
@edcarlo you will get the media info if you add your videos to the library and play them from the library. You can add multiple accounts and have them serve as a source. If you have an issue post always your debug log file.

@dabinn thanks for the suggestion. Do you mind creating the issue in github? so I have it in the list. Or if you can do a PR would be way better and faster.
@alfredo.perez it doesn't matter how many video files you have. In that minute period, the only thing the addon will process are the changes you made in that period. Unless you are modifying all your files in less than a minute there should be no problem. You can schedule the automatic exports too. It's up to you and I think you should test what works best for you.
The error you mentioned is caused when there are multiple process accessing the same configuration file. It's a known issue and I'll fix it in a future. It should work if you try again tho.

@wayjin wouldn't be easy if you have a device sharing the library? Like a MySQL server or any option from https://kodi.wiki/view/Syncing_and_sharing. There is also a issue created here: https://github.com/cguZZman/plugin.googl.../issues/37 which would download the library info but it's not implemented yet. If adding your folder as a source is not working, post your debug log file and I will take a look.
I have my strm files in a network share and mysql serving the library.

@vtwin0001 if you want to report an issue or something is not working for you, always post your debug log file. I don't know what's the problem the other people have.
The herokuapp is working just fine. Unless you have a very outdated version of the addon, the login server http://drive-login.herokuapp.com/ is and always been up and running.
@cguZZMan Thank you, I have created a PR.
@wayjin I am using MySQL for 4 devices to share the library. Dont worry about the artworks, KODI puts image links in the metadata, and only keeps image cache. So you don't really need to save images file.
Using Strm is better in speed  than add gdrive http server as a media source when scraping. If you don't like to have your library files separately, you may add multiple file location in one media source, KODI will display the files together.
(2018-11-26, 05:43)cguZZMan Wrote: [ -> ]@keithcq71 I'm not sure if I'm understanding, but there is no plan and I don't see why it should be a way to put a limit for how many times you can add an account. If you are getting a ban from google because you are over sharing your drives, then it's easy to know that you should stop sharing it.

@Kahn10 the addon has nothing to do with the buffer and there is no handling of the advancedsettings.xml. That's a Kodi thing. If you are getting buffer may be you should select a lower stream format to play.

@alfredo.perez you will get the media info if you add your videos to the library and play them from the library. At least in Kodi 18 it's working as expected. Let me know.

@GGATEV same as the answer for @Kahn10

@HatsuneMX it's a known issue. Try removing your account (context menu / Delete account). Let me know

 Sorry @cguZZMan, I didn't explain well. In fact I get all the info but I don't get the info during the reproduction... I paste and image to see the issue:

Image
As @alfredo.perez said:

This is a .strm file, the file is in the library and has metadata
Image

but during playback, kodi shows the name of the video in its "raw" form
Image
(2018-11-26, 05:49)cguZZMan Wrote: [ -> ]@edcarlo You can add multiple accounts and have them serve as a source. If you have an issue post always your debug log file.
Ok, so how exactly can I add 2 (or more) accounts as source? The same way as I added the first account, using the same port (8587)? Or do I have to use another port? As I said before, everything works great when I have only one account as source but as soon as I add a second account (using the same method and the same port as the first one) the files from the first account disappear from the source's path. I don't think this is a issue that's why I didn't post a debug file, I think I'm simply missing something.
(2018-11-26, 14:31)edcarlo Wrote: [ -> ]As @alfredo.perez said:

This is a .strm file, the file is in the library and has metadata
Image

but during playback, kodi shows the name of the video in its "raw" form
Image
 Hi @edcarlo I've found a solution for the info problem:

Solved the problem of the information in the @cguZZMan  gdrive addon while playing thanks to partner Adan

1.- The first thing is to go to the file manager and add a new source, in this case the famous address http: // localhost: 8587 / source

2.- After> Files and we also add in there.

3.- Once inside the folder we must establish the contents of the folders (series, movies). Obviously if we do not want to add all of a blow in the video library we add the folders to the queries of specific series, for example.

4.- It takes longer to show the contents in the video library, but we save space. (No strm)
@dabinn thanks for the PR, I just merged it. It'll be available in the next release.

@alfredo.perez and @edcarlo just confirmed that's Kodi 17 issue. It doesn't happen in Kodi 18. So I think you should do the jump to Leia.

@edcarlo in the source mode the number of accounts should not matter. Each account is just a different folder within the same url http://localhost:8587/source/. You just need to add each video folder to Kodi as a separate source and that's it. For example, I have a source folder pointing to "tv shows" in one account and then another source folder pointing to the "tv shows" of the other account.
(2018-11-26, 06:20)cguZZMan Wrote: [ -> ]@vtwin0001 if you want to report an issue or something is not working for you, always post your debug log file. I don't know what's the problem the other people have.
The herokuapp is working just fine. Unless you have a very outdated version of the addon, the login server http://drive-login.herokuapp.com/ is and always been up and running.
 Hey @cguZZMan , Im sorry, you're right... I got into kodi-login.herokuapp.com (which is the wrong address) LOL... Sorry for this

I also was able to fix the issue I was having with the drive as source.. It seems there was a conflicting issue with the ports.. I dont know why those were changed... but anyhow, thanks again and sorry for this as well Smile