Kodi Community Forum

Full Version: Google Drive for KODI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I have a few movies that require kodi to have a .nfo file in the movie folder for it to be deceteted correctly or at all.
When I export .strm files from your addon it does not add any .nfo for those movies, so when I add my movies source folder with all of my .strm files, all movies get scanned in except for any that originally needed the .nfo file.
Do u have a workaround for this? I have approximately 400 movies that are not being scanned due to this.
Thanks.
In regards to my last post. The movies that don't get scanned in and require nfo's, fanart and posterart are movies that are not in IMDB.com
Hey there !
This might have been answered but I've searched and found nothing.

Is there any way for me to view the photos I have on the root folder of Google Photos (meaning the ones that are not in an album)?
It seems that I can only see the photos that are within created albums in Google Photos.

Thanks in advance.
(2019-02-23, 21:15)starkman Wrote: [ -> ]Hey there !
This might have been answered but I've searched and found nothing.

Is there any way for me to view the photos I have on the root folder of Google Photos (meaning the ones that are not in an album)?
It seems that I can only see the photos that are within created albums in Google Photos.

Thanks in advance.
Anyone who could provide a little bit of help on this ?
Am I the only one who cannot view the photos that are not within albums ?
I am getting Google Drive Error. Here is my log file.  https://paste.kodi.tv/faxowuxipo
@cguZZMan Any chance that you'd entertain the idea of creating a separate Google Photos add-on that relies on the Google Photos API as opposed to the duplication of media in Google Drive?  It would allow for a more secure authentication method and eliminate the need to use up google account storage quota for Google Photos content. https://developers.google.com/photos/
(2019-03-02, 19:46)sabrex Wrote: [ -> ]@cguZZMan Any chance that you'd entertain the idea of creating a separate Google Photos add-on that relies on the Google Photos API as opposed to the duplication of media in Google Drive?  It would allow for a more secure authentication method and eliminate the need to use up google account storage quota for Google Photos content. https://developers.google.com/photos/
 That would be great, indeed.
Hi, 

I've just installed the app, awesome. But it does not display any pictures? Only displays folders and .mp4? Anyone else experience this?
Hi, just Setup the gdrive Addon and everything works like charm. But I still got one problem, I want to start the Videos automatic after the boot. Which path i need to Write in my autoexec?
Hi!

  First of all - this is the best Kodi add-on ever! Thank you @cguZZMan for putting this together! Really, I am amazed with what I am able to do with it. For that I am really thankful!

  I have 2 devices running this add-on:
  1. OnePlus 6 with lastest Android 9 and latest Kodi and latest add-on version.
  2. Shield TV 2017 with all the latest Android/Firmware running the latest Kodi and latest add-on version. This is my main media player - it is the main movie player in my Home Theater. 
  3. I use the same userid to connect the GDrive add-on o both devices.
  I have both connected to the same Asus Rog Rapture Router - the smartphone using AC Wireless Network and Shield TV with Gigabit cable. The router is connected to the ISP ONT. Currently I've got 200mbps down 100 mbps up connection to the internet.

  I run any video on the Smartphone without any problem, any delay/stop. Things just works great there! 
  On the Shield TV I got the "Slow connection to play/stream" error every other 3 minutes or so! I can't even use it anymore.
  1. Here is the log using Aura skin and wireless (I thought it may have been the cable, don't know - just want to use the same wireless AC as the smartphone to test) connection to the internet: nekuyihono.kodi (paste)
  2. Here is the log after changing the skin to the default one and connecting Shield again to the router using the cable: wasuvomubo.kodi (paste)
  3. And here is the log from my phone - I played the same movie for about 25 minutes without having ANY issues: okoxepajap.kodi (paste)
  4. Here is the media information of the movie I used to reproduce the error: yovapogigo (paste)

What can I do to make the Shield TV problem go away?! 

Thanks
Gilson
When it says "Add Drive as a source", providing the localhost address, is it possible to have multiple sources such as http://localhost:8587/source/Movies and http://localhost:8587/source/TV Shows? Or is it http://localhost:8587/Movies?

Edit: installed the plugin and understood how it works.
(2019-03-02, 22:19)raczyk Wrote: [ -> ]Hi, 

I've just installed the app, awesome. But it does not display any pictures? Only displays folders and .mp4? Anyone else experience this?
 If you launch Google Drive from under the video addons section, it will only show videos from your drive.  If you launch it from under the pictures addon section, it will only show pictures.
One question: is there a reason to use the .strm approach as opposed to using Drive as a source with http://localhost:8587/source/ ?

Because unless I'm missing something, using it as source should provide and experience identical to local files with Kodi, so I don't understand why one would want the other option.
Thanks.
PS
I read several pages without finding an explanation for this.
I have a doubt, I confess that I did not read everything after my last access.
   But in the past it was not possible to view information about the movie, during the execution of the same .... Even added to your library .... The strm file has not (or did not) have this capability ....

So I always had the filename ..... Do you already display the metadata during the execution of the movie? or do we still have this limitation Huh



forgets! It's working !!!
(2019-03-06, 23:52)ashlar Wrote: [ -> ]One question: is there a reason to use the .strm approach as opposed to using Drive as a source with http://localhost:8587/source/ ?

Because unless I'm missing something, using it as source should provide and experience identical to local files with Kodi, so I don't understand why one would want the other option.
Thanks.
PS
I read several pages without finding an explanation for this.
Anyone using the plugin that can answer this question? Thank you in advance.