Kodi Community Forum

Full Version: Google Drive for KODI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2020-02-19, 09:11)alfiancc Wrote: [ -> ]Hello,

Im having an error on Android : "_get_item play_url() takes at most 5 arguments (6 given)"

How to fix it?

Thanks in advance.

Regards.
same here, can't play nothing Sad
Hello cguZZMan,

May I begin by saying THANK YOU SO MUCH for this Add-On. I use Kodi only for Google Drive and nothing else since I have a lot of videos and pictures on my account and your Add-On is, for me, the best entertainment application I have ever used. I really can not live without it. 

Naturally, I was super bummed when I noticed my videos stopped working and a quick search led me to this thread and signing up for an account. I'd like to point a couple of things out.

1: Google have definitely changed something or f***ed up somewhere causing these issues. I can say that with 100% certainty because VLC on iOS no longer works either. As you may know, VLC for iOS allows the playing of network streams. It stopped playing Google Drive videos around 2 weeks ago on both iPhone and iPad, at about the same time as your Add-On stopped working.

2: I have used your fix (is it version 1.3.1?) from your repository and while it works and I am happy I can play Google Drive videos again, it somehow feels a bit 'off'. It doesn't feel as efficient as before and is a bit more sluggish. I am not sure if that's just on my computers.

3: I use your Add-On to view images. I have a few folders with 100+ pictures that I use as a slideshow and your latest version doesn't load folders that have large numbers of pictures. Your previous version would take a couple of seconds to load 200+ pictures but your current version just hangs. In folders with less than 30 pictures, it might take 30 or 40 seconds to load, but it won't load large folders at all.

I'm using Aeon MQ 8 skin if that's relevant at all.

I hope that's not nitpicking. I really do love your Add-On and I hope you can fix the fix at some point because I truly can't live without it!
(2020-02-19, 20:01)jonsnow30 Wrote: [ -> ]
(2020-02-19, 09:11)alfiancc Wrote: [ -> ]Hello,

Im having an error on Android : "_get_item play_url() takes at most 5 arguments (6 given)"

How to fix it?

Thanks in advance.

Regards.
same here, can't play nothing Sad 
just adding the complete error from the kodi log :

2020-02-20 09:50:12.312 T:23032   ERROR: [plugin.googledrive][MainThread-23032]: [plugin.googledrive] [1.3.1]/[1.2.10]
                                            
                                            unknown error:
                                            _get_item_play_url() takes at most 5 arguments (6 given)
                                            please try again.
                                            
                                            Traceback (most recent call last):
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 764, in route
                                                method(**arguments)
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 654, in play
                                                subtitles.append(self._get_item_play_url(urllib.quote(Utils.str(subtitle['name'])), driveid, Utils.default(Utils.get_safe_value(subtitle, 'drive_id'), driveid), subtitle['id'], True))
                                            TypeError: _get_item_play_url() takes at most 5 arguments (6 given)
                                            
                                            
                                            show_error_dialog: True
2020-02-20 09:50:28.258 T:9196 WARNING: CGUIWindowManager - CGUIWindowManager::HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2020-02-20 09:50:28.577 T:23032 WARNING: Previous line repeats 7 times.
(2020-02-20, 09:59)scofield272 Wrote: [ -> ]
(2020-02-19, 20:01)jonsnow30 Wrote: [ -> ]
(2020-02-19, 09:11)alfiancc Wrote: [ -> ]Hello,

Im having an error on Android : "_get_item play_url() takes at most 5 arguments (6 given)"

How to fix it?

Thanks in advance.

Regards.
same here, can't play nothing Sad   
just adding the complete error from the kodi log :

2020-02-20 09:50:12.312 T:23032   ERROR: [plugin.googledrive][MainThread-23032]: [plugin.googledrive][1.3.1]/[1.2.10]
                                            
                                            unknown error:
                                            _get_item_play_url() takes at most 5 arguments (6 given)
                                            please try again.
                                            
                                            Traceback (most recent call last):
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 764, in route
                                                method(**arguments)
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 654, in play
                                                subtitles.append(self._get_item_play_url(urllib.quote(Utils.str(subtitle['name'])), driveid, Utils.default(Utils.get_safe_value(subtitle, 'drive_id'), driveid), subtitle['id'], True))
                                            TypeError: _get_item_play_url() takes at most 5 arguments (6 given)
                                            
                                            
                                            show_error_dialog: True
2020-02-20 09:50:28.258 T:9196 WARNING: CGUIWindowManager - CGUIWindowManager::HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2020-02-20 09:50:28.577 T:23032 WARNING: Previous line repeats 7 times.  
FYI
the issue seems to be in script.module.clouddrive.common-1.2.10,  I've installed the older ver 1.2.8. and it works perfectly.
Hello, new to this addon (and a little bit to Kodi). I have installed the addon and succesed logged in to my Google Drive account. But how do i get to the video's in my Google drive. How do i add a source folder where my video's are?

Kind regards,

Bert
(2020-02-20, 10:07)scofield272 Wrote: [ -> ]
(2020-02-20, 09:59)scofield272 Wrote: [ -> ]
(2020-02-19, 20:01)jonsnow30 Wrote: [ -> ]same here, can't play nothing Sad   
just adding the complete error from the kodi log :

2020-02-20 09:50:12.312 T:23032   ERROR: [plugin.googledrive][MainThread-23032]: [plugin.googledrive][1.3.1]/[1.2.10]
                                            
                                            unknown error:
                                            _get_item_play_url() takes at most 5 arguments (6 given)
                                            please try again.
                                            
                                            Traceback (most recent call last):
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 764, in route
                                                method(**arguments)
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 654, in play
                                                subtitles.append(self._get_item_play_url(urllib.quote(Utils.str(subtitle['name'])), driveid, Utils.default(Utils.get_safe_value(subtitle, 'drive_id'), driveid), subtitle['id'], True))
                                            TypeError: _get_item_play_url() takes at most 5 arguments (6 given)
                                            
                                            
                                            show_error_dialog: True
2020-02-20 09:50:28.258 T:9196 WARNING: CGUIWindowManager - CGUIWindowManager::HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2020-02-20 09:50:28.577 T:23032 WARNING: Previous line repeats 7 times.   
FYI
the issue seems to be in script.module.clouddrive.common-1.2.10,  I've installed the older ver 1.2.8. and it works perfectly. 

does the related video has subtitles?

also do you have the same issue with the videos without subs?
(2020-02-20, 16:06)xybydy Wrote: [ -> ]
(2020-02-20, 10:07)scofield272 Wrote: [ -> ]
(2020-02-20, 09:59)scofield272 Wrote: [ -> ]just adding the complete error from the kodi log :

2020-02-20 09:50:12.312 T:23032   ERROR: [plugin.googledrive][MainThread-23032]: [plugin.googledrive][1.3.1]/[1.2.10]
                                            
                                            unknown error:
                                            _get_item_play_url() takes at most 5 arguments (6 given)
                                            please try again.
                                            
                                            Traceback (most recent call last):
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 764, in route
                                                method(**arguments)
                                              File "C:\Users\Lenovo\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\ui\addon.py", line 654, in play
                                                subtitles.append(self._get_item_play_url(urllib.quote(Utils.str(subtitle['name'])), driveid, Utils.default(Utils.get_safe_value(subtitle, 'drive_id'), driveid), subtitle['id'], True))
                                            TypeError: _get_item_play_url() takes at most 5 arguments (6 given)
                                            
                                            
                                            show_error_dialog: True
2020-02-20 09:50:28.258 T:9196 WARNING: CGUIWindowManager - CGUIWindowManager::HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2020-02-20 09:50:28.577 T:23032 WARNING: Previous line repeats 7 times.   
FYI
the issue seems to be in script.module.clouddrive.common-1.2.10,  I've installed the older ver 1.2.8. and it works perfectly.  

does the related video has subtitles?

also do you have the same issue with the videos without subs? 

now that you mentioned it, I checked with ver -1.2.10, only videos with external subtitles files gives the error  "_get_item_play_url() takes at most 5 arguments (6 given)" , movies without subtitle files plays just fine ...
(2020-02-20, 17:21)scofield272 Wrote: [ -> ]
(2020-02-20, 16:06)xybydy Wrote: [ -> ]
(2020-02-20, 10:07)scofield272 Wrote: [ -> ]FYI
the issue seems to be in script.module.clouddrive.common-1.2.10,  I've installed the older ver 1.2.8. and it works perfectly.  

does the related video has subtitles?

also do you have the same issue with the videos without subs?  

now that you mentioned it, I checked with ver -1.2.10, only videos with external subtitles files gives the error  "_get_item_play_url() takes at most 5 arguments (6 given)" , movies without subtitle files plays just fine ... 

Do you play it via exported strm files or just inside the addon?
(2020-02-20, 17:25)xybydy Wrote: [ -> ]
(2020-02-20, 17:21)scofield272 Wrote: [ -> ]
(2020-02-20, 16:06)xybydy Wrote: [ -> ]does the related video has subtitles?

also do you have the same issue with the videos without subs?  

now that you mentioned it, I checked with ver -1.2.10, only videos with external subtitles files gives the error  "_get_item_play_url() takes at most 5 arguments (6 given)" , movies without subtitle files plays just fine ...   

Do you play it via exported strm files or just inside the addon?  
the issue happens in both, strm files and direct from the addon
The new google drive addon version is 1.3.3. That works with the common drive addon version 1.2.10. Make sure you have both versions correctly.
The problem is that the team kodi merged the common drive addon only and the google drive addon is still pending.
(2020-02-20, 17:36)cguZZMan Wrote: [ -> ]The new google drive addon version is 1.3.3. That works with the common drive addon version 1.2.10. Make sure you have both versions correctly.
The problem is that the team kodi merged the common drive addon only and the google drive addon is still pending.

ohhh boy, shame on me Smile,  I was running Google drive addon ver 1.3.1, now that I upgrade it to 1.3.3 all works great with common drive addon 1.2.10, with and without subtitles. thanks! and sorry for the false alarm.
(2020-02-20, 17:36)cguZZMan Wrote: [ -> ]The new google drive addon version is 1.3.3. That works with the common drive addon version 1.2.10. Make sure you have both versions correctly.
The problem is that the team kodi merged the common drive addon only and the google drive addon is still pending.

I've gotten it installed on my PC no problem through this link: http://repo.faustinotv.ml/plugin.googled...-1.3.3.zip , but how does one add this to a smart tv to stream off of it?
why from there?
(2020-02-20, 17:36)cguZZMan Wrote: [ -> ]The new google drive addon version is 1.3.3. That works with the common drive addon version 1.2.10. Make sure you have both versions correctly.
The problem is that the team kodi merged the common drive addon only and the google drive addon is still pending.

Hi cguZZman. I'm a little confused. When I learned of the problems, I followed the instructions in one of the posts a few pages back. I completely uninstalled the old version of Google Drive, added your repo and installed it directly from there, version 1.3.3

Do I need to have 2 versions of your Add-on, 1.2.0 and 1.3.3, to makes it work as smoothly as before? I thought it's only possible to install one version at a time?
cguZZman, I've updated to the latest 1.3.3 and verified common drive is 1.2.10 but can only play video files directly from the Google drive addon, when trying to play from library where Google drive is a source, I can see the files/ movies but when selecting to play starting to play for a mili second and then connection breaks and nothing is playing. Only happens since last update. I've tested and have the same issue on two seperate Android Tv mi boxes with Kodi 18.5. any ideas? Thanks in advance