Kodi Community Forum

Full Version: Google Drive for KODI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi. I got a problem with multi part videos (moviex part1.mkv & moviex part2.mkv). In normal condition, Kodi will merge both video into a single entry in library, and both video will be merged into a single video when we play it. But when we export it as STRM, the filename become "moviex part1.mkv.strm" and "moviex part2.mkv.strm" and kodi will create 2 separate entries of the same movie in library. What should I do to fix this?

Or is there an option to export the STRM without including the original file extension, so it would become "moviex part1.strm"?
I can't get any google drive to connect with kodi.

only get this:
OOGLE Drive
Retrieving drive information

and the blue processbar never comes over 50%

what to do Huh
Anybody else having problems to run .strm exports against a large amount of folders and files? I've logged this issue @cguZZMan's git -> https://github.com/cguZZman/plugin.googl...issues/125
(2020-03-13, 17:07)gilsonsjc Wrote: [ -> ]Anybody else having problems to run .strm exports against a large amount of folders and files? I've logged this issue @cguZZMan's git -> https://github.com/cguZZman/plugin.googl...issues/125

Yes, all kinds of problems. Files being named with their extension *.mkv *.mp4 instead of *.strm. Only partial syncing of library and this is after I did a clean install of kodi 18.5.
Hey cguZZman,

Just wanna say that it truly sucks with what's happening to your Add-on.

It used to work perfectly for me, for months and months and months. Loved it. Still do.

Then along came Google making pointless, unnecessary changes that cause all kinds of problem. Words can't describe enough how much I hate Google as a company. It's like they deliberately enjoy reducing functionality and making life more difficult for everyone.
(2020-03-05, 19:47)teof13 Wrote: [ -> ]Hi, I have a problem from yesterday. Kodi doesn't play the original stream, it plays the transcoded by Google drive, but when I select the original, it can't open it.

No one replied to you, so I'll try again.
Same issue here in kodi. If choose a different resolution in the drive add-on, it plays, but only in 2 channel audio.
I loose any multichannel output. Hence the need for the original stream. Anyone want to chime in?
Thanks in advance.
double post
(2020-03-13, 18:17)Droidly Wrote: [ -> ]
(2020-03-13, 17:07)gilsonsjc Wrote: [ -> ]Anybody else having problems to run .strm exports against a large amount of folders and files? I've logged this issue @cguZZMan's git -> https://github.com/cguZZman/plugin.googl...issues/125

Yes, all kinds of problems. Files being named with their extension *.mkv *.mp4 instead of *.strm. Only partial syncing of library and this is after I did a clean install of kodi 18.5.  
a workaround solution is that you manually edit the names of the strm files and delete the format extension (.mkv / .mp4...).
(2020-03-13, 23:52)Aquatic Wrote: [ -> ]Hey cguZZman,

Just wanna say that it truly sucks with what's happening to your Add-on.

It used to work perfectly for me, for months and months and months. Loved it. Still do.

Then along came Google making pointless, unnecessary changes that cause all kinds of problem. Words can't describe enough how much I hate Google as a company. It's like they deliberately enjoy reducing functionality and making life more difficult for everyone.
for me the addon still works great, le'ts just hope that it will still work after Google changes on the 31th .
what kind of issues you're facing with the addon at the moment?
any one else find that only the .strm part of the file deletes if a file is removed form google drive if you have selected to watch for changes

so 

9-1-1.S01E02.Let.Go.1080p.AMZN.WEBRip.DDP5.1.x264-NTb.mkv.strm

becomes 

9-1-1.S01E02.Let.Go.1080p.AMZN.WEBRip.DDP5.1.x264-NTb.mkv

after file deletes from google

thanks
Bryan
(2020-03-15, 10:04)scofield272 Wrote: [ -> ]a workaround solution is that you manually edit the names of the strm files and delete the format extension (.mkv / .mp4...). 

Yes, I don't get why people expect from this add-on to cover every possible option and scenario and to work automatically based on their desires.
I mean @cguZZMan has so much to work on, even major re-work of the add-on to make it compatible with Kodi 19, we should give him a break.
Anyway all created strm files can be loaded to our media managers (MediaElch, tinyMediaManager etc), like we do with our local files and be managed with them easily (renaming, moving or even artwork and metadata retrieval).
(2020-03-15, 10:04)scofield272 Wrote: [ -> ]
(2020-03-13, 18:17)Droidly Wrote: [ -> ]
(2020-03-13, 17:07)gilsonsjc Wrote: [ -> ]Anybody else having problems to run .strm exports against a large amount of folders and files? I've logged this issue @cguZZMan's git -> https://github.com/cguZZman/plugin.googl...issues/125

Yes, all kinds of problems. Files being named with their extension *.mkv *.mp4 instead of *.strm. Only partial syncing of library and this is after I did a clean install of kodi 18.5.   
a workaround solution is that you manually edit the names of the strm files and delete the format extension (.mkv / .mp4...). 
Thanks for the solution, I know how to edit them manually and resolve some issues that way. Furthermore, I upgraded to 18.6 and google drive add-on 1.35 and common module to 1.2.14 and all is working well for me now as long as I am patient. The syncing process seems a lot slower but it has been 100% accurate for me and my library is reasonably sized with 1500 movies and 450 tv series... and I make a lot of changes to the files daily trying to ensure a very tidy file naming system.

Love the add-on and in no way am I razzing on it, Carlos or anyone who helps. All your hard work is appreciated, thanks again.

P.S. I could use some help and I've scoured the support pages and I don't like the options like delete the library cache etc... Occasionally I get a series or movie thumbnail that has the correct name but the jpg icon just shows the default folder icon. How do I fix these individually? I have tried to refresh the folder data but that doesn't work. I have manually downloaded from tmdb then added that poster jpg and it works temporarily then at some point kodi disregards it and I am back to the folder jpg.

Any advice would be appreciated, thanks. I know this is the wrong place to ask but since I am here I thought I would give it a whirl. Laters
(2020-03-15, 09:51)HalfEmptY Wrote: [ -> ]
(2020-03-05, 19:47)teof13 Wrote: [ -> ]Hi, I have a problem from yesterday. Kodi doesn't play the original stream, it plays the transcoded by Google drive, but when I select the original, it can't open it.

No one replied to you, so I'll try again.
Same issue here in kodi. If choose a different resolution in the drive add-on, it plays, but only in 2 channel audio.
I loose any multichannel output. Hence the need for the original stream. Anyone want to chime in?
Thanks in advance. 
Same on me, I choose the best simple way to play video directly from Gdrive not Library but I can not understand the way it does. Sometime the original plays sometime it doesn't. If you know the rule you can play with it, if not you just wish you'll be lucky today.
Looking for some help - been watching videos in my drive directly from Google Drive add on, but have noticed that videos disappear once watched. there is no option to show all videos, so im not quite sure how to be able to view both watched and unwatched videos on kodi. thanks
So I am setting up a media center with kodi and all my files are in Google Drive. All files are present in a Shared Drive from an .edu account. So my problem is that I have around 415 movies in a folder "Movies" each in its separate folder named "MovieName(yyyy)". So when I am importing the "Movies" only around 290 of them gets imported as .strm files. I try to import the non added movies manually by selecting the particular movie folder and importing it, that still doesn't import the files. All I get is a message that says importing that disappears soon. I tried re-importing and it still imports the same movies. I have already raised an issue at https://github.com/cguZZman/plugin.googl...issues/130. Posting it here so that anybody else can help me if they can.