Kodi Community Forum

Full Version: Unable to load plugin in MP2 2.1.2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am running a setup with some MP2 clients and some Kodi clients and the other day I upgraded from 1.18 to 2.1.2 but I am unable to get the Kodi plugin to load. After a lot of research I have enabled DEBUG logging and found the following:


[2017-12-06 07:20:45,076] [21883  ] [TVService] [DEBUG] - Exception while loading ITvServerPlugin instances: TVServerKodi.TVServerKodiPlugin
[2017-12-06 07:20:45,077] [21884  ] [TVService] [DEBUG] - System.InvalidCastException: Unable to cast object of type 'TVServerKodi.TVServerKodiPlugin' to type 'TvEngine.ITvServerPlugin'.
   ved TvService.PluginLoader.LoadPlugin(String strFile)
[2017-12-06 07:20:45,077] [21884  ] [TVService] [DEBUG] - Unable to cast object of type 'TVServerKodi.TVServerKodiPlugin' to type 'TvEngine.ITvServerPlugin'.
[2017-12-06 07:20:45,077] [21884  ] [TVService] [DEBUG] -    ved TvService.PluginLoader.LoadPlugin(String strFile)

I have tried to download the newest DLL again but to no avail. Not sure why it does not load. The version I use is v1.16.0.137 for MP2.1 final.
Found this new DLL in another thread, downloading this fixed it! Big Grin