Kodi Community Forum

Full Version: MX3 Air Mouse(s) - Stops working intermittently issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have one of the variations of the MX3 Airmouse as per below. Highly rate it as a pretty much all in one solution to controlling Kodi and TV etc (could be rechargeable, could be prettier but those are minor complaints). 

https://www.ebay.com/itm/Remote-NEW-TV-B...2a6dd83007

What I am seeing tho is a weird issue where the remote will stop working on the Kodi system. It's intermittent but regular (at least a couple of times a week). The remote is still working in terms of IR etc and it lights up when sending commands to the media/Windows box but is not at all working on Kodi/Windows. An unplug of the USB dongle and replug even into the same port instantly fixes the problem.

Things I have tried to resolve the problem or find a pattern;
  1. I have two of these remotes and 3 Kodi endpoints, both remotes present the issue on all 3 Kodi endpoints
  2. All my Kodi boxes are Windows media PC's of different varieties, a reboot of Windows doesn't necessarily fix the issue, the USB unplug does. It's a pity as at least then a regular scheduled reboot would work as a general workaround
  3. Tried using the legacy USB2.0 ports rather than USB3.0 ports to see if any correlation, none found, issue still appears
Anyone experiencing similar issues?
Anyone have suggestions for a replacement option if this is a known issue? I really don't want to have to have a keyboard and a remote, keyboard should only come out of the draw if the box is broken, don't mind spending a bit more $ on a higher quality solution but I just can't find anything that has all the non-negiotable features;
inbuilt keyboard
backlit - why are almost non of the airmouse models backlit? makes no sense haha!
IR (to turn TV or other components on)
(2017-12-12, 06:17)rjay Wrote: [ -> ]I have one of the variations of the MX3 Airmouse as per below. Highly rate it as a pretty much all in one solution to controlling Kodi and TV etc (could be rechargeable, could be prettier but those are minor complaints). 

https://www.ebay.com/itm/Remote-NEW-TV-B...2a6dd83007

What I am seeing tho is a weird issue where the remote will stop working on the Kodi system. It's intermittent but regular (at least a couple of times a week). The remote is still working in terms of IR etc and it lights up when sending commands to the media/Windows box but is not at all working on Kodi/Windows. An unplug of the USB dongle and replug even into the same port instantly fixes the problem.

Things I have tried to resolve the problem or find a pattern;
  1. I have two of these remotes and 3 Kodi endpoints, both remotes present the issue on all 3 Kodi endpoints
  2. All my Kodi boxes are Windows media PC's of different varieties, a reboot of Windows doesn't necessarily fix the issue, the USB unplug does. It's a pity as at least then a regular scheduled reboot would work as a general workaround
  3. Tried using the legacy USB2.0 ports rather than USB3.0 ports to see if any correlation, none found, issue still appears
Anyone experiencing similar issues?
Anyone have suggestions for a replacement option if this is a known issue? I really don't want to have to have a keyboard and a remote, keyboard should only come out of the draw if the box is broken, don't mind spending a bit more $ on a higher quality solution but I just can't find anything that has all the non-negiotable features;
inbuilt keyboard
backlit - why are almost non of the airmouse models backlit? makes no sense haha!
IR (to turn TV or other components on) 
 Forgot to add 2 x Windows 8.1 and 1 x Windows 10, so it's not OS versions specific either :|
bump....
Further testing, turning off "allow computer to turn off this device to save power" on all USB elements in device manager makes no difference either :|
(2017-12-19, 15:19)rjay Wrote: [ -> ]Further testing, turning off "allow computer to turn off this device to save power" on all USB elements in device manager makes no difference either :|
 Update..... stumbled across this thread which while not actually originally about the above issue had a final post that did mentioned it and looks like this is a common problem across all the iterations of this remote (there seem to be serveral rebrandings of the same design). Looks like there may be no solution

2681152 (post)
I am having the same issue in windows 10. I also tired ensuring that everything is disabled from saving power and am using high performance power profile as well.
(2018-01-19, 03:42)ZERO <ibis> Wrote: [ -> ]I am having the same issue in windows 10. I also tired ensuring that everything is disabled from saving power and am using high performance power profile as well.
 Yeh from that other thread it looks like myself and the other user have tried everything as well and I have eliminated it being related to 1 particular version of OS etc
I noticed that if you turn on the air mouse when the problem is occurring it works. So it appears that they keyboard functions stop working but not the mouse functions.

What I also notice is that in the Win10 settings menu it shows up under devices as RF Connector but I am not able to find it under device manager.

Check and see if the airmouse works when you turn it on while having the problem.
Interesting I will give that a spin. I was pretty sure I had tried that previously with no change but I will try it again next time if happens Smile
Yea, that does not resolve the issue either. I also tried to place the transmitter on an extension cable so it is really close to the remote to remove any sort of RF issue. However, I still am required to replug the transmitter often to reset the device.
Yeh I would love to get to the bottom of the issue because within reason apart from looking a bit old school the device is probably the only one out there that offers and all in one solution for media PC that is backlit. For the life of me I can't find any common link to the problem, not only that the other thread that is mentioned above one of the commenters said they even had a different brand of the same device (there is a few different rebranded versions of this exact remote) and had the same issues across all versions. Tells me either something is bunk with the product itself or there is some sort of weird sleep issue with the actual remote. The USB sender makes the remove and re-add noise even when the remote has stopped working making me think USB is still working but don't know if it has stopped sending out RF signal as the remote itself works fine for IR still as well when its stops communicating with the PC/Kodi
Yea still no fix, I wonder why so many recommend this broken junk.
yeh dunno! considering it wasn't that easy to find detail on the issue, only figured it out there was an issue due to having two remotes on completely different hardware and OS's and identical issue and then stumbled across it mentioned in a thread about something else, I am actually wondering if it isn't happening for all of the remotes/configs out there and thats why ppl still use/recommend it?

Also I find sometimes it can happen twice in an evening and then other times it might work for a week!

Pretty damn annoying!
i'm having the same problem with my mx3 and found another forum with the same problem happening on osmc (which is based on kodi v17).
https://discourse.osmc.tv/t/solved-my-rf...-v17/22118 
it looks like kodi was misidentifying the remote as a joystick. i wonder if that is the same problem we are having but i don't know how to apply their fix to the windows version of kodi v17.
(2018-03-07, 21:44)ernr Wrote: [ -> ]i'm having the same problem with my mx3 and found another forum with the same problem happening on osmc (which is based on kodi v17).
https://discourse.osmc.tv/t/solved-my-rf...-v17/22118 
it looks like kodi was misidentifying the remote as a joystick. i wonder if that is the same problem we are having but i don't know how to apply their fix to the windows version of kodi v17.
 It might have have some relation to the problem, although the symptoms aren't the same. From what I can see in that thread people had working remotes no issues in Kodi v16.1 then moved to Kodi 17 and the remotes functions were limited and keys weren't working but overall the device was still working.

The problem I think people are seeing here is the remote works perfectly for a period of time and then intermittently hangs/sleeps/loses RF comms with the dongle and therefore Windows/Kodi.
Pages: 1 2