Kodi Community Forum

Full Version: stuttering video
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Kodi 17.6 on Windows 7.  Video playback "stutters": constantly slows down, and speeds up.  It occurs both while watching internet videos as well as videos from the hard disc. The only remedy that stops this "stuttering" is moving the mouse courser so the controls bar shows at the bottom (the bar with play, stop, media info, bookmark, subtitles, and settings). The picture is fluid and steady while the bar is displaying but it starts immediately stuttering again when the bar hides.  I actually used a program (Move mouse) that kept the bar displaying all the time to watch a movie.  I use other media player (VLC) on this laptop on the same movies and the movies are fluid and steady, so it seems that it is a problem with Kodi video player.
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
I am experiencing similar stuttering/buffering using 17.6 (stable) on MacOS 10.11.6 (mac mini Mid 2010).
It appears as if video is not catching up but if I Cmd-Tab to put Kodi into background (bring Finder window in front of Kodi) playback becomes smooth.
This is present on YouTube channels and local video if the resolution is greater than 360p.

Debug log for youtube video:
https://pastebin.com/YmXwhhJ3

Local video (with Cmd-Tab) debug log:
https://pastebin.com/SmWzUR3K

Kodi 15 plays all videos just fine.
(2017-12-28, 11:41)Klojum Wrote: [ -> ]To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
Thank you for your assistance, I really appreciate it.  
my first Debug log... Kodi is "windowed" , the problem starts and continues when the bottom control bar hides
https://pastebin.com/6Ly2D63t
second Debug log Kodi is "full screen 1" 1680x945 p, there is NO problem, no stuttering, fluid motion
https://pastebin.com/5dYvHHYa
and the final third Debub log, Kodi is "windowed" but I made the window smaller than my monitor (about 90%) - there was NO problem until I had expended the window to take the whole monitor (20-25 seconds into the movie), then I got the stuttering again but less frequent than when I had started with full window (the first Debug log)
https://pastebin.com/gUPyJe87
I have repeated this actions and it seems that the problem persists only when Kodi is "windowed" and the window is fully expended.
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
(2017-12-29, 10:54)Karellen Wrote: [ -> ]The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
 I am not aware of any addons except Youtube and Boblight (disabled) on my system (other than the ones on which these two depend on). Can you clarify?
03:01:36.282 T:1996 DEBUG: ADDON: cpluff: 'Plug-in repository.exodus has been installed.'
03:01:36.282 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.module.exodus has been installed.'
03:01:36.282 T:1996 DEBUG: ADDON: cpluff: 'Plug-in repository.kodil has been installed.'
03:01:36.282 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.bonanza has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.safehouse has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.genesis has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.genesis.artwork has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.gurzil.metadata has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.covenant.metadata has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.gurzil.artwork has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.poseidon.metadata has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.kodisraelliveconcert has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.icefilms has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in repository.xbmchub has been installed.'
03:01:36.283 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.module.schism.common has been installed.'
03:01:36.284 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.covenant has been installed.'
03:01:36.284 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.livepremiership has been installed.'
03:01:36.285 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.genesis.metadata has been installed.'
03:01:36.285 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.video.F4mProxy has been installed.'
03:01:36.285 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.exodus.artwork has been installed.'
03:01:36.285 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.exodus.metadata has been installed.'
03:01:36.285 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.tvaddons.debug.log has been installed.'
03:01:36.286 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.covenant.artwork has been installed.'
03:01:36.286 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.program.indigo has been installed.'
03:01:36.286 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.SportsDevil has been installed.'
03:01:36.286 T:1996 DEBUG: ADDON: cpluff: 'Plug-in repository.mdrepo has been installed.'
03:01:36.286 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.module.muckys.common has been installed.'
03:01:36.286 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.poseidon.artwork has been installed.'
03:01:36.287 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.module.covenant has been installed.'
03:01:36.288 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.exodus has been installed.'
03:01:36.288 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.f4mTester has been installed.'
03:01:36.288 T:1996 DEBUG: ADDON: cpluff: 'Plug-in script.module.genesis has been installed.'
03:01:36.289 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.gurzil has been installed.'
03:01:36.289 T:1996 DEBUG: ADDON: cpluff: 'Plug-in plugin.video.md123movies has been installed.'

From your first log - how much more junk could be jammed in there? All of the above are banned addons (wiki) or components of them.

I'd suggest you get rid of this fully loaded crap, uninstall Kodi and reinstall a fresh copy from the store and start again. Your current one is unsupportable and a cesspit.
(2017-12-29, 14:09)blazo Wrote: [ -> ]
(2017-12-29, 10:54)Karellen Wrote: [ -> ]The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
 I am not aware of any addons except Youtube and Boblight (disabled) on my system (other than the ones on which these two depend on). Can you clarify? 
I have uninstalled Kodi, and got a new copy from https://kodi.tv/, so it shouldn't have any banned addons or programs.  Unfortunately the issue continues.
first log: Kodi is "windowed" , the problem starts and continues when the bottom control bar hides. I moved the mouse around 35s into the movie to close Kodi, the control bar showed and the fluidity came back 
https://pastebin.com/thNAa794
second Debug log: Kodi is "full screen 1" 1680x945 p, there is NO problem, no stuttering, fluid motion
https://pastebin.com/dq92xg7g
third Debub log, Kodi is "windowed" but I made the window smaller than my monitor (about 90%) - there was NO problem until I had expended the window to take the whole monitor (around 50 seconds into the movie), then I got the stuttering again.
https://pastebin.com/uMVL5PeH

I have played the same video from my hard drive in all three instances.
I have made a short video to display a problem.
https://youtu.be/ZzM7wno3qsI
Any news on progress of this issue?
not that I know. and the problem persists.
Update: Disabling hardware VTB acceleration resolved my issue.

Check this thread.