Kodi Community Forum

Full Version: Shuttering playback on Nvidia Shield Tv and amazon Fire Tv of particular BD rip
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have tried quite a few releases during my ownership of Amazon Fire TV2 and now new Nvidia Shield TV. Neither could play this BD rip of Red Planet correctly. There is nothing special about this movie, but it will wrecks those devices. It plays perfectly fine on any other device and kodi release (WDTV Live Streaming, Dune Smart D1, rPi (B, B+, 2B) with kodi + raspbmc and openelec, libreelec). It is kind of linked to the fact - it fails only on platforms running android with kodi as an app.

I could cut a small piece of it, if anyone interested to look into this issue. It starts immediately on beginning of the playback and continues through out the movie with video freezes for up to 5 to 10 secs.

Below is the media info of the file:
 mediainfo Red_Planet[BD-AVC-DTSMA].m2ts 
General
ID                                       : 1 (0x1)
Complete name                           : Red_Planet[BD-AVC-DTSMA].m2ts
Format                                   : BDAV
Format/Info                              : Blu-ray Video
File size                                : 17.1 GiB
Duration                                 : 1h 46mn
Overall bit rate mode                    : Variable
Overall bit rate                         : 23.0 Mbps
Maximum Overall bit rate                 : 35.5 Mbps

Video
ID                                       : 4113 (0x1011)
Menu ID                                  : 1 (0x1)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : [email protected]
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 2 frames
Codec ID                                 : 27
Duration                                 : 1h 46mn
Bit rate mode                            : Variable
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive

Audio
ID                                       : 4352 (0x1100)
Menu ID                                  : 1 (0x1)
Format                                   : DTS
Format/Info                              : Digital Theater Systems
Format profile                           : MA / Core
Mode                                     : 16
Format settings, Endianness              : Big
Muxing mode                              : Stream extension
Codec ID                                 : 134
Duration                                 : 1h 46mn
Bit rate mode                            : Variable
Bit rate                                 : Unknown / 1 509 Kbps
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 KHz
Bit depth                                : 24 bits
Compression mode                         : Lossless / Lossy
Language                                 : English

Text
ID                                       : 4608 (0x1200)
Menu ID                                  : 1 (0x1)
Format                                   : PGS
Codec ID                                 : 144
Language                                 : English
Happy to report the issue is gone after updating to dev build kodi-20171231-dc587bd7-master-arm64-v8a.apk (Kodi v18 "Leia" nightly). Took a while to nail this one, Thanks!

PS. I upgraded my Fire TV 2 to Kodi v18 "Leia" nightly v7a(32bit) and it was still having issues, but after verifying the fact my Fire TV gen 2 runs on 64BIT FireOS, I installed same 64bit kodi-20171231-dc587bd7-master-arm64-v8a.ap and the issue is gone as well. Moving to 64bit on Fire TV 2 also solved issue with jerky playback in general. It is silky smooth now. Only little issue - it went black screen after I stopped movie playback, but it is still in alpa state, so glitches are to be expected.
Thread marked solved.