Kodi Community Forum

Full Version: Multiple DVDs refuse to scrape properly
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am presently using Kodi 17.3 on my QNAP NAS. I use IMDB as my primary scraper and I have followed the rules from http://kodi.wiki/view/Naming_video_files/Movies exactly. (section 5.2 now) .  I search the IMDB and copy the title exactly to the folder name and it works except for by multiple dvds. I have tried dvd#, disk#, and disc# but nothing works. It always comes scraped as video.  Here is one I recently did.  Pearl Harbor (2001) disc1 and Pearl Harbor (2001) disc2. I have to manually run the scraper, change the information (because it adds disc 1 and 2 to the title) then go back and manage to title name to add the disk sequence back in so I know which one it is.

Any thoughts on why this is happening?  Also is the dvd1 case sensitive? Some of the ones I had were all caps.
Hello jnkweaver

Can you provide a Debug_Log (wiki) so we can see what the scraper thinks it is finding. The instructions are in my signature. Use the Basic method. Once you have enabled debugging in Settings>System Settings>Logging, restart Kodi then replicate the problem. In your case, try re-scrape those titles. Once done upload to pastebin and link back here. Note: Full logs only. No partial or redacted logs

Also tell us what you are expecting to happen. Is this the one movie split across two DVD's?
I just did a quick test on v17.6 for windows. Using your exact filename you stated above I got this...

16:54:06.569 T:852   DEBUG: VideoInfoScanner: Adding new item to moviesConfusedtack://F:\Movies- Test - Scraped\Pearl Harbor (2001) disc1\Pearl Harbor (2001) disc1.mp4 , F:\Movies- Test - Scraped\Pearl Harbor (2001) disc2\Pearl Harbor (2001) disc2.mp4
16:54:06.603 T:2520 DEBUG: CCurlFile::GetMimeType - http://image.tmdb.org/t/p/original/cDctk...nI28ea.jpg -> image/jpeg
16:54:06.603 T:2520 DEBUG: CurlFile::Open(12C44EC0) http://image.tmdb.org/t/p/original/cDctk...nI28ea.jpg

So it worked for me.

Do you have settings in section 2 enabled? Are movies in one folder or each movie in separate folders?

oops, forgot the settings link... http://kodi.wiki/view/Settings/Media/Videos#Files
Sorry for the day delay, my kids were hogging the NAS yesterday.  That helped alot. It turns out that even though I copied the title exactly IMDB doesn't pull up that title. One example is Victoria & Albert (2001) (I already had fixed Pearl Harbor).  I have Victoria & Albert (2001) disc1 and disc2. When I search for Victoria & Albert (2001) on IMDB it doesn't pull up the page but does pull up a selection with multiple choices with the first one being exactly what I typed. All the non-scraped files seem to fall into this category.

If I read this correctly http://kodi.wiki/view/NFO_files what I need to do is include a parsing information to a nfo file. It appears it is just at the end of the file. A little annoying but appears to be the easiest solution.

If you have a better solution let me know.

PS  I have Kodi showing up in its' own directory (Kodi17) as well as having an XBMC directory with info. Is that leftover from Kodi 16 or does it need both directories?
Yes, a parsing nfo will fix that movie search issue, as Kodi will read the address and go directly to the nominated movie and not bother with a search. No other solution I can think of.

If you had v13 or prior installed, it was named XBMC. From v14 onwards it became Kodi and is a separate install to XBMC. You can safely delete XBMC.
Strange. I installed the version 16 and then 17. Never had anything before that. I have had other issues that makes me think it is best to totally uninstall and reinstall .

Thanks for your help
(2018-01-27, 02:16)jnkweaver Wrote: [ -> ]I installed the version 16 and then 17. Never had anything before that
Ok, then we are talking about different items. Where are you seeing the XBMC folders? Full address or screenshot.
It is possible that QNAP had it left over from a default install as they used to support Kodi.  It is in the .qpkg folder where all the programs are stored. Full path is /share/Cachedev1_data/.qpkg/xbmc   Looks like it is somewhat active as it has a file from Jan 12 2018 which is a supervisor log.
Not familiar with the QNAP. Maybe other members can advise. Now only telling you something you already know... If you have recent files in there, best to not delete it. Smile