Kodi Community Forum

Full Version: Sony Android TV - Stuttering and no audio to play 4K videos
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all,

I've been trying to play some 4K videos (Bitrate around: 50 Mbps) in Kodi (HW: Sony Android TV X750D) but most of the time it starts stuttering and after that with no audio anymore. In general, the video doesn't play smooth.

So far, I tried the changes below in Kodi and Tv, but no success yet.

1 - TV Factory Reset
2 - Changed cache in many different ways (buffermode, memorysize and readfactor)
3 - In Video processing, disabled H/W acceleration in the following ways:
  - Mediacodec and Mediacodec (surface) -> Video plays really slow (impossible to watch)
  - Mediacodec (surface) -> Video plays really slow (impossible to watch)
  - Mediacodec -> Video plays smooth but it start stuttering at some moments and get out of audio


Network setup I tried:
1 - Video source device and Tv in ethernet cable 1 Gbps (Even though TV has only 100Mbps ethernet port)
2 - Video source in ethernet cable and TV connected in the network with a 802.11ac (1900)
Conclusion: In both setup, the video source device is sending/receive 70Mbps in average when playing the videos.

I enabled Kodi's log and see that in average (during the video playblack) it's been using 400MB RAM and 115% (Kodi CPU).

Logs: 
MemoryCacheEnabled: https://ufile.io/4hmvm
DiskCacheEnabled: https://ufile.io/2uy8g
Factory Config: https://ufile.io/bnbsf
PS: SOrry for not using pastbin but logs are bigger than 'free' option can handle.

TV Specs:
Model: Sony 65X750D (https://www.rtings.com/tv/reviews/sony/x750d)
Specs: 2GB RAM, 8GB Disk and 4 CPUs.

Example of Video Tested
Code:
 Video
 ID                                       : 1
 Format                                   : HEVC
 Format/Info                              : High Efficiency Video Coding
 Format profile                           : Main [email protected]@[url=https://forum.kodi.tv/member.php?action=profile&uid=232430]high[/url]
 Codec ID                                 : V_MPEGH/ISO/HEVC
 Duration                                 : 1 h 43 min
 Bit rate                                 : 52.7 Mb/s
 Width                                    : 3 840 pixels
 Height                                   : 2 160 pixels
 Display aspect ratio                     : 16:9
 Frame rate mode                          : Constant
 Frame rate                               : 23.976 (24000/1001) FPS
 Color space                              : YUV
 Chroma subsampling                       : 4:2:0 (Type 2)
 Bit depth                                : 10 bits
 Bits/(Pixel*Frame)                       : 0.265
 Stream size                              : 38.3 GiB (72%)
 Default                                  : Yes
 Forced                                   : No
 Color range                              : Limited
 Color primaries                          : BT.2020
 Transfer characteristics                 : SMPTE ST 2084
 Matrix coefficients                      : BT.2020 non-constant
 Mastering display color primaries        : R: x=0.680000 y=0.320000, G: x=0.265000 y=0.690000, B: x=0.150000 y=0.060000, White point: x=0.312700 y=0.329000
 Mastering display luminance              : min: 0.0050 cd/m2, max: 4000.0000 cd/m2
 Maximum Content Light Level              : 6414 cd/m2
 Maximum Frame-Average Light Level        : 952 cd/m2

How can I know if the hardware (TV) is being the bottleneck and has resources (CPU/MEM) enough to play those kind of videos? 

Sincerely,
Hello,

Please, is anyone able to tell anything about the logs that could matter to the issue? I checked it many times but I don't know which errors/warnings could be related to the issue.

I really appreciate any help here.

Thanks,
Rafael Boschini
(2018-01-28, 15:56)rafaboss Wrote: [ -> ]TV connected in the network with a 802.11ac (1900)
Just wondering... Does the TV also have a ethernet cable option? Wifi can be suffering from signal loss at the weirdest moments.

Start with playing simpler video files. If the big(ger) files have a problem, it'll be a network problem IMO.
Also try other/simpler 4K testvideos (lower bitrate). Just maybe it is a codec problem.

Quote:NOTICE: Disabled debug logging due to GUI setting. Level 0.
Always enable debugging for more detailed log files.

Quote: DEBUG: ffmpeg[8C5DB920]: [matroska,webm] Non-increasing DTS in stream 2: packet 1489 with DTS 1242, packet 1490 with DTS 124
Lots of these... Audio was incorrectly muxed? I'm no audio expert, though.

For uploading longer log files, try https://paste.ubuntu.com .

PS: with large log sections being identical, you can remove the majority of sections section. Just clearly indicate it.
(2018-01-28, 15:56)rafaboss Wrote: [ -> ]TV connected in the network with a 802.11ac

Check this out. Sony ATV network performance is just bad. Either try Ethernet cable or move closer to the access point.