Kodi Community Forum

Full Version: C More add-on thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Image

C More for Kodi
This is a Kodi add-on that allows you to stream content from C More in Kodi.

Disclaimer
This add-on is unoffical and is not endorsed or supported by C More Entertainment in any way. Any trademarks used belong to their owning companies and organisations.

Dependencies:
This add-on is available in the official Kodi repository and all dependencies will be installed automatically when installed from there. However, if you're installing straight from git, please make sure you've got the following modules installed:
This add-on requires Kodi 17.4 or higher with InputStream Adaptive installed. Kodi 18 is required for Android based devices and for subtitles support.

DRM protected streams
Most of C More's content is DRM protected and requires the proprietary decryption module Widevine CDM for playback. You will be prompted to install this if you're attempting to play a stream without the binary installed. Most Android devices have built-in support for Widevine DRM and doesn't require any additional binaries. You can see if your Android device supports Widevine DRM by using the DRM Info app available in Play Store.

Support
Please report any issues or bug reports on the GitHub Issues page. Remember to include a full, non-cut off Kodi debug log. See the Kodi wiki page for more detailed instructions on how to obtain the log file. Additional support/discussion about the add-on can be found in the C More add-on thread.

License
This add-on is licensed under the GNU GENERAL PUBLIC LICENSE Version 3. Please see the LICENSE.txt file for details.

Links
Does this support all nordic countrys?
(2018-01-31, 15:20)Jezze Wrote: [ -> ]Does this support all nordic countrys?

.fi is unsupported at this time because it uses a different API, at least for the login process.

I can take a look at how hard it would be to implement if someone hooks me up with an account.
One finnish guy already made cmore.fi addon, i just wondering if that including .fi. Add to title those countrys so peoples know Smile
Thanks for great addon. But i missing subtitles.
When i look att the new Beck yesterday it was No sub. If i look in the mobil phone om cmore app it was sub.

//Fredrik
(2018-02-04, 10:34)Fredde73a Wrote: [ -> ]Thanks for great addon. But i missing subtitles.
When i look att the new Beck yesterday it was No sub. If i look in the mobil phone om cmore app it was sub.

//Fredrik

Subtitles are fixed in Kodi 18. Smile
Hey m8 good job on the add-on just a couple things subs ain't working and Video resolution h264 1024x576 2404000 bps was a first for me, also i set the add-on to pull from Denmark but it goes to Sweden for all streams. 
And in Audio Stream it states swe audio, movie played fine and everyone spoke Swedish, so that woops no i meant everyone spoke English ofc but no subs tried all nationalities none of them worked.
This is what i am seeing in my log, (not a proper Debug Log) but you get the idea
12:53:41.173 T:2796   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 503
12:53:41.173 T:2796   ERROR: CCurlFile::Open failed with code 503 for https://lbs-usp-dash-live.cmore.se/bbr-c...seekable=0
12:53:41.173 T:2796   ERROR: AddOnLog: InputStream Adaptive: Download https://lbs-usp-dash-live.cmore.se/bbr-c...14256.dash doesn't provide any data: invalid
also this one 13:04:26.620 T:8116   ERROR: CGUIMediaWindow::GetDirectory(
the command it tries to run is a command spanning 50 lines so not posting it here, but a 50 lines command starting with this
plugin://plugin.video.cmore/?action=list_page_with_page_data&page_data=%5b%7b%22parentalGuidance% and goes on for 50 lines is a bit much?
InputStream Adaptive do i need to enable that myself or does it enable itself on install, because could be the issue i am having with res
Thank You
(2018-02-24, 15:17)kimkl Wrote: [ -> ]Hey m8 good job on the add-on just a couple things subs ain't working and Video resolution h264 1024x576 2404000 bps was a first for me, also i set the add-on to pull from Denmark but it goes to Sweden for all streams. 
And in Audio Stream it states swe audio, movie played fine and everyone spoke Swedish, so that woops no i meant everyone spoke English ofc but no subs tried all nationalities none of them worked.
This is what i am seeing in my log, (not a proper Debug Log) but you get the idea
12:53:41.173 T:2796   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 503
12:53:41.173 T:2796   ERROR: CCurlFile::Open failed with code 503 for https://lbs-usp-dash-live.cmore.se/bbr-c...seekable=0
12:53:41.173 T:2796   ERROR: AddOnLog: InputStream Adaptive: Download https://lbs-usp-dash-live.cmore.se/bbr-c...14256.dash doesn't provide any data: invalid
also this one 13:04:26.620 T:8116   ERROR: CGUIMediaWindow::GetDirectory(
the command it tries to run is a command spanning 50 lines so not posting it here, but a 50 lines command starting with this
plugin://plugin.video.cmore/?action=list_page_with_page_data&page_data=%5b%7b%22parentalGuidance% and goes on for 50 lines is a bit much?
InputStream Adaptive do i need to enable that myself or does it enable itself on install, because could be the issue i am having with res
Thank You

Wait, I thought this add-on was illegal to use? Laugh  https://forum.kodi.tv/showthread.php?tid=328446
  • Subtitles require Kodi 18 as stated in the first post.
  • C More incorrectly flags English audio as Swedish, so unfortunately there is nothing we can do there.
  • You can force higher bitrates by changing the Min. Bandwidth setting in the InputStream Adaptive settings.
Hello everyone.

Is it just me or did the add-on stopped working like two days ago. Otherwise awesome add-on. I hope it can be fixed soon. If the developer needs a log I can provide with one.
(2018-04-14, 08:36)Jfunker82 Wrote: [ -> ]Hello everyone.

Is it just me or did the add-on stopped working like two days ago. Otherwise awesome add-on. I hope it can be fixed soon. If the developer needs a log I can provide with one.
 Hi!

You're right, C More threw out their old playback API which this add-on depended on. I have fixed this in git now.

https://github.com/emilsvennesson/kodi-c...8b22d1e47f
Hi,

Im using Kodi on Android TV (Philips TV). Added your latest version from Github. Everything seems to be working correct except for the playback on most broadcasts.  Playback only shows a grey screen with some kind of pixelish movement on the top the screen, it appears to be playing the actual stream "behind" (without any sound). The strange thing is that the TV-series "Sjölyckan" actually did work perfect, tried all episodes avaliable. All other tries gave the first scenario, i tried several series and sport streams.

Im a rookie at this stuff so maybe im missing out on something vital needed for playback?
(2018-04-24, 10:19)_Tomas_ Wrote: [ -> ]Hi,

Im using Kodi on Android TV (Philips TV). Added your latest version from Github. Everything seems to be working correct except for the playback on most broadcasts.  Playback only shows a grey screen with some kind of pixelish movement on the top the screen, it appears to be playing the actual stream "behind" (without any sound). The strange thing is that the TV-series "Sjölyckan" actually did work perfect, tried all episodes avaliable. All other tries gave the first scenario, i tried several series and sport streams.

Im a rookie at this stuff so maybe im missing out on something vital needed for playback?

Hi! Could you please provide a debug log?
Hi,
The addon has stopped working for me, 
Here's the relevant part of the kodi log: https://paste.ubuntu.com/p/QffJDYyQCt/

I'm running on windows 10 1804, with the prerelease Alpha 2 of Kodi.

Btw, thanks for an awesome Addon.
Hi!

Just installed the C-More add-on according to the instructions. Login and view the content works, but I can't stream anything.

This is the log file; https://paste.ubuntu.com/p/fvFn7mmKZD/

Im running Kodi 17.6, OSMC on a Raspberry Pi 3. 

Anyone who know what can be wrong?

Thanks!
I just tried to get the CMore add-on going, but failed with a similar result as bremiz. I'm noob to this, but it seems to be related to the SSL certificate of restapi.cmore.se.

I'm running libreElec, Kodi 17.6, on a RPi3.

Code:
20:27:15.555 T:1304425376   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'requests.exceptions.SSLError'>
                                            Error Contents: HTTPSConnectionPool(host='restapi.cmore.se', port=443): Max retries exceeded with url: /api/tve_web/asset/10315840/play.json?protocol=VUDASH (Caused by SSLError(CertificateError("hostname 'restapi.cmore.se' doesn't match either of '*.one.com', 'one.com'",),))
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.cmore/default.py", line 5, in <module>
                                                addon.run()
                                              File "/storage/.kodi/addons/plugin.video.cmore/addon.py", line 14, in run
                                                router(sys.argv[2][1:])  # trim the leading '?' from the plugin call paramstring
                                              File "/storage/.kodi/addons/plugin.video.cmore/addon.py", line 386, in router
                                                helper.play_item(params['video_id'])
                                              File "/storage/.kodi/addons/plugin.video.cmore/resources/lib/kodihelper.py", line 216, in play_item
                                                stream = self.c.get_stream(video_id)
                                              File "/storage/.kodi/addons/plugin.video.cmore/resources/lib/cmore.py", line 255, in get_stream
                                                data_dict = self.make_request(url, 'get', params=params, headers=headers)['playback']
                                              File "/storage/.kodi/addons/plugin.video.cmore/resources/lib/cmore.py", line 66, in make_request
                                                req = self.http_session.get(url, params=params, headers=headers)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 525, in get
                                                return self.request('GET', url, **kwargs)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 512, in request
                                                resp = self.send(prep, **send_kwargs)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 622, in send
                                                r = adapter.send(request, **kwargs)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/adapters.py", line 511, in send
                                                raise SSLError(e, request=request)
                                            SSLError: HTTPSConnectionPool(host='restapi.cmore.se', port=443): Max retries exceeded with url: /api/tve_web/asset/10315840/play.json?protocol=VUDASH (Caused by SSLError(CertificateError("hostname 'restapi.cmore.se' doesn't match either of '*.one.com', 'one.com'",),))
                                            -->End of Python script error report<--
Pages: 1 2 3