Kodi Community Forum

Full Version: CBC TV (Canadian Broadcasting Corporation)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
Thanks for looking at this. So far I haven't had any luck with Google but I will keep looking.
Not sure if this is related but the laptop I am using Kodi on has an old AMD processor with shared graphics memory(6 years old). It is connected by HDMI to an lcd TV

Brand
HP
Series
Pavilion
Model
dv7-6113cl
Part#
QE360UAR#ABA
Quick Info
Operating System
Windows 7 Home Premium 64-Bit
CPU
AMD Quad-Core A6-3400M 1.4GHz
Screen
17.3"
Memory
6GB DDR3
Storage
750GB
Optical Drive
DVD Super Multi
Graphics Card
AMD Radeon HD 6520G
Video Memory
Shared memory
I am not sure if this will help but I will try and install ffmpeg
(2018-07-30, 03:47)SpottedDog Wrote: [ -> ]I am not sure if this will help but I will try and install ffmpeg
It won't. Its built into Kodi. Can you try a nightly build?
(2018-07-30, 03:56)micahg Wrote: [ -> ]
(2018-07-30, 03:47)SpottedDog Wrote: [ -> ]I am not sure if this will help but I will try and install ffmpeg
It won't. Its built into Kodi. Can you try a nightly build? 
Thanks for the suggestion. It works fine now. The addon is much appreciated
hello micahg,

It appears I am having a similar issue to WildPhydeaux.  I have tried deleting the contents of the addons folder as some have suggested in this thread.  I haven't tried bitrate selection or auto bitrate selection as you suggest in post 132, because I don't know where that setting is!
I also haven't tried the special branch you suggest in post #132
However, as far as I can tell from the logs, the ffmpeg keeps trying to connect and fails, for reasons that elude me ( similar to WildPhydeaux).  The only thing I can see is that the people with problems may all getting the streams  from cbcvott-a.akamaihd.net (at least 2 are) whereas the live working streams come from cbclivedai5-i.akamaihd.net.

I am using the latest Kodi and CBC add-on as of today.

Live programs and channels work, none of the shows on demand do that I've tried.  Really weird is that some of the shows that I tried to stream that I have never watched ask if I want to start at 13.44 or restart at the beginning.

log

https://paste.osmc.tv/edasonewon.xml

thanks for your  help.
Yeah, I haven't updated here for a long time but the addon works about 10% of the time for me at best.

Cheers,
Robert
Is that true of the live channels/programs as well as on demand shows or just one or the other?

I don't know how the CBC works - since they ask for your postal code I wonder if they direct you to a server for your "area". If you have access to another email account you could try signing up for another CBC account with a Toronto postal code and see if that makes a difference.  If they use your IP address then it won't make any difference.
(2018-09-12, 03:56)boleroweevil Wrote: [ -> ]Is that true of the live channels/programs as well as on demand shows or just one or the other?

Live Channels work zero percent of the time for me. The other program material works on rare occasions, mostly it just fails to load.

Good thought about the area code possibly being tied to "local" servers, however the Android CBC app on my mobile phone works 100% of the time.

Cheers,
Robert
That's interesting - after a recent update to, I think,17.6, live channels and programs began working for me, a least the couple of times I tried but on demand shows do nothing, ever.

Your Android version almost certainly uses a different format of stream and possibly server.  I'm no expert but I'm pretty sure Android doesnt support ffmpeg without some pretty serious workarounds.  CBC webstuff didn't work at all in any Android browser until pretty recently so you had to use the app.  That's changed now but obviously they are flipping the formats around.
That's probably why your Android works all the time - the problem I'm having with cbc seems to be related to not being able to negotiate a connection in ffmpeg.
Hi Micahg, All recorded CBC TV shows are working very well for the exception of Still Standing as of a couple of weeks ago. The error message says to have a look at the log. Here is the log portion that I think could be related to this issue. When you have time pls have a look at the attached log and see if you can get this particular TV show running again. Thanks

21:22:24.951 T:140470504466176   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IndexError'>
                                            Error Contents: list index out of range
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.cbc/default.py", line 235, in <module>
                                                showsMenu(values)
                                              File "/storage/.kodi/addons/plugin.video.cbc/default.py", line 152, in showsMenu
                                                show_list = shows.getShows(url, progress_callback = prog.update)
                                              File "/storage/.kodi/addons/plugin.video.cbc/resources/lib/shows.py", line 116, in getShows
                                                tags = self.getShow(item)
                                              File "/storage/.kodi/addons/plugin.video.cbc/resources/lib/shows.py", line 79, in getShow
                                                tags['url'] = item.getElementsByTagName('link')[0].firstChild.nodeValue
                                            IndexError: list index out of range
                                            -->End of Python script error report<--
21:22:25.148 T:140472348133056   ERROR: GetDirectory - Error getting plugin://plugin.video.cbc/?image=https%3a%2f%2fi.watch.cbc.ca%2fp%2fcategoryThumbnails%2ff3ed9de1-7e46-4515-9f5b-4eeaf62c056b.jpg&menu=Shows&smil=https%3a%2f%2fapi-cbc.cloud.clearleap.com%2fcloffice%2fclient%2fweb%2fbrowse%2f8936f1dc-be23-43ee-84db-58279f88c7f4&video=None
21:22:25.149 T:140472348133056   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.cbc/?image=https%3a%2f%2fi.watch.cbc.ca%2fp%2fcategoryThumbnails%2ff3ed9de1-7e46-4515-9f5b-4eeaf62c056b.jpg&menu=Shows&smil=https%3a%2f%2fapi-cbc.cloud.clearleap.com%2fcloffice%2fclient%2fweb%2fbrowse%2f8936f1dc-be23-43ee-84db-58279f88c7f4&video=None) failed
Using OpenElec with Kodi 15.

Whenever I try installing this plugin directly from the zip or from the repository, it errors out before it connects.

It displays "Authorizing 100%" then errors out

The Log displays (truncated, I have it on my cubox pro so I'm paraphrasing where the error text is displayed. If more information is required I'll figure out how to access it remotely through the network)

Error: GetDirectory - Error getting plugin://plugin.video.cbc/

This is then followed by a slew of other "Notice xxx start, auto delete: false" statements"

I've created a CBC account, I just don't know where to login

EDIT: Figured out where the settings are (they weren't accessible on the skin I had enabled) and logged in. Same error. logged out, deleted the plugin information as suggested, logged back in, relaunched the plugin, same error.

Thanks in advance!
The CBC TV Plugin v4.x does not work with the older Kodi 15.x.  See this earlier post.
Using Minix U1 Android CBC live and on demand has worked fine for me since day one. It does take a while to open.
Hello,

When I try to view the episodes for "The Great Canadian Baking Show", the plugin dies. The log contains "list index out of range".

This particular show has an episode 0 in season 2 which might be significant, but I haven't looked to verify this.

Thanks
Hi @drew.b -- I've found the problem. I'll upload a fix tonight.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18