Kodi Community Forum

Full Version: CBC TV (Canadian Broadcasting Corporation)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
Sure. If you can get a log I'll have a look. We probably will need debug logging, which will take up a lot of space...
OK I had to create a GitHub project https://github.com/pteeson/CBC_logs because the Debug file is ~29MB which is too large to paste anywhere.
So there are 4 files: kodi.old.log, KodiP1.txt, KodiP2.txt. KodiP3.txt. The txt files start from when I did a new launch of Kodi after turning on debugging, including components. (FFMPEG, Audio, Video).

Then I ran the CBC TV add on and selected the News Network show (NN). I let it run until it froze.  P1 around 19:48 is when it started. It froze around 19:57:13: which is in KodiP3.txt

2019-03-08 19:57:13.329 T:1753998064   DEBUG: CWebServer[8080]: request received for /jsonrpc
2019-03-08 19:57:13.547 T:1487418096   DEBUG: Previous line repeats 2 times.
2019-03-08 19:57:13.552 T:1487418096 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
2019-03-08 19:57:13.885 T:1538036464   DEBUG: AddOnLog: InputStream Adaptive: Begin WaitForSegment stream
2019-03-08 19:57:13.930 T:1753998064   DEBUG: CWebServer[8080]: request received for /jsonrpc
2019-03-08 19:57:13.986 T:1538036464   DEBUG: AddOnLog: InputStream Adaptive: Begin WaitForSegment stream
2019-03-08 19:57:14.063 T:1487418096 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
etc etc etc

I hope this works OK for you because I couldn't think of any other way to get the logs in their entirety to you.
Let me know if you have difficulty reading the GitHub project....

PHT
I am currently running Kodi Leia 18.0 RC 4 with the CBC add on 4.0.6.

Starting last Wednesday, the add on freezes after 6 minutes of playing.

Then you have to restart Kodi for an additional 6 minutes.

If I change the add on settings to use FFMEPG, the freeze does not occur.

What changed last week?
As a free subscriber CBC sent an email to me around Mar 1st saying they would be updating the streaming facility (I think on the 4th Mar).
Did you also get one?

Issue details in my previous 2 posts. Looks like you have also got it.

As you can see I setup some debug logs for micahg to take a look. Meanwhile like you I'm using  ffmpeg as per the Settings option.

We must wait to see what, if anything, micahg discerns from the full logs. The snippet I posted shows the freeze very clearly - timing out waiting for buffer.
Well, even if I am using FFMEPG, only on the CBC add on I am getting a lot of tearing and excessive jiggle on the video portion. There seems to be a general buffering problem on the stream. Any word on the analysis of your logs?
Sorry all,

Out of the country and not able to do analysis. I'll look as soon as I'm home next week.
Hi,

Looked through the logs and there isn't anything I can see ... what are you trying to play? I haven't had any luck reproducing here yet.
Thank you @micahg for maintaining this addon.

I too experience pauses in playback when using the CBC v4.0.6 addon on LibreELEC 9.0.1 (Kodi 18.1).

If I use the CBC v4.0.4 addon on LibreELEC 8.2.3 (Kodi 17.6) the playback is perfect with no pauses.

Interestingly I also see similar pauses with the HGTV addon v3.0.12 on LibreELEC 9.0.1 whereas these do not occur with the same addon (v3.0.12) on LibreELEC 8.2.3.

I wonder if something common to these two addons changed.  Perhaps in the InputStream Adaptive addon (just a guess) which changed from v2.0.20.0 to v2.3.15.1 in LibreELEC from 8.2.3 to 9.0.1?

FYI:  I'm using Raspberry Pi 2 / 3 for these tests.

If there are additional tests you would like me to run, or logs to create then please let me know and I'll see what I can do to help identify the cause of this pause issue.
Where can I download (for sideloading) a copy of 4.0.4 so if i can see if it measurably improves the  two problems (probably buffering) that I am experiencing with 4.0.6 (see problem descriptions above).
Enabling ffmpeg should have the same effect
Unfortunately it doesn't. I had to enable ffmpeg already, otherwise version 4.0.6 is almost unwatchable. It will run for only 6 minutes before it freezes. See my description on a previous post. So, something has changed that makes 4.0.6 unwatchable with or without ffmpeg enabled.

I would like to try some previous versions to see if any work well without buffering issues.
@steveottawa double-checking -- falling back to ffmepg does still work, as your original post indicates, yes?

If so, I think those of you having trouble will just have to stick with ffmpeg fallback for now until I can figure out/reproduce your issues with inputstream. If anyone else wants to chime in here, I'd appreciate if someone could maybe narrow it down to a platform issue.

In my house I have a linux desktop, a "me box" (android) and a firestick (also android). These changes seem to work fine for all my machines, but I don't have a libreelec machine. If anyone has a mixed environment (even a windows machine running the new addon and a libreelec machine) I'd love to know if _only_ the pi-based systems have trouble.

The addon doesn't actually playback anything -- it just scrapes the website for the stream address and hands it over to kodi to play (indicating which player to use).

Thanks in advance!
Thanks @micahg for continuing to investigate the problems with stream pauses and this addon.  Being a developer myself I know how frustrating it can be trying to isolate the root cause of issues.

Yesterday I did some more testing with the CBC addon.

In an effort to eliminate some of the variables I used the same Raspberry Pi 3 model B+ with the same microSD card with LibreELEC 9.0.1 and the same TV.  In each test I tried to stream a TV show with Closed Captioning (CC) enabled.

TEST STEPS
----------

1. First I deleted the ~/.kodi/addons/plugin.video.cbc/ folder, restored a v4.0.4 one I had from backup, and streamed a show.

2. Next I manually invoked the upgrade to CBC v4.0.6 and choose FFMPEG in the configuration options and streamed another show.

3. Finally with the same CBC version and configuration options I streamed a third show.

4. This morning I deleted the ~/.kodi/addons/plugin.video.cbc/ folder, restored a v4.0.4 one I had from backup, and streamed several minutes of the same Working Moms show from step 2.

Following are the results:

STEP   CBC      TV SHOW                  OBSERVATIONS
----   ------   ----------------------   -----------------------------------

 1.    4.0.4    Kim's Convenience: S03   Video played flawlessly,
                - Appanticitis           CC displayed correctly.

 2.    4.0.6    Working Moms: S03        Video played flawlessly,
       FFMPEG   - Business Boyz          CC not displayed correctly.

 3.    4.0.6    Kim's Convenience: S03   Video paused after several minutes,
       FFMPEG   - Elephant in the Room   restarts skipped sections of show,
                                         CC displayed correctly.

 4.    4.0.4    Working Moms: S03        Video played flawlessly,
                - Business Boys          CC not displayed correctly.


Based on this very small test sample I hypothesize the following conclusions:

A. The "Working Moms: S03 - Business Boyz" TV show has something wrong with it's closed captions.

B. CBC v4.0.6 does stream with less pauses when FFMPEG is enabled than when it is not enabled; however, it still experiences pauses when CC is displayed.

C. CBC v4.0.4 streams flawlessly with no issues.

With the above being said, it is quite possible that other outside factors are at play as well, such as network congestion while streaming these TV shows.  Further I am not a heavy user of the CBC addon and generally only use it to view TV shows that I missed Over-The-Air.  Hence the time I've spent streaming shows with the CBC addon is limited.  So far from my limited time I have not experienced any pauses in playback when using v4.0.4.
OK, I agree that there are too many variables.

So I propose a simple test to use a fresh install of 4.0.6 without any changes or options and select CBC NN News.

When I do this, on Kodi 18.1, the program runs for 6.5 minutes and then freezes.  The quality of the program until that point is perfect.

Others have commented on this behaviour. Can you duplicate this behaviour?

Shouldn't that be an easier behaviour to resolve?

And I am still looking for a version of 4.0.4 that I can download.
@steveottawa I do not have the ".zip" file used for installing the CBC v4.0.4 addon.  I only have a backup of my entire Raspberry Pi microSD card.  Using this I have been restoring the "~/.kodi/addons/plugin.video.cbc/" folder which has the older v4.0.4 copy of the CBC addon.  You might try getting the appropriate files from the git source code.

@micahg you might be onto something regarding the platform being related to the issue with pauses when streaming TV shows.

Early this afternoon I performed the following test steps.

1. On a Pentium 4 (3.0 GHz) computer running Xubuntu 18.04 I installed kodi using the following commands:

    sudo apt-get install software-properties-common
    sudo add-apt-repository ppa:team-xbmc/ppa
    sudo apt-get update
    sudo apt-get install kodi

2. Installed the CBC v4.0.6 addon.

3. Enabled Closed Caption parsing.
     System (gear icon) > Player settings.
     Change Settings level from Standard to Expert
     Language > Enable parsing for closed captions.

4. Enabled InputStream.Adaptive.

4. Played "Kim's Convenience: S03 - Elephant in the Room".
   Video played first 11 minutes smoothly [A], no pauses.
   Closed Captions displayed properly.

5. Enabled FFMPEG in CBC addon configuration options.

6. Resumed playing "Kim's Convenience: S03 - Elephant in the Room".
   Video played last 11 minutes smoothly [A], no pauses.
   Closed Captions displayed properly.

[A] Observed screen tearing probably because no compositor installed.

                       PENTIUM 4               RPI3 B+
COMPONENT              XUBUNTU 18.04           LIBREELEC 9.0.1
--------------------   ---------------------   ---------------
Kodi                   18.1+git20190217.1232   18.1
InputStream.Adaptive   2.3.15-1                2.3.15.1
Linux kernel           4.15.0-45               4.19.23



QUESTION

Is there a reason why the CBC v4.0.6 addon won't run on Kodi 17.6?

The reason I ask is that I do have InputStream.Adaptive v2.0.20.0 installed on Kodi 17.6 on an RPi.  I could try manually installing CBC v4.0.6 on a RPi if that would help with troubleshooting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18