Kodi Community Forum

Full Version: Library title problem.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi (I'm a newbie)

I have a standard installation of Kodi 17.6 on a Raspberry Pi3 (Stretch) with Pixel desktop. (Don't know for sure, if that's what it's called)

I have some chinese movies, (on a FTP server) that are shown/named with chinese characters in the movie library. 
If I go into 'info' and press 'refresh' I can choose the correct english title, but when Kodi updates, it still chooses the chinese version.
Example. The movie CJ 7 is named 長江七號

I have tried to remove and rebuild the library a couple of times, and changed naming settings in the scrapers. But nothing have helped.

Any hints?

Thank you
Hello Whoppers

I am assuming you are using the TMDB scraper. You mention "changed naming settings in the scrapers". Have you also tried changing the Language setting in the scraper settings page? Should be the fourth option from the top.

Image
Also as an afterthought...

When you modify your scraper settings. you must make the changes on the Source using Change Content from the Context Menu when highlighting the Source.

Do not make changes through the Add-ons menu option. This only sets default options and will not change existing settings attached to Sources.
Hi Karellen

Oh. Forgot to tell that. Language is set to 'EN' And i've also tried ON and OFF at 'Keep Original title'
And yes, i'm using the TMDB scraper. All Fanart settings are set to OFF

Oh, i'll check up on your afterthought...

Thank you
Hi again.

I checked scraper settings as you described. And they were set as previously posted.

But I noticed something else. If I browse via 'Video - Files - FTP movie folder' the movie name is listed correctly. And if I update, it will fetch the chinese version, but keep the CJ 7 title.
And it's still listed in chinese in the 'Movie' library.

Thank you.
(2018-02-19, 23:42)Whoppers Wrote: [ -> ]If I browse via 'Video - Files - FTP movie folder' the movie name is listed correctly
I assume you have your folder named as CJ 7 in English. Viewing from Videos>Files>Source is just a file browser and simply displays what is on the hard drive.

So, now we are at the point of requiring a Debug log (wiki). Can you remove the CJ 7 movie from your library. Then run a Clean Library from Settings>Media Settings>Library. Then...

Enable debugging in Settings>System Settings>Logging, restart Kodi then replicate the problem. In your case, scrape the movie. Once done upload to https://pastebin.com/ or https://paste.ubuntu.com/ and link back here. Note: Full logs only. No partial or redacted logs

Then we can see what is happening during the scrape.
Hi Karellen

Well, I've my movies in only one folder, called movies. Smile

I'll get to work on your suggestions. Will report back tomorrow.

Thank you.
(2018-02-20, 00:04)Whoppers Wrote: [ -> ]Well, I've my movies in only one folder, called movies.
Ok, so you have all your movie files in one folder named "Movies" instead of one folder for each movie which are all stored in "Movies". Understand. So that means you have named the video file in English as CJ 7. And that is what you are seeing in Videos>Files.

I'll look out for the log when you post.
Hi again

Hope this is enough. https://paste.ubuntu.com/p/ndwqRGZwMK/

It also shows another problem I got. When I have danish characters æ ø å in the title, they will not update when I choose 'Info' - 'Refresh'
Kodi just exist to the movie list.

Thank you.
@olympia

Why is the scraper returning Title and Original Title with the same info? Shouldn't the Title be "CJ 7" and the Original Title be the Chinese title?

<title>長江七號</title><originaltitle>長江七號</originaltitle><year>2008</year>
@Whoppers

Can you post a screenshot of the scraper settings you used. Same as my screenshot as in post #2 above
(2018-02-20, 22:20)Karellen Wrote: [ -> ]@olympia

Why is the scraper returning Title and Original Title with the same info? Shouldn't the Title be "CJ 7" and the Original Title be the Chinese title?

<title>長江七號</title><originaltitle>長江七號</originaltitle><year>2008</year>
 Guess because "Keep Original Title" is enabled?!
Just tested and works fine for me.
(2018-02-19, 23:13)Whoppers Wrote: [ -> ]And i've also tried ON and OFF at 'Keep Original title'
I'm only going by what the member states. I've asked for a screenshot.
(2018-02-20, 22:49)Karellen Wrote: [ -> ]
(2018-02-19, 23:13)Whoppers Wrote: [ -> ]And i've also tried ON and OFF at 'Keep Original title'
I'm only going by what the member states. I've asked for a screenshot. 
You don't want me to evaluate the member statement, right? Smile
(2018-02-20, 22:49)Karellen Wrote: [ -> ]
(2018-02-19, 23:13)Whoppers Wrote: [ -> ]And i've also tried ON and OFF at 'Keep Original title'
I'm only going by what the member states. I've asked for a screenshot. 
Yes. I'm sure I tried both settings.  (But evidence point the other way. Smile  )

But I have just installed the Universal Movie Scraper, and that did the trick. No more chinese names.

Now, I only have trouble with my danish special characters, I'll try to sort that out later.

Thank you for all your help.