Kodi Community Forum

Full Version: Please help - 4K Mp4 Stuttering on Kodi 17.6 for Linux
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i'm attaching a log which i captured few hours ago:

Kodi Log

I'm running Kodi 17.6 on Ubuntu 16.04, which is running on a HP G8 server with 16gigs of ram and a 2 core Xeon processor. I have added a Nvidia GT630 64 bit video card. My HDMI signal goes from the video card to my receiver and than to the TV. I've also attached a Pulse8 HDMI CEC dongle. I have set Kodi to run as soon as the server starts and it goes directly to it without going through any other user environment. This is my basic setup, i believe more information could be found in the log.

My problem is with "4K" MP4 files "produced" by a Panasonic G7 camera. They are with 3840 x 2160 which obviously exceeds my FHD output but i don't think this might be an issue. As soon as i start such video it start stuttering. It stutters so bad that it's unwatchable. Sound on the other hand is ok, the issue is only with the picture. I searched for similar threads, based on what i found i played with my hardware decoding options (VDPAU and VAAPI), i tried switching between them or completely turning them off. I also tried playing with the cache through the advancedsettings.xml file, but i cannot say anything made the video play better or worse. the clips i'm trying to view are running fine on other devices so i'm sure the issue is not with the files. i'm also sure that Kodi can read them fast enough since i've put them in one of the server's HDDs, so there's no LAN streaming and no USB bottleneck. 

i also noticed that sometimes there's a slight stuttering when i'm watching particular 1080p TV rips which are about 4 GBs per 44 minutes and are in .ts format. everything else is running just fine. on the other hand i'm able to watch a 25gb 1080p bdrip movie in .mkv format without any stuttering. what could be the issue? bad codec? of weak hardware (the 64 bit video card)?
Hello d_ave

Two issues...

1. You have not enabled Debug Mode in Settings>System Settings>Logging
2. You have banned add-ons installed.

The forum moderators have determined that Banned_addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
Make sure, you set the scaling (while the video is playing) from Auto to bilinear. 17.6 would choose Lanczos3 which the GPU most likely is too slow to downscale.

But we will see that from your Debug Log.
i'm sorry but i didn't realize there are such things as banned addons. i removed the extra repos i have once installed - is this enough?

fritsch, i checked the scaling while the video is playing and it's on bilinear.

here's my new log - it turned out quite big so i used paste.ee since pastebin didn't allow me to paste a log larger than 512kb. i hope it's ok. sorry 

kodi debug log

i hope i'm not breaking any other rules, please let me know and i'll fix it right away.
Quote:10:54:26.814 T:139961343355264  NOTICE: GL_VENDOR = nouveau
10:54:26.814 T:139961343355264  NOTICE: GL_RENDERER = NV108
10:54:26.814 T:139961343355264  NOTICE: GL_VERSION = 3.0 Mesa 17.2.8
10:54:26.814 T:139961343355264  NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.30

You run the wrong drivers. You need the nvidia binary blob. Make sure you install libvdpau also. Kodi will then hw accelerate H264, HEVC(8bit) and others.
I installed the nvidia proprietary driver which removed nouveau. once i rebooted it booted to a black screen but after a second reboot i get into Kodi and this time the videos play without stuttering which basically eliminated my issue.


now i have a new issue which was probably the cause for the usage of nouveau instead of the nvidia proprietary driver. i'm using remote desktop to manage my server from my windows laptop. i have KDE/Plasma running as a desktop environment which was running just fine with the nouveau driver when i was connecting using remote desktop. now when i try to connect Plasma is not loading with the following error:
 plasma is unable to start as it could not correctly use opengl 2.  Please check that your graphic drivers are set up correctly.

Aparently there's some issue with the OpenGL support after i installed the nvidia driver. any way to fix this?
No idea. In Linux world one does not use remote desktop but ssh.
Well, i believe in Linux world one use whatever is possible, as soon as it's working. I'm pretty sure i will make it work properly. for the moment i'm back to MATE - welcome back old daysSmile thanks a lot for the help, i tried playing different files which were stuttering before and now everything plays fine.