Kodi Community Forum

Full Version: Multiple (
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Having a new issue and I'm not sure what I changed. I'm running Kodi 17.6 on Ubuntu 16.04 on an HTPC (intel / nvidia box). I have a harmony 300 universal remote and am running CEC through the Panasonic TV I have. Most of the time, this works. We'd had a problem in general that sometimes button presses were recognized as being hit twice (about every 3rd time we pressed something, but it wasn't the biggest annoyance). 

Recently, though, the "back" button started getting recognized as always being hit multiple (more than 2 times). Logs below suggest it hit 7 times (with action taken at least 4 times to go back). I know Kodi used to have a way of not recognizing a second press until some number of milliseconds, but new Kodi doesn't. I'm not at all sure why it's receiving it with three "real" durations of 23, 206, and 451ms, but it appears that action is taken when it gets a "0" duration keypress. 

https://paste.ubuntu.com/p/ZNjnWhKSZZ/

I'm basically not sure where to go from here. I've updated all my Ubuntu packages to give that a shot (this log is a result of that). To compare to a "good" press (the "ok" button which is set to the select button)

https://paste.ubuntu.com/p/74Ztc6pd6s/

The "play" button still double presses now and then, which is mildly annoying, but not terribly so. It's the back button being hit 4 times that's making me want to fix the problem. Any ideas where to look or what to fix? 

I'll note that this problem appears to be with the TV itself or the remote, no question. If I'm in menus in the TV and press the back button, it's the same behavior. I expected a way to fix it in Kodi, though, since there's likely no way to fix the TV or the remote (I would guess).

Thanks!
Well, I can't figure out how to delete this post (don't seem to be allowed), so I'll comment as to what my "fix" was. 

I still get some multiple button presses and would love to set a higher delay (300ms or so?), but the pressing many times on just the back button has been fixed. I did two things.

1) In the Harmony, I set the "repeat" to zero instead of 1, though I don't think this actually mattered.

2) I changed the Panasonic function being sent to "Return" instead of "Last". That fixed it for both the TV menu and the Kodi so it only goes back once (unless it registers a double press).