Kodi Community Forum

Full Version: cannot mount NFS
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there!
I have a NFS shared accross home network on my CentOS 7.3:
Kodi compiled Feb 25 2018 by MSVC 191225835 for Windows NT x86 64-bit version 10.0 (0x0A000004)

cat /etc/exports

showmount -e
Export list for master.home.lan:

Server debug logs doesnt says much neither Kodi debug log:

14:03:56.282 T:176 ERROR: NFS: Failed to mount nfs share: (nfs_service failed)
14:03:56.282 T:2304 ERROR: XFILE::CDirectory::GetDirectory - Error getting nfs://
14:03:56.282 T:2304 ERROR: CGUIDialogFileBrowser::GetDirectory(nfs:// failed
14:05:27.412 T:2304 NOTICE: NFS is idle. Closing the remaining connections.

The same share works on other linux machine (ubuntu) with kodi
insecure flag is missing in exports
no luck with insecure flag as well Sad
Read this if you haven't already to make sure it's configured right https://kodi.wiki/view/NFS#NFS_sharing_from_Linux
config is right, i can access it from other kodi instances ( windows and linux ) but not from xbox
i used sftp as a workaround now
I have the same issue.
how you managed to use sftp?
I could only use ftp but is not efficient
I have gotten this to work with nfs from both nas4free and openmediavault. From nas4free it just worked right away I think. Didnt have to do any special settings. On openmediavault I had to add some settings. Used the following flags: insecure,no_subtree_check,all_squash. And I gave rw permission on the shared folder to the 'nobody' user. This might be a bit sketchy security wise. But it worked.