Kodi Community Forum

Full Version: Out of Sync Playback on Firestick
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When playing my backed up movies (from 2 different NAS sources) they mostly play perfectly, but something like 1 in 10 files do not play properly - the video is not smooth and the sound, although clear, is wildly out of sync. The problem isn't related to one particular NAS. I even tried copying one troublesome movie file to the other NAS - the problem stays with the file. The weird thing is the troublesome files play perfectly through my Oppo BluRay player. The files are uncompressed DVDs and BluRays ripped using MakeMKV software. I'm using KODI 17.3 on a 2017 firestick. The problem doesn't seem to be related to file size - a 33Gb bluray will play smooth as silk, whereas a 4Gb DVD will be totally unwatchable.. What could be causing this issue? More importantly what can I try to fix it?
Further to my initial post above, I'm finding the issue is much worse than I thought. It appears that many of my .mkv files won't play properly through KODI (I checked to see if the files play properly through my Oppo - and they do).
In all cases where I'm experiencing the problem, the video runs in juddery slo-mo, consequently, as the audio seems to run at the correct speed, the AV sync gets wildly out - several seconds. Does this sound familiar to anyone?
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
Thanks for your reply DaVu

My first time at this, but hey - I've got a debug log for you, it's at....

Hoping you can figure out what's going on - fingers crossed ;-)
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
Wow - This is news to me. I was completely unaware that I have such add-ons. I certainly do NOT want/need any add-ons other than those required to play my backed up discs. I'm trying to use KODI SOLELY  to play my own video files. Please advise me what these rogue add-ons are, where to find them, and I will remove them immediately.
These repo's and all the add-ons they contain...

12:42:23.551 T:18446744072498294880 NOTICE: ADDONS: Using repository repository.elysium
12:42:23.552 T:18446744072498294880 NOTICE: ADDONS: Using repository repository.smash
12:42:23.552 T:18446744072498294880 NOTICE: ADDONS: Using repository repository.origin
You were right Karellen - I searched and found the 3 offending AddOns and, to the best of my knowledge, have uninstalled them. Please advise me of any more undesireables you find on my system.
And so, having removed the aforementioned, I once again tried to play one of my files which plays flawlessly on my Oppo but not on my 2017 FireTVstick. The issue remains.
Here is the debug log... http://ix.io/Xwr
Your help is much appreciated.
As I said earlier, quite a few of my files (all .mkv's) are affected and so if more debug logs are required - just ask and I will furnish same.
To re-cap, the affected files, when played, the video does so in a choppy/juddery slow motion fashion, but the audio plays fine at normal speed. Every so often, it seems a resync occurs, but rapidly goes out of sync again. Affected files play perfectly through my Oppo...
I've got a baaaad feeling about this issue..... in the light of no suggestions, I think I better start keeping an eye on 2nd hand Oppo BD network players ?!! (Kodi is in a different room to my Oppo system - but hard-wired to my gigabit network))
I have to confess to being more than a tad disappointed at the total lack of response from KODI experts. Someone clearly did, initially, have a look at my debug log, stating that I had those banned addons. I subsequently removed said addons (I never used them anyway) and submitted what I thought was a "clean" log. Have I been dismissed as unworthy of a response? Did I submit the log incorrectly? I don't know.
Anyways, I've done a bit of my own research, and have found the issue is likely due to the authoring of the Blurays in question...
I have re-ripped some of the discs whose ripped files were exhibiting exactly the same KODI playback issues. In all cases the playback issue (juddery/frame drop slo-mo effect) remained. There has to be something glaringly obvious in the log concerning this issue. The odd fact remains that all my files play correctly through a network player.
However, I found that if I used "Handbrake" on the trouble some files, the issue completely goes away. One problem of course is that it takes around 5 hrs to handbrake a 25Gb bluray and so is far from a perfect solution (not to mention resolution loss!).
I'm not giving up hope that someone can throw some light on this issue.
Thanks in anticipation ;-)
Looking forward to a reply over the weekend - but I'm not holding my breath !