Kodi Community Forum

Full Version: Video render issue in scenes with background vertical line pattern
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This is a difficult issue to describe, and I cannot provide a screenshot as every attempt I've made to get one have failed (screenshots rendered correctly).

When there is a background consisting of a vertical pattern of lines and the camera is tracking horizontally with an object moving horizontally in the foreground, the vertical lines in the background become distorted or merge with the foreground object. The issue is more obvious when the foreground object is moving more quickly.

As an example, consider the scene in The Last Jedi where Kylo Ren smashes his helmet. Here, we have a background consisting of vertical black and white lines, and an object in the foreground that is moving horizontally.

On the same system (see below), VLC will render the video image without issues.

My system setup is:

Windows 7 Home Premium SP1 x64
Intel i3 4330 processor
Asus H871I-Plus motherboard
GeForce GT 1030 graphics card (recently added)

Marantz SR5003 AV receiver.

Kodi 17.6

Aero is disabled. Default screen resolution is 1080p @ 50Hz, but with the option in Kodi set to change refresh rate as required.

A friend has the same file and it plays fine on his Android TV.

I've uploaded the relevant part of the debug log here. This is the log after choosing Play to just before entering the menu to stop play. There are 2 instances where I go back 10 seconds to get to the correct point in the file. Log level is set to Normal. If more of the log is required, please let me know.

I've had this issue for as long as I can remember. I initially thought that it was due to having no graphics card and using the CPU to render video, hence the recent addition of the graphics card (yesterday). However, this has not resolved the issue.

If you need any further information, please let me know.

Thanks in advance for any assistance provided
I don't see anything relevant in the relevant log. Please help me.
(2018-03-21, 08:07)fritsch Wrote: [ -> ]I don't see anything relevant in the relevant log. Please help me.
 I've posted the complete log here.

Is there any way to get more information into the log? Would it help if I set the log level to 2 in advancedsettings.xml?

I set debugging to component-specific 'video'. Should I not set this?
(2018-03-21, 07:00)Jeff Wrote: [ -> ]I cannot provide a screenshot as every attempt I've made to get one have failed (screenshots rendered correctly).
Perhaps you can make a photo with a smartphone instead, identifying the problem?
I don't seem to have video issues with my GT1030, although I use Linux 99% of the time. I take it your Nvidia drivers are up-to-date?
Can you also try taking out the Marantz AVR, and see if a direct connect between htpc and tv is making things any better?
You can find a photo here. You can see a strange halo around the back of his head (right of screen). He is moving to the left of the screen.

I'll try without the AV receiver and let you know.

Please note that I don't believe this to be related to the graphics card as I had the same problem before installing the card, when I was using the CPU to do all the work (no graphics card installed).

Many thanks for your help so far

Edit: Taking the AV receiver out of the loop fixes the problem
(2018-03-21, 11:26)Jeff Wrote: [ -> ]Taking the AV receiver out of the loop fixes the problem
That's ... interesting.

@fritsch Weren't you a Marantz AVR fanatic? :"-)
Maybe it's just getting old (like me).

I tried changing a few settings. It was 'converting' the video (upscaling), but turning this off didn't help. Neither did changing the output from 1080p to 'through'.

Luckily, buying the GT 1030 wasn't totally redundant as it has 2 output ports, so I can use 1 to pass video direct to the TV and the other to pass audio to the AVR.

Thanks to both of you for your quick response and help in identifying the issue. I realise now that my problem solving skills are not as good as I thought as I never would have considered the AVR to be the problem.
Can you reset the AVR? Change its cables? This looks really odd.
(2018-03-22, 07:41)fritsch Wrote: [ -> ]Can you reset the AVR? Change its cables? This looks really odd.

I tried changing the cables as you suggested, but no change.

However, I just thought I would check one more time that direct to TV is working and it seems not. So, it's not the AVR.

I'm rechecking all my settings in Kodi and windows to see if I can find anything.

If you have any other suggestions, please let me know.

I'll reopen the thread
Would it help if I did a new clean install of Kodi?

I remember when I was using version 16 (or early 17) that I tried to roll back to version 15. Obviously unsuccessful due to changes in the database structure for the library. Maybe that could have messed up something?

Rechecked VLC output using direct to TV and no issues.
If you disable DXVA2 - does it change a thing?

Edit: GeForce GT 1030 graphics card (recently added) <- can you remove it / reset the nvidia control panel settings?
Disabling DXVA2 has no effect.

Removing the graphics card also has no effect.

I previously ran the system without a graphics card and had the same issue. I purchased the graphics card because I thought the CPU couldn't handle the video processing required and hoped that it would fix the problem.
I believe I may have found the source of the problem.

In order to eliminate all possible causes, I tried a different display. I attached the small LCD monitor from my PC using DVI and there are no video issues.

So, I guess that means the issue is the TV (or possibly the DVI connection?).

I'm using a 50" plasma screen from Panasonic (TC-P50ST50). The TV display is set to 1080p (native) @ 50Hz by default. The software/firmware for the TV is up to date.

In Kodi, I've set 'Adjust refresh rate' to 'Always', with a delay of 0.5 secs. I've also checked that the refresh rate for the TV is changed by Kodi to 24Hz when playing the source.

I don't know if you have any ideas, but I can't see any way to resolve this issue without replacing the TV (which unfortunately isn't an option). Thankfully, most videos play fine, and those that do have this issue only show it in short scenes where there is fast foreground movement against a background pattern consisting of vertical lines.

If you do have any ideas, please let me know.
try turning off all image "enhancements" in the TV
(2018-03-23, 10:02)wsnipex Wrote: [ -> ]try turning off all image "enhancements" in the TV
 Great suggestion.

You're not going to believe this, but certain picture options are only visible in the menu when a specific source is passed to the TV. So, while playing 24 fps content, a secret option appears called '24p Smooth Film'. It was set to max, and now after turning this off, no more issues.

There are other options that appear and disappear at will. Very annoying. None of this is documented in my manual.

Anyway, many thanks to all who have assisted me. I would never have fixed this problem without your help.