Kodi Community Forum

Full Version: v18 - [Windows] Hardware accelerated playback is choppy unless an overlay is present
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
Note: This issue seems resolved for Intel based systems as of Beta3, or somewhere thereabouts.  For Nvidia systems, a proper fix is only currently available in a test build from afedchin here. I'm using this test build on my Intel and Nvidia systems and playback is now extremely stable.

Well this is a weird one.  After moving most of my machines over to v18 alpha/nightlies I noticed that video playback with hardware acceleration enabled was very choppy.  Not constantly but quite frequently.  Software rendering, while not perfect was far better with barely any stuttering.  I decided to collect some debug logs so I could post a new thread about it but I found that as soon as I enabled debugging, the choppiness disappeared!

Thinking that the increased CPU load and disk activity associated with debug logging couldn't possibly be helping, the only thing that's different is the overlay you get with CPU usage/framerate etc.  To test this theory, I installed MSI Afterburner which comes with RTSS.  I set it up so that the OSD was enabled for Kodi and as desired, a little GPU usage overlay appeared in Kodi.  As long as I leave this overlay enabled, hw accelerated playback is fine.  The moment I disable it, even without restarting Kodi, the stuttering returns.  Note that I am not applying an overclock with Afetburner, it seems that's not even possible on an Intel chip, this is just the overlay being enabled, nothing more.

I've resorted to setting RTSS to load at startup and then moved the OSD to the bottom right, made it black and the smallest possible font so now it's barely visible, and this has solved the problem.  This is all on an Intel NUC i3 (Intel HD4000 graphics) on Win10 1709 x64.  Any thoughts?
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
i have stuttering too since some nightly's. startet about 10.04.2018. winx64 win10 nvidia gtx950.
Just an update, I never saw this thread until now and it seems other are indeed seeing this.  I unfortunately had to ditch Windows on the NUCs in favour or LibreElec but the desktop with a 1080Ti still runs Windows and still has this problem.  The only useful suggestion I saw in the Linux thread was adjusting the Windows power plan so I've used Process Lasso to apply the Maximum Performance power plan whenever Kodi is running but it makes no difference.  With hardware acceleration on, frames get dropped/skipped all over the place.
Exact same issue here on two core i3 windows 10 x64 1709 htpc's. Booth have an 1030 nvidia gpu. With v17 dxva runs very good. After upgrade to v18 alpha, both have this problem.

Have posted in wrong Linux thread, but here is the post, with full debug log :

Hey guys.

Have made a clean install of kodi "KodiSetup-20180428-94737c2f-master-x64.exe", installed just EmbyCon (to access my media .
With default settings:
  • dont change refreshrate & sync to display disabled -> a 24fps movie is running without the stutter but every second a frame is dropped (because display 50hz <> movie 24fps)
  • dont change refreshrate & sync to display enabled -> a 24fps movie is running without the stutter @104% speed with no stutter at all -> this is my workaround for now.
  • change refreshrate & sync to display doesnt matter (tried on and off) -> the behaviour i have described with the osd
I have made two debug logs:
Will go with the workaround for now.
I have the identical issue on two windows 10x64 clients (same kodi build & same nvidia gpu)
Can you please look at it (maybe @FernetMenta  & @afedchin )

Anyone of you using an earlier build which is working?
If yes, which one?
I was never able to reproduce this behaviour on my system. In the meantime my Windows system got broken and scrapped. Sorry, but I think I can't help here.
(2018-05-15, 18:30)FernetMenta Wrote: [ -> ]I was never able to reproduce this behaviour on my system. In the meantime my Windows system got broken and scrapped. Sorry, but I think I can't help here.
That's bad that your windows system is broken. Is there any other kodi dev member we can ask for help?

Can we help to find the issue with additional logs?

Did you saw an issue in the logs I'll posted, didn't saw anything, but my knowledge is limited

Have made a trac ticket here https://trac.kodi.tv/ticket/17879
I can help to debug if you can provide a debug build with more debug messages around the dxva code.

please help to fix this issue
i am also having this issue, which I described here: 2724203 (post)

I'd be happy to help the devs debug this, but I agree that we need a different build that allows for better DVXA debugging
(2018-05-21, 16:52)JoshDi Wrote: [ -> ]i am also having this issue, which I described here: 2724203 (post)

I'd be happy to help the devs debug this, but I agree that we need a different build that allows for better DVXA debugging
Here's a testbuild: https://trac.kodi.tv/ticket/17879

Can you please test it, in my case it crashes, if it's crashing in your case also, please post a debug log in the thread.

This issue sounds very much like this one, which @FernetMenta was able to fix when v17 was under development:

299115 (thread)

Has this somehow jumped back to V18?
(2018-05-23, 07:34)goodton Wrote: [ -> ]Has this somehow jumped back to V18?
 Seems so. New strategy was implmenented that replaced the old code.
(2018-04-10, 02:43)JoshDi Wrote: [ -> ]I am having a similar issue on my Windows 7 x64 machine running Kodi x64 KodiSetup-20180408-ff02b71b-master-x64.exe. This seems to happen only with content that is 720i or 720p - 1080p or 1080i content runs fine.

If I turn off "Sync playback to display" the issue goes away. This issue has been present since Alpha1 for me, but I have not had an issue with my initial v18 or previous versions (<v17) of Kodi. 

If I pause the video, as you can see in the sample video below, the video continues to play at the wrong speed. 

Any ideas? 

Sample Video of Issue: Sample Playback mp4Debug Log: https://pastebin.com/uUYC59AY

If I turn back on "Sync playback to display" and turn off DXVA2, all content plays as expected. If I turn on DXVA2, content that is less than 1080p has the issue in my OP above.
@JoshDi and others with this issue.

@afedchin has reverted an commit which maybe is the cause of our dxva issues.

Please try upcoming nightly (25.05.2018) and report back here.

Would be nice if you could also add the info to your test results, which gpu and drivers you are using.

Pages: 1 2 3 4 5 6 7