Kodi Community Forum

Full Version: Titan M O D ( last Updated 24-04-2019)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2018-12-09, 17:42)E net Wrote: [ -> ]
(2018-12-09, 15:05)mardukL Wrote: [ -> ]
(2018-12-08, 21:36)E net Wrote: [ -> ]OK thanks but
1. doesn't work. If you are in Netflix mode then click on the movie to get to the video information page. If you change the video information page to FanArt then you can't get to the options Slide menu by pressing down. Nothing happens.

2. I tried the custom path, it works but then the fan art on the Netflix page still doesn't change. It just chooses fanart1 then blinks as if it is trying to change the image.

Sorry Wink one more thing. When choosing posters etc in Artwork Beef why do they take so long to appear then they disappear? I am sitting here right now in front of the screen and the posters are not appearing even after waiting for more than 5 minutes. Eventually you may get the jigsaw and then after that you "may" get some pictures. But even if they do appear they disappear again afterwards.
Sorry again and thanks Smile    

Ah, ok.
1. Slide side menu:
Can you eneble "quick alphatet navigation" in
Skinsettings-library settings (fanart view miss the custom ondown if its not enebled) but the other views should work independent .

2. Artwork i didnt had issues last time.
I need to take a look.
But the next 2 - 3 weeks i will not have any time to work on the mod, just looking in the forum frequently.
Quote:Note and reminder, thats part variable used for extra fanart, so its clear its actual depending to sknhelper, not artwork beef/artwork download.
need look on that in future

 <!-- normal extrafanart -->
       <value condition="Skin.HasSetting(SkinHelper.EnableExtraFanart) + !String.IsEmpty(Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt))">$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]</value>
I already have quick alphabet navigation enabled. Once you go into the Video Information page you can click down to choose another view type. But once you choose FanArt click down does nothing.

The funny thing about the extra art is that it did work for some collections but now it isn't working for any collections. I think it works when the collection is using art from FanArt.tv. Since we can no longer connect to that site from this skin it has stopped working. I have centralised my Collection art locally and point to it. AB picks up the extra fanart. When you highlight a collection you can see it flickering every 5 or 6 seconds (depending on what I set it to) trying to get the next fanart but it fails and the image does not change.

What drives me a bit crazy is one point.
I understand when you talk/wrote "movie information" you mean "view type" and in that case "fanart" , is that correct?

I need to look how skinhelper handle this
(Sidenote i didnt change anything related to that case, I got a few things in mind for resolve that sometime in future)
disaacso Wrote:this does work, I just prefer the aesthetic of having the video in the background  
[/quote]


I m sorry, i had to change currently playing bar that way.
But i will get the bg video working again next release.
thanks, no worries.  Just wanted to bring it up.

thanks for all the work you're doing
(2018-12-09, 18:31)mardukL Wrote: [ -> ]
(2018-12-09, 17:42)E net Wrote: [ -> ]
(2018-12-09, 15:05)mardukL Wrote: [ -> ]Ah, ok.
1. Slide side menu:
Can you eneble "quick alphatet navigation" in
Skinsettings-library settings (fanart view miss the custom ondown if its not enebled) but the other views should work independent .

2. Artwork i didnt had issues last time.
I need to take a look.
But the next 2 - 3 weeks i will not have any time to work on the mod, just looking in the forum frequently.
I already have quick alphabet navigation enabled. Once you go into the Video Information page you can click down to choose another view type. But once you choose FanArt click down does nothing.

The funny thing about the extra art is that it did work for some collections but now it isn't working for any collections. I think it works when the collection is using art from FanArt.tv. Since we can no longer connect to that site from this skin it has stopped working. I have centralised my Collection art locally and point to it. AB picks up the extra fanart. When you highlight a collection you can see it flickering every 5 or 6 seconds (depending on what I set it to) trying to get the next fanart but it fails and the image does not change.   

What drives me a bit crazy is one point.
I understand when you talk/wrote "movie information" you mean "view type" and in that case "fanart" , is that correct?

I need to look how skinhelper handle this
(Sidenote i didnt change anything related to that case, I got a few things in mind for resolve that sometime in future)   
OK so from the main menu I click Movies -> All Movies.
From there I select a Movie collection.
Inside there I can click down and get the slide out Options menu.
I choose to have the FanArt Menu as my "view type" so now inside the collection, each movie FanArt is shown in full screen.
So I should be able to click down and get the Slide out Options menu again. But it doesn't work.

The Logo "view type" since it is different to FanArt because I can press Up and get the slide out Option menu.

But to be honest I just want to know how to get the rotating extra fan art working again. It was working before but since the update it has stopped. I've even gone back to using an old version and it still doesn't work. I still think this has to do with the Fanart.tv connection problems. 

Thanks Smile
(2018-12-09, 13:51)mardukL Wrote: [ -> ]
(2018-12-07, 22:06)neurosis13 Wrote: [ -> ]
(2018-12-07, 19:23)mardukL Wrote: [ -> ] Special Ratikng (wich used to show in Library/Home) are stored locally (simple.cache), the refresh rate is 30 days.

No Atmos, flags, and i'm not to plan to integrate if last bugs are fixed.

I got problem to understand the 3rd request, you like to have option to disable the Plot? or and Details in generell? 
 if the ratings are stored locally then why it always takes 6 seconds for them to show up?  


Unsure why its sometimes take longer
(i assume its take longer if the cache is still filling)

To me its just max of 1-2 sec to show.

2750300 (post)  
i switched off the internet and like i suspected the ratings don't show up at all. 
So it definitely not uses the cache, it just fills it up but that's it.
i wonder why
(2018-12-10, 01:37)neurosis13 Wrote: [ -> ]
(2018-12-09, 13:51)mardukL Wrote: [ -> ]
(2018-12-07, 22:06)neurosis13 Wrote: [ -> ] if the ratings are stored locally then why it always takes 6 seconds for them to show up?  


Unsure why its sometimes take longer
(i assume its take longer if the cache is still filling)

To me its just max of 1-2 sec to show.

2750300 (post)  
i switched off the internet and like i suspected the ratings don't show up at all. 
So it definitely not uses the cache, it just fills it up but that's it.
i wonder why

Mine working offline :-)
(2018-12-10, 02:21)mardukL Wrote: [ -> ]
(2018-12-10, 01:37)neurosis13 Wrote: [ -> ]
(2018-12-09, 13:51)mardukL Wrote: [ -> ]Unsure why its sometimes take longer
(i assume its take longer if the cache is still filling)

To me its just max of 1-2 sec to show.

2750300 (post)  
i switched off the internet and like i suspected the ratings don't show up at all. 
So it definitely not uses the cache, it just fills it up but that's it.
i wonder why  

Mine working offline :-)  
 Ratings for us are not caching and do take a minimum of 5-10 seconds but on many occasions longer. Fanart.tv not working. Extra Fanart rotating stopped working since Fanart.tv stopped working even if Movie Set files are stored locally

It might help if you can explain your set up including:
- Which repositories you are using,
- What settings you use your skin media page
- What settings you are using for addons Universal Scraper, ArtBeef and Metamedia

This is a great Skin. But it's just not working as well as it could be for me and for many others.

Regards and Thanks
(2018-12-10, 11:14)E net Wrote: [ -> ]
(2018-12-10, 02:21)mardukL Wrote: [ -> ]
(2018-12-10, 01:37)neurosis13 Wrote: [ -> ]i switched off the internet and like i suspected the ratings don't show up at all. 
So it definitely not uses the cache, it just fills it up but that's it.
i wonder why 

Mine working offline :-) 
 Ratings for us are not caching and do take a minimum of 5-10 seconds. Fanart.tv not working. Extra Fanart rotating stopped working since Fanart.tv stopped working even if Movie Set files are stored locally

It might help if you can explain your set up including:
- Which repositories you are using,
- What settings you use your skin media page
- What settings you are using for addons Universal Scraper, ArtBeef and Metamedia

This is a great Skin. But it's just not working as well as it could be for me and for many others.

Regards and Thanks


Skinhelper use simple cache to store the online lookups, by using its modules .e.g. metadatautils.
(e.g. for Ratings, animated art,infos, etc....)
The refresh rste is 30 days.

I am not on pc to debug some stuff.
But the cache will also work on your side IF THE DATA IS CACHED ALREADY.
(2018-12-10, 12:30)mardukL Wrote: [ -> ]
(2018-12-10, 11:14)E net Wrote: [ -> ]
(2018-12-10, 02:21)mardukL Wrote: [ -> ]Mine working offline :-) 
 Ratings for us are not caching and do take a minimum of 5-10 seconds. Fanart.tv not working. Extra Fanart rotating stopped working since Fanart.tv stopped working even if Movie Set files are stored locally

It might help if you can explain your set up including:
- Which repositories you are using,
- What settings you use your skin media page
- What settings you are using for addons Universal Scraper, ArtBeef and Metamedia

This is a great Skin. But it's just not working as well as it could be for me and for many others.

Regards and Thanks 


Skinhelper use simple cache to store the online lookups, by using its modules .e.g. metadatautils.
(e.g. for Ratings, animated art,infos, etc....)
The refresh rste is 30 days.

I am not on pc to debug some stuff.
But the cache will also work on your side IF THE DATA IS CACHED ALREADY. 
Which version of Leia are you using please?

I have used RC1 and the latest RC3 candidate nightly. I have wiped Kodi completely and started again. Ratings do come a little quicker but it is sporadic. By that I mean that sometimes they come immediately, then other times they don't come at all. I wonder if the Cache is full so stuff gets kicked out?
(2018-12-10, 11:14)E net Wrote: [ -> ]
(2018-12-10, 02:21)mardukL Wrote: [ -> ]
(2018-12-10, 01:37)neurosis13 Wrote: [ -> ]i switched off the internet and like i suspected the ratings don't show up at all. 
So it definitely not uses the cache, it just fills it up but that's it.
i wonder why 

Mine working offline :-) 
 Ratings for us are not caching and do take a minimum of 5-10 seconds. Fanart.tv not working. Extra Fanart rotating stopped working since Fanart.tv stopped working even if Movie Set files are stored locally

It might help if you can explain your set up including:
- Which repositories you are using,
- What settings you use your skin media page
- What settings you are using for addons Universal Scraper, ArtBeef and Metamedia

This is a great Skin. But it's just not working as well as it could be for me and for many others.

Regards and Thanks


Skinhelper use simple cache to store the online lookups, by using its modules .e.g. metadatautils.
(e.g. for Ratings, animated art,infos, etc....)
The refresh rste is 30 days.

I am not on pc to debug some stuff.
But the cache will also work on your side IF THE DATA IS CACHED ALREADY.


(ps: it has may sound harsh, but telling "So it definitely not uses the cache, it just fills it up but that's it."
just confuses people like you and many others.

Thats why i keep the answer that short.

I'm. not the dev of skinhelper, nor fanart.tv.
(Skinhelper wich is really big and uses a lot dependencies )

I am aware of some issues, in your case rotating fanart, where i aswered i need to investigate.Also it seems a new issue.

And yeah, the skin/mod has more potential but IT NEEDS TIME TO SET IT UP.
It's not finished, nor perfect.

Dont take it personal nor as offend.
(2018-12-10, 13:06)mardukL Wrote: [ -> ]
(2018-12-10, 11:14)E net Wrote: [ -> ]
(2018-12-10, 02:21)mardukL Wrote: [ -> ]Mine working offline :-) 
 Ratings for us are not caching and do take a minimum of 5-10 seconds. Fanart.tv not working. Extra Fanart rotating stopped working since Fanart.tv stopped working even if Movie Set files are stored locally

It might help if you can explain your set up including:
- Which repositories you are using,
- What settings you use your skin media page
- What settings you are using for addons Universal Scraper, ArtBeef and Metamedia

This is a great Skin. But it's just not working as well as it could be for me and for many others.

Regards and Thanks 


Skinhelper use simple cache to store the online lookups, by using its modules .e.g. metadatautils.
(e.g. for Ratings, animated art,infos, etc....)
The refresh rste is 30 days.

I am not on pc to debug some stuff.
But the cache will also work on your side IF THE DATA IS CACHED ALREADY.


(ps: it has may sound harsh, but telling "So it definitely not uses the cache, it just fills it up but that's it."
just confuses people like you and many others.

Thats why i keep the answer that short.

I'm. not the dev of skinhelper, nor fanart.tv.
(Skinhelper wich is really big and uses a lot dependencies )

I am aware of some issues, in your case rotating fanart, where i aswered i need to investigate.Also it seems a new issue.

And yeah, the skin/mod has more potential but IT NEEDS TIME TO SET IT UP.
It's not finished, nor perfect.

Dont take it personal nor as offend. 
I realised that it must be that the Cache fills up. I know that I have said this many times before but the rotating fanart definitely did work on your previous release but it only seems to work with fanart.tv. Now that fanart.tv has stopped working with this skin the functionality has stopped. It would be great if we could get it working with the local movie set directory.

Thanks for taking the time to answer. No offence taken at all Smile
(2018-12-10, 13:12)E net Wrote: [ -> ]
(2018-12-10, 13:06)mardukL Wrote: [ -> ]
(2018-12-10, 11:14)E net Wrote: [ -> ] Ratings for us are not caching and do take a minimum of 5-10 seconds. Fanart.tv not working. Extra Fanart rotating stopped working since Fanart.tv stopped working even if Movie Set files are stored locally

It might help if you can explain your set up including:
- Which repositories you are using,
- What settings you use your skin media page
- What settings you are using for addons Universal Scraper, ArtBeef and Metamedia

This is a great Skin. But it's just not working as well as it could be for me and for many others.

Regards and Thanks 


Skinhelper use simple cache to store the online lookups, by using its modules .e.g. metadatautils.
(e.g. for Ratings, animated art,infos, etc....)
The refresh rste is 30 days.

I am not on pc to debug some stuff.
But the cache will also work on your side IF THE DATA IS CACHED ALREADY.


(ps: it has may sound harsh, but telling "So it definitely not uses the cache, it just fills it up but that's it."
just confuses people like you and many others.

Thats why i keep the answer that short.

I'm. not the dev of skinhelper, nor fanart.tv.
(Skinhelper wich is really big and uses a lot dependencies )

I am aware of some issues, in your case rotating fanart, where i aswered i need to investigate.Also it seems a new issue.

And yeah, the skin/mod has more potential but IT NEEDS TIME TO SET IT UP.
It's not finished, nor perfect.

Dont take it personal nor as offend. 
I realised that it must be that the Cache fills up. I know that I have said this many times before but the rotating fanart definitely did work on your previous release but it only seems to work with fanart.tv. Now that fanart.tv has stopped working with this skin the functionality has stopped. It would be great if we could get it working with the local movie set directory.

Thanks for taking the time to answer. No offence taken at all Smile

Yepp, i will see whats causing the lag, maybe its just server side issue on fanart.tv

And side note if it wasnt clear, the cache is used for certain things, not just one specific
(Info stuff for sets, movies,shows, omdb infos, special ratings,....)
(2018-12-10, 15:54)mardukL Wrote: [ -> ]
(2018-12-10, 13:12)E net Wrote: [ -> ]
(2018-12-10, 13:06)mardukL Wrote: [ -> ]Skinhelper use simple cache to store the online lookups, by using its modules .e.g. metadatautils.
(e.g. for Ratings, animated art,infos, etc....)
The refresh rste is 30 days.

I am not on pc to debug some stuff.
But the cache will also work on your side IF THE DATA IS CACHED ALREADY.


(ps: it has may sound harsh, but telling "So it definitely not uses the cache, it just fills it up but that's it."
just confuses people like you and many others.

Thats why i keep the answer that short.

I'm. not the dev of skinhelper, nor fanart.tv.
(Skinhelper wich is really big and uses a lot dependencies )

I am aware of some issues, in your case rotating fanart, where i aswered i need to investigate.Also it seems a new issue.

And yeah, the skin/mod has more potential but IT NEEDS TIME TO SET IT UP.
It's not finished, nor perfect.

Dont take it personal nor as offend. 
I realised that it must be that the Cache fills up. I know that I have said this many times before but the rotating fanart definitely did work on your previous release but it only seems to work with fanart.tv. Now that fanart.tv has stopped working with this skin the functionality has stopped. It would be great if we could get it working with the local movie set directory.

Thanks for taking the time to answer. No offence taken at all Smile  

Yepp, i will see whats causing the lag, maybe its just server side issue on fanart.tv

And side note if it wasnt clear, the cache is used for certain things, not just one specific
(Info stuff for sets, movies,shows, omdb infos, special ratings,....)  
Yeah I understood the cache issue thanks. Does your skin have an issue Fanart.tv or is it a general Kodi issue with Fanart.tv?
*edit* ignore this I have found out now thanks
(2018-11-30, 12:34)mardukL Wrote: [ -> ]
(2018-11-30, 11:30)tiku100 Wrote: [ -> ]Hello friends! Big Grin

I don't know why, but every time I try to install skin.helper.service my Kodi 18 Leia RC1 on Android, the whole Kodi system crashes. Only way to run Kodi again is deleting the folder from addon_data or modifying the content of addon.xml in the skin.helper.service folder under /addons.

I've installed both the "official" skin.helper.service and skin.helper.service alpha with same result. I've tried the official one and the ones listed in marcel BETA repository with no luck...

Could somebody help me, please? I'm trying to install the skin I'm used to (TITAN and its variants) and I'm a bit lost with this error.

Thanks in advance!!! Big Grin

If you use latest nightly rc1, there is a gui version bump.

Can you test this ? And report back.

https://github.com/marduklev/skin.titan....master.zip


Edit: i tried on androud phone.
Crashes if i install from zip
(No matter whatsoever)

Log looks like an Android kodi bug and not skin.related

Idk, wich nightly/beta kodi xx.arm.apk package worked before.

Log

UDP: Listening on port 9777 (ipv6 : false)
10:25:47.963 T:18446744072573942128 ERROR: GetDirectory - Error getting
10:26:00.426 T:18446744072748018032 ERROR: Previous line repeats 2 times.
10:26:00.426 T:18446744072748018032 ERROR: GetDirectory - Error getting /mnt/runtime/
10:26:00.426 T:18446744072748018032 ERROR: CGUIDialogFileBrowser::GetDirectory(/mnt/runtime/) failed
 
Hello @mardukL !!!

First of all, sorry for my late answer. I could not try your zip when you linked it and, after that, I've been suffering the f"%·"&" flu for almost ten days. Sorry again for being missing in action.

Again, I made a clean install of Kodi Leia RC1 on my Mi Box 3 and, without installing anything (even without installing any repo), I tried the package you linked and... IT WORKED!!! Big Grin Big Grin Big Grin

I really don't know why, because previously (and also on clean installs), I also tested your Skin Helper Service 1.1.25 and kept crashing, but now it's been perfectly working for a few days!

If I can help you identify something that could be useful to you, just tell me and I will be pleased to help Smile

Thanks again! Big Grin

And thanks to @Angelinas too, of course! Big Grin

Sorry for my English :__(
(2018-12-10, 16:40)E net Wrote: [ -> ]
(2018-12-10, 15:54)mardukL Wrote: [ -> ]
(2018-12-10, 13:12)E net Wrote: [ -> ]I realised that it must be that the Cache fills up. I know that I have said this many times before but the rotating fanart definitely did work on your previous release but it only seems to work with fanart.tv. Now that fanart.tv has stopped working with this skin the functionality has stopped. It would be great if we could get it working with the local movie set directory.

Thanks for taking the time to answer. No offence taken at all Smile  

Yepp, i will see whats causing the lag, maybe its just server side issue on fanart.tv

And side note if it wasnt clear, the cache is used for certain things, not just one specific
(Info stuff for sets, movies,shows, omdb infos, special ratings,....)  
Yeah I understood the cache issue thanks. Does your skin have an issue Fanart.tv or is it a general Kodi issue with Fanart.tv?
*edit* ignore this I have found out now thanks

Ok.
Maybe its worth a try, since that case of fanart / Poster naming for sets is new to me.
(Just worked with artwork beef for sets)

You can test with local artwork by follow the wiki
(https://kodi.wiki/view/Movie_artwork#Movieset_Fanart