Kodi Community Forum

Full Version: No sound at all
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hey guys, 

I'm new to Kodi and have recently installed the latest version Leia Alpha on Xbox One. 
From the beginning I have had no sound either on the UI, playing a movie from my Xbox internal storage or via streams.
My TV is connected through HDMI and I am using the TV speakers for sound output. 
All other apps work fine, when on Kodi if I press the Xbox home button I hear sound from the Xbox so it is just the Kodi app i'm having problems with. 
I've looked at some videos and some of the posts on this forum but can't seem to find a solution. 
Any help would be appreciated!

Curtis
Use the right stick in your controller to raise the volume.
Kodi has an inner volume scale that you can controller with the controller's right stick.

This is probably the issue.
Hi yanivk

Unfortunately this is not the issue. My volume is set to full, i've used the right stick to maximise the volume and on settings have my volume at 0.0dB and amplification at 60.0dB. It was originally at 0 but i've set it to max but still no sound.
One thing i'm unsure of is the audio stream says "undetermined - stereo [default] (1/1)" if that has any relevance to my query.
Hi everyone! I'm with the same problem and I think it's because the beta/delta updates of the Xbox Insider program. That will explain that some users recover the sound when factory defaults the Xbox one system as they explain on the "lack of sound" post at the first post of this forum.

I read somewhere that the last updates had problems with some apps and audio. Can anyone with this problem confirm if they are in the Insider program? If it is the problem we should report the issue to xbox insider support team.

Thanks!
I found the solution without the need to factory default. The problem is part of the insider program updates, but it will be part of the April's official update if you don't do this trick. It's all because of a new feature to set the background music volume independent of the apps.

Now the solution: Start Kodi app and then push Guide button. You'll see the recent app list. Put over on Kodi app and then press A button to enter. You'll see now a "media player?" with the play and back/forward buttons. At the bottom a slide bar with a controller icon on the left and a musical note icon on the right. Slide the bar all to the right (musical note icon) and then back to kodi app. Play some video/audio and the sound is back!

That's all!

Sorry for my English, cheers from Catalonia!
SOLUTION(Ish)
I’ve found force quitting the app and restarting seem to work. Quickest way BY FAR I’ve seen

By “force restart” I mean going into the guide > scrolling on the app in The guide menu > pressing menu > hitting close app


Hope that helps and that they FIX THIS SOON
Had sound yesterday on kodi for xbox one and today no sound at all tried both above and still nothing, uninstalled re-installed nothing
not had any updates for xbox under insider and never changed anything when was working yesterday only opened app and none

Have now also Reset & keep my games and apps and still no sound
please help
(2018-05-02, 06:12)1nFamous Wrote: [ -> ]SOLUTION(Ish)
I’ve found force quitting the app and restarting seem to work. Quickest way BY FAR I’ve seen

By “force restart” I mean going into the guide > scrolling on the app in The guide menu > pressing menu > hitting close app
Worked for me too.
tried that nothing reset xbox still same no audio noticed there is nothing in audio passthrough that can set which used to be have reinstalled kodi 5 x and still no audio the audio vol is saying 0.0db cannot move, my xbox is working ok as audio everywhere else except kodi
This is happening to me a lot the last few days. Suddenly videos will take a bit longer to start than usual, and there will be no sound. I have to close kodi and relaunch to get sound back. Sometimes that will work, other times i have to do it several times before sound is back. Never been like this before.
(2018-05-11, 22:54)bo1e Wrote: [ -> ]This is happening to me a lot the last few days. Suddenly videos will take a bit longer to start than usual, and there will be no sound. I have to close kodi and relaunch to get sound back. Sometimes that will work, other times i have to do it several times before sound is back. Never been like this before.

No one in this thread provides a Debug Log. sadly..
Thank you. This absolutely worked! Great. I appreciate it.
(2018-04-28, 07:59)Agaroth Wrote: [ -> ]I found the solution without the need to factory default. The problem is part of the insider program updates, but it will be part of the April's official update if you don't do this trick. It's all because of a new feature to set the background music volume independent of the apps.

Now the solution: Start Kodi app and then push Guide button. You'll see the recent app list. Put over on Kodi app and then press A button to enter. You'll see now a "media player?" with the play and back/forward buttons. At the bottom a slide bar with a controller icon on the left and a musical note icon on the right. Slide the bar all to the right (musical note icon) and then back to kodi app. Play some video/audio and the sound is back!

That's all!

Sorry for my English, cheers from Catalonia!

THIS WORKS 100%. Thanks!!
You are the greatest.
Pages: 1 2