Kodi Community Forum

Full Version: kodi-pvr-vbox dependency mismatch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All

Setting up Kodi on Mint to use the vbox as a backend;

mint 18.3
kernel 4.13.0-38 generic
kodi 15.2 git unknown 15.2+dfsg1-3 ubuntu1.1

System is fully up to date.

Install the kodi-pvr-vbox from the software manager, available version is

3.6.12-dmo1+deb9u1

Trying to install gives some dependency errors;

The following packages have unmet dependencies:

kodi-pvr-vbox: Depends: libgcc1 (>= 1:3.0) but 1:6.0.1-0ubuntu1 is to be installed
Depends: libp8-platform2 (>= 1:2.1.0.1) but 1:2.1.0.1-dmo1 is to be installed
Depends: libstdc++6 (>= 6) but 5.4.0-6ubuntu1~16.04.9 is to be installed


The first two should be ok, as the packages look >=, but the libstdc++ may be the problem

Any advice to resolve this?
I fixed this
The Kodi version installed by mint package manager is 15, version installed through wiki guide gives 17 and the add on works fine