Kodi Community Forum

Full Version: Kore/Yatse won't connect on 2nd use
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Have been googling everything I could think of to find the solution to this problem and I haven't found anybody who has asked it.

This same problem has come up for me with Yatse and now it's happening with Kore.

First I installed Yatse and I connected to it without problem.  I have a TV wall with 4 Kodi individual Kodi devices connected to each individual TV.  Upon setup, there was no problem.  I was able to use my remote to control all 4 Kodi devices.

When I came back the next day to control the devices again, my phone could recognize, but couldn't connect to any of the Kodi devices.  I thought maybe it's a problem with Yatse so I then went to attempt to intall Kore.  With Kore I ran into the exact same problem.  After the initial setup, everything worked fine.  I came back the next day, and again, Kore could recognize the devices, but it could not connect to any of them.  

Anybody have any idea why this would be happening or how to fix it?  I thought maybe I needed to set up port forwarding, but on my Google Wifi, the port forwarding feature wouldn't allow me to create the exception unless I listed both an internal and an external port.  I assume the internal port is my Kodi device, 8080, but what's the port on my android?  Not even sure if this is the direction I need to go, just not sure what to do from here.

It happened to me in almost the same way. Now Kore works OK after these trial & error steps:
  • Kore worked fine just once (IP & port inserted manually). When it stopped connecting a 2nd time, tried Yatse and Music Pump's Remote for Kodi without luck.
  • Changed original Kodi port (8080) to another numerals just to see what happens. Nothing.
  • Installed Apple's Bonjour just for enabling Kodi's Zeroconf option (Bonjour originally came with Windows 8.1, but I deleted it long ago). With Bonjour, the three remotes recognized my Kodi but none could establish a connection yet.
  • Opened the new changed port (mentioned above) in my firewall (duh!). Voilá.

Hope it also works for someone else!

(EDIT): Forgot to say that with Bonjour + the open port in the firewall there was no need of manually inserting IP & port parameters —just clicked in the recognized Kodi session and that's it.