Kodi Community Forum

Full Version: could it be there is a problem with mysql 8.0.11?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i couldn't get connection to database to work again.
i alreday switched to local Database for further testing purposes, so no logfile, but wanted to leave a hint, in case the disappearing files are related to database-version.
older Versions got no problem just this alpha on XBOX and Windows 64bit.
What did the Debug log (wiki) tell?
sorry, as i said, there is no log.
reason is simple, i could be sure, there is a problem with mysql as my workbench wouldn't connect either and after switching to wokbench 8.0.1 i found there is a problem how i use mysql on docker, somehow.
so i didn't want to do more harm to my still running older kodi version and sit and wait, what happens. at the moment, i just want to keep it up with older kodi...
but one thing is for sure, there are some things going on at mysql.
It's possible that the 8.0 database names were created with all lower case letters, and Kodi still uses mixed case names.
Check your kodi.log and your MySQL server.
i doubt that that is the problem in my case. i even deleted the database and fired up Kodi again. That should rebuild the database, shouldn't it?
(2018-06-24, 15:50)Dave-Kay Wrote: [ -> ]That should rebuild the database, shouldn't it?
It should, but you are the 2nd user of MySQL 8.0 in three days that is having a database problem.
that's the whole reason for my initial post. i wanted to point out, that there are issues with the new mysql. i would have prevented it, but unfortunately i set docker to auto-update Sad
after a lot of troubleshooting i finally found my missing root password and not so much later, i found a solution to my problem with connection.
I found my users not being able to connect to mysql through MYSQL-Workbench because of this message
Quote:The user specified as a definer ('mysql.infoschema'@localhost) does not exist
and the solution for that was found here:
Database was rebuild with Kodi Alpha and is up and running again.

I don't know what caused this, because everything worked fine, till  a few days ago and the only thing that changed, seemed to be the upgrade (which was made automatically by Docker) to MYSQL V8

thx for your hints and help!
Thread marked solved.
I know, its marked as solved but actually this was just a workaround.
To solve this, reinitialize mysql (if on a case-sensitie filesystem like ie ubuntu)

- edit '/etc/mysql/mysql.conf.d/mysqld.cnf' and add lower_case_table_names=1
- service mysql stop
- empty the mysql data directory
- reinitialize mysql following the manual: https://dev.mysql.com/doc/refman/8.0/en/...ysqld.html

my mysqld.cnf:

pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
datadir         = /var/lib/mysql
log-error       = /var/log/mysql/error.log

innodb_dedicated_server=1  #optimizes all variables on a dedicated server

afterwards mysql will convert everything in lowercase

if you are migrating your data from another mysqldb, a tool I prefer is HeidiSQL since it can easily do this on the fly

enjoy your way faster mysql experience!
Thanks for the workaround AND the whole fix Smile