Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I used the main deb

Went to package manager, searched for xbmc, highlighted for install and got this error.

The following packages have unresolvable dependencies.

xbmc:
Depends: xbmc-common but it is not going to be installed
Depends: xbmc-skin-pm3-hd but it is not going to be installed
Depends: xbmc-web-pm3 but it is not going to be installed
which PPA did you use ?

try to install only xbmc-common and see what is the error.
watta:

Im getting the same error. I tried installing xbmc-common as well ad getting another dependency error. Im using feisty fawn.

Edit: I was able to install it using this PPA:

deb http://ppa.launchpad.net/xbmc-team-feisty/ubuntu feisty main
deb-src http://ppa.launchpad.net/xbmc-team-feisty/ubuntu feisty main

The ones posted in the first page of this thread gave out the error below, including the svn one.

Code:
[email protected]:~$ sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xbmc: Depends: xbmc-common (= 2.1a2svn14729-feisty1) but it is not going to be installed
        Depends: xbmc-skin-pm3 (= 2.1a2svn14729-feisty1) but it is not going to be installed
        Depends: xbmc-web-pm3 (= 2.1a2svn14729-feisty1) but it is not going to be installed
E: Broken packages
[email protected]:~$ sudo apt-get install xbmc-common
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xbmc-common: Depends: libjasper1 but it is not installable
E: Broken packages
[email protected]:~$
Where I can get GPG keys what you use for package signing?
Tobler Wrote:Where I can get GPG keys what you use for package signing?

Well actually, even if you add my GPG key to apt, it won't work cause the PPA building system doesn't sign the packages. It prevents me to upload sources for building if I am not an Ubuntuero and if my sources are not signed with my GPG key. There is also an authentication against my SSH key.

So basically, Launchpad protects a lot for upload but once on the system, the build system can't sign the packages. That's quite normal cause it doesn't has my GPG key.
I added the PPA's for SVN to my sources, and nothing shows up in my Synaptic.
I am running Hardy i386
When i sort by origion the ppa sources don't even show in the list.
If anyone can't point out what i've done wrong i'd appreciate it.

or is there somewhere i can just download the .deb files
Seems like svn isn't working. XBMC shows up when I add the hardy repository, but not for svn
Perhaps they're gearing up for a the Release Candidate with all the updates in svn to date.... no news could very well be good news!
SVN PPA is not updated anymore. We push for the usage of the releases and we don't update SVN ppa anymore. Please use the stable PPA.
well its your distribution, however the release version isn't so stable on my system. And the source code for svn won't compile because there are missing files in the Goom visualizations, was only hoping to get the current patches that make it work worthwhile on my system because everytime i play a video the whole screen goes white.

I by no means am complaining, I just love XBMC (have been using it on my Xbox for the last 5 years, and am eager to use it to power my HTPC, all that said, keep up the good work.
Nicezia Wrote:well its your distribution, however the release version isn't so stable on my system.

If you have some issues with the release version, please report them and/or open bugs report on trac (http://trac.xbmc.org)
can I install xbmc on Ubuntu Server edition?
yazoo Wrote:can I install xbmc on Ubuntu Server edition?
Yes, read README.linux for which dependencies you need.
Any pre-compiled builds of Atlantis (beta2) expect for Ubuntu ?
covert Wrote:Any pre-compiled builds of Atlantis (beta2) expect for Ubuntu ?
Laugh ! PPA is meant for that, don't worry Laugh