Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
To the package maintainer: the Wii Remote event client requries libbluetooth2. However, my fully updated Intrepid only provides libbluetooth3. This breaks the dependancy check. Can you please look into it? (or should I compile it on my own?)

edit: shoulda hunted around, since plenty of others have complained about it. Thanks for the hard work though!
Whats goin on with launchpad? Is it problem with Intrepid SVN packages? Launchpad acting weird in these days.
@LiquidRain: Are you using SVN PPA or stable ? I have fixed it on SVN PPA. The fix on stable will come soon.

@queeup: what is happening to Launchpad ?
Fix done on intrepid.
ooo nice thx. intrepid compiled atm Smile keep going...
FEH.py not exist(missing) in xbmc - 8.10final1svn18158-intrepid1. That couse X server to shut down.

Code:
python: can't open file '/usr/share/xbmc.FEH.py': [Errno 2] No such file or directory

waiting for X server to shut down


after this:
Code:
$sudo wget http://trac.xbmc.org/export/18153/branches/linuxport/XBMC/tools/Linux/FEH.py
-O /usr/share/xbmc/FEH.py

i get this error:
Code:
sh: glxinfo: not found
Traceback (most recent call last):
  File "/usr/share/xbmc/FEH.py", line 167, in <module>
    error("XBMC can not run without direct rendering.\n\nPlease install a valid opengl driver.")
  File "/usr/share/xbmc/FEH.py", line 27, in error
    if "Qt" in Output:
NameError: global name 'Output' is not defined

waiting for X server to shut down

i need mesa-utils package for glxinfo.
Code:
$ sudo aptitude install mesa-utils

@wattazoum pls add mesa-utils Depends to in your xbmc-common package.
queeup Wrote:FEH.py not exist(missing) in xbmc - 8.10final1svn18158-intrepid1. That couse X server to shut down.

Code:
python: can't open file '/usr/share/xbmc.FEH.py': [Errno 2] No such file or directory

waiting for X server to shut down


after this:
Code:
$sudo wget http://trac.xbmc.org/export/18153/branches/linuxport/XBMC/tools/Linux/FEH.py
-O /usr/share/xbmc/FEH.py

i get this error:
Code:
sh: glxinfo: not found
Traceback (most recent call last):
  File "/usr/share/xbmc/FEH.py", line 167, in <module>
    error("XBMC can not run without direct rendering.\n\nPlease install a valid opengl driver.")
  File "/usr/share/xbmc/FEH.py", line 27, in error
    if "Qt" in Output:
NameError: global name 'Output' is not defined

waiting for X server to shut down

i need mesa-utils package for glxinfo.
Code:
$ sudo aptitude install mesa-utils

@wattazoum pls add mesa-utils Depends to in your xbmc-common package.

Damn, thought glxinfo was always in ubuntu, sorry about that. added to README.linux aswell r18167.

also it might be good to add recomend python-gt3 or python-gtk or python-pygame. FEH.py will should work without it them but it wont give graphical error message.
Also noteworthy its possible to skip tests with xbmc --no-test
wattazoum Wrote:Fix done on intrepid.

Wattazoum,

I notice on my mythbuntu system an update waiting to install and the update is xbmc-common etc.. I am using the intrepid ppa on that system. Is this the fix you are talking about here OR has there been a recompile to a new stable version in the intrepid ppa. I am planning on switchin over to the vdpau rev soon on that machine anyhow, but I was just wondering before I upgrade via apt.

Thanks,

Dave
Yep that's a new stable package with the fix. The package has been rebuilt on intrepid only. No new code has been added. Only dependencies fixed.
I just had a problem getting a new source tree working by trying to get all the dependencies installed for XBMC through the PPA for intrepid.

Quote:[email protected]:~/XBMC/branches/linuxport/XBMC$ sudo apt-get build-dep xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libcurl3-dev is a virtual package provided by:
libcurl4-openssl-dev 7.18.2-1ubuntu4.3
You should explicitly select one to install.
E: Package libcurl3-dev has no installation candidate
E: Failed to satisfy Build-Depends dependency for xbmc: libcurl3-dev

Some updates to libcurl were installed a few days ago through Intrepid. Does this mean the PPA dependencies for XBMC also need to be updatedHuh
Hi,
I am not having the same issue.
The apt system replace libcurl3-dev on my system without problem.

http://pastebin.ubuntu.com/127707/
Hi, are there any plans for an xbmc-vdpau repository ?
I am getting this error.

[code[W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2BBD133164234534[/code]

this is a fresh 8.10 install.

I have tried this:

Code:
gpg --keyserver subkeys.pgp.net --recv 2BBD133164234534
gpg --export --armor 2BBD133164234534 | sudo apt-key add -
sudo apt-get update

Running the first code I get this error:

Code:
gpg: requesting key 64234534 from hkp server subkeys.pgp.net
gpg: can't open `/home/peter/.gnupg/pubring.gpg'
gpg: keydb_get_keyblock failed: eof
gpg: no writable keyring found: eof
gpg: error reading `[stream]': general error
gpg: Total number processed: 0
onesojourner Wrote:I am getting this error.

[code[W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2BBD133164234534[/code]

this is a fresh 8.10 install.

I have tried this:

Code:
gpg --keyserver subkeys.pgp.net --recv 2BBD133164234534
gpg --export --armor 2BBD133164234534 | sudo apt-key add -
sudo apt-get update

Running the first code I get this error:

Code:
gpg: requesting key 64234534 from hkp server subkeys.pgp.net
gpg: can't open `/home/peter/.gnupg/pubring.gpg'
gpg: keydb_get_keyblock failed: eof
gpg: no writable keyring found: eof
gpg: error reading `[stream]': general error
gpg: Total number processed: 0

Does pubring.gpg exist? And is it owned by peter? To test, run this command

Code:
ls -al /home/peter/.gnupg/pubring.gpg
jokeli Wrote:I think you're on the right track! Keep trying to get better and better. You will improve if you practice properly, all you need is patience and time.

You might want to kill that spammy user, look at the links...