Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
bmfrosty Wrote:Maybe I'm missing something, but as far as I can tell, neither of the hardy PPAs have the 9.04 alpha, just 8.10, or SVN. Is there a 3rd one I'm missing?
My dpkg says:
xbmc 9.04~alpha1svn19419-intrepid1
Looks like SVN is 9.04 alpha.
My corresponding entries in the sources.list are
## sources for xbmc
deb http://ppa.launchpad.net/team-xbmc-intrepid/ppa/ubuntu intrepid main
deb http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu intrepid main
deb http://ppa.launchpad.net/xbmc-addons/ppa/ubuntu intrepid main
## installing vdpau support on intrepid
deb http://www.avenard.org/files/ubuntu-repos release/
As far as I can see, the hardy-repository from svn contains 9.04 alpha too.

Really want to try this application but am currently being thwarted by the gpg key installation to be able to download the actual packages.
Have follow the first post and read the concerned articles/pages
Have tried both command line method and inserting the save text file key in to the authentication section. File gets imported fine but no joy when trying to update the sources.
Command line import of public key produces the following out put
sudo gpg --keyserver keyserver.ubuntu.com --recv 43C0AFF0D7FAE680
gpg: WARNING: unsafe ownership on configuration file `/home/iluciv/.gnupg/gpg.conf'
gpg: external program calls are disabled due to unsafe options file permissions
gpg: keyserver communications error: general error
gpg: keyserver receive failed: general error

The following error is produced after importing the text file and doing apt-get update in the terminal
W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 43C0AFF0D7FAE680
W: You may want to run apt-get update to correct these problems

This is a fresh install of ubuntu 8.10 and I've not played with anything

Is it a permission error or something?

Thanks in advance

Actually this got solved I was tying to run the command with sudo and I only had to run as a normal user lol
Topfs2 Wrote:Either choose it in the Settings -> Appearence -> Screen and choose the fullscreen resolution, or run xbmc --standalone. xbmc --fs might work aswell.

--standalone won't change your screen setup though, so you might need to wipe your guisettings.

Standalone will also enable shutdown features and such.


If the resolution was set to "auto" the "--fs" does not work very well as the result resolution was fixed at a lower resolution than the native one.

I have a python start up script here

Get it with
svn export https://xbox-remote.googlecode.com/svn/trunk/scripts/start-xbmc.py start-xbmc.py
svn export https://xbox-remote.googlecode.com/svn/trunk/scripts/xbmcclient.py xbmcclient.py

To start up full screen run:
python start-xbmc.py -f

To start up in spawn mode run:
python start-xbmc.py -f -s
When is the next ppa svn build? Can't wait for the fix by r19439.
For the record, despite having effects in Gnome turned off, it seems that the issue was still Gnome-related.

I tried starting up in KDE this weekend and it stays in fullscreen just fine.

While I would like to hunt down the Gnome issue, my wife and children are insisting that we juts remain in KDE Big Grin
What is the best way to install this on 9.04?

I am running 9.04 rc with and nforce 9400 motherboard. Also the Nvidia 180 driver was installed.
why there's no LPIA build?
smacfarl Wrote:What is the best way to install this on 9.04?

I am running 9.04 rc with and nforce 9400 motherboard. Also the Nvidia 180 driver was installed.


The best way is to use the Jaunty PPA:

The SVN PPA also has Jaunty's packages.
I'll update the first message of this thread to add the information.
Cimi Wrote:why there's no LPIA build?

There is no LPIA build because XBMC depends on some packages that are not available on this platform. I don't remember which though Undecided
I can't find the key fingerprint where it's supposed to be located. I'm trying to put a key in for jaunty xbmc.

What's the deal?
To add the AWN key, you'd enter this:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B0BE17C2A0C914F086B7B8327D2C7A23BF810CD5
Replace B0BE17C2A0C914F086B7B8327D2C7A23BF810CD5 with the fingerprint of the PPA key you're dealing with.
jaunty jackalope repos?

Sad sometimes happens. Intrepid svn package not update. I think its launchpad bug.
W: GPG error: http://ppa.launchpad.net jaunty Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible*: NO_PUBKEY 2BBD133164234534

The key I added is 9317790E, dated 04/04.. Any clues there ?

Oups, message is in french. It say, can't check signatures, public key not availible.