Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
MartijnKooi Wrote:Still the same..

PHP Code:
xbmc@solonview:~$ sudo apt-get install xbmc-live
Reading package lists
... Done
Building dependency tree
Reading state information
... Done
The following packages were automatically installed 
and are no longer required:
  
libvorbisenc2 usplash-theme-ubuntu python-bluez libbluetooth3 libcwiid1
  usplash
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  
xbmc-standalone
Suggested packages
:
  
xbmc-third-parties
The following 
NEW packages will be installed:
  
xbmc-live xbmc-standalone
0 upgraded
2 newly installed0 to remove and 0 not upgraded.
Need to get 14.8kB of archives.
After this operation156kB of additional disk space will be used.
Do 
you want to continue [Y/n]? y
Get
:1 http://ppa.launchpad.net jaunty/main xbmc-standalone 9.04.1-jaunty1 [2726B]
Get:2 http://ppa.launchpad.net jaunty/main xbmc-live 9.04.1-jaunty1 [12.1kB]
Fetched 14.8kB in 0s (80.5kB/s)
Selecting previously deselected package xbmc-standalone.
(
Reading database ... 51244 files and directories currently installed.)
Unpacking xbmc-standalone (from .../xbmc-standalone_9.04.1-jaunty1_i386.deb) ...
Selecting previously deselected package xbmc-live.
Unpacking xbmc-live (from .../xbmc-live_9.04.1-jaunty1_i386.deb) ...
Setting up xbmc-standalone (9.04.1-jaunty1) ...
Setting up xbmc-live (9.04.1-jaunty1) ...
Installing new version of config file /etc/init.d/xbmc-live ...
The user `xbmc' is already a member of `admin'.
The user `xbmc' 
is already a member of `adm'.
The user 
`xbmc' is already a member of `dialout'.
The user `xbmc' is already a member of `cdrom'.
The user `xbmc' 
is already a member of `floppy'.
The user 
`xbmc' is already a member of `audio'.
Adding user `xbmc' to group `dip' ...
Adding user xbmc to group dip
Done.
The user `xbmc' 
is already a member of `video'.
The user 
`xbmc' is already a member of `plugdev'.
The user `xbmc' is already a member of `fuse'.
The user `xbmc' 
is already a member of `sudo'.
polkit-auth: AuthorizationAlreadyExists: An authorization for uid 1000 for the action org.freedesktop.hal.power-management.shutdown with constraint '' already exists
dpkg: error processing xbmc-live (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 xbmc-live
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$ 

XBMC is running fine though, it wont starup automaticaly..
Can't find how to autoboot to xbmc..

system=> administration=>login window=> Default session => XBMC.
how easy can it be?
I.capriotti: I am still having issues but I am seeing something different.

Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
xbmc-live is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up xbmc-live (9.04.2+svn20937-jaunty1) ...
Adding user `xbmc' to group `floppy' ...
Adding user xbmc to group floppy
Done.
Adding user `xbmc' to group `video' ...
Adding user xbmc to group video
Done.
Adding user `xbmc' to group `fuse' ...
Adding user xbmc to group fuse
Done.
Adding user `xbmc' to group `sudo' ...
Adding user xbmc to group sudo
Done.
[WARN  3746] polkit-action.c:211:polkit_action_set_action_id(): polkit_action_validate_id (action_id)
Not built with -rdynamic so unable to print a backtrace
polkit-auth: GeneralError: Given action does not have action_id set
dpkg: error processing xbmc-live (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
xbmc-live
E: Sub-process /usr/bin/dpkg returned an error code (1)
I just get the same error, should I be logged in as XBMC when I do this?
updated the SVN version, please retry these steps
l.capriotti Wrote:updated the SVN version, please retry these steps
Still getting the same error Sad
Cirion Wrote:Still getting the same error Sad

Same here. I've done a fresh install of Live 9.04.1, modified the xbmc-live.postinst file per the instructions in this thread and still got the same xbmc-live processing error when attempting to update to the latest SVN version.
l.capriotti Wrote:updated the SVN version, please retry these steps

I am still getting the same error. Any info I can provide to help?

-Bahndit
Replacing the postinst script with WEiSLaND's version worked for me.
(as per http://forum.xbmc.org/showpost.php?p=350...tcount=403 )

[EDIT] Still had to use this with the new SVN #21124 which just finished building.
Why does the 'xbmc' user have to be in the 'sudo' group?
to make life easier for lazy people Smile
has this been fixed I tried the suggestions here and keep getting the same error
l.capriotti Wrote:to make life easier for lazy people Smile

Ok. I hope this isn't the only answer.

I suggest this is not done by installing the package but rather when installing XBMCbuntu, or whatever it's going to be called.
amended in the SVN and latest packages
If it hasn't already been done, please update the svn ppa to reflect changes fixed by this trac ticket, as it affects all linux users rather meaningfully: OGG tracks not added to music library.
l.capriotti Wrote:amended in the SVN and latest packages
Do you mean it should work now? Or it will work soon?

I'm still getting the same error when updating to the latest SVN.