Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
PrimaryMaster Wrote:then i have to ask... how?

Code:
wget https://edge.launchpad.net/~team-xbmc-svn/+archive/ppa/+build/1205143/+files/xbmc-live_9.04.3+svn22528-jaunty2_i386.deb
wget https://edge.launchpad.net/~team-xbmc-svn/+archive/ppa/+build/1205143/+files/xbmc-standalone_9.04.3+svn22528-jaunty2_i386.deb
sudo dpkg -i xbmc-standalone_9.04.3+svn22528-jaunty2_i386.deb xbmc-live_9.04.3+svn22528-jaunty2_i386.deb

What I wonder is how you were able to install these packages without getting dependency problems. I had to force install some of these packages myself.
Hey Guys,

Is it possible to share the build scripts for the ubuntu and xbmc live specific packages.?

I'm able to compile xbmc from source but then I need to hack the /etc/event.d/tty1 and .xsession to get things working on my xbmc live system.

It would definitely help if you could post the build scripts to make my owne xbmc-standalone (xbmc_*-jaunty1_i386.deb, xbmc-skin-pm3-hd_*-jaunty1_i386.deb, xbmc-common_*-jaunty1_i386.deb, xbmc-web-pm3_*-jaunty1_i386.deb) and xbmc-live packages instead.

The command I'm using right now to build my own packages is:

Code:
sudo checkinstall --fstrans=no --install=no --pkgname=xbmc --pkgversion "1:0.svn.r`svn info | grep Revision: | awk -F": " '{ print $2 }'`-0.0ubuntu1" --default --pakdir "../debs"
erhnam Wrote:Hey Guys,

Is it possible to share the build scripts for the ubuntu and xbmc live specific packages.?

I'm able to compile xbmc from source but then I need to hack the /etc/event.d/tty1 and .xsession to get things working on my xbmc live system.

It would definitely help if you could post the build scripts to make my owne xbmc-standalone (xbmc_*-jaunty1_i386.deb, xbmc-skin-pm3-hd_*-jaunty1_i386.deb, xbmc-common_*-jaunty1_i386.deb, xbmc-web-pm3_*-jaunty1_i386.deb) and xbmc-live packages instead.

The command I'm using right now to build my own packages is:

Code:
sudo checkinstall --fstrans=no --install=no --pkgname=xbmc --pkgversion "1:0.svn.r`svn info | grep Revision: | awk -F": " '{ print $2 }'`-0.0ubuntu1" --default --pakdir "../debs"

ernham, If you figure this out it, It would be great if you could write a how to. I have been looking for a way to compile from SVN and still use xbmc live.
spozen Wrote:ernham, If you figure this out it, It would be great if you could write a how to. I have been looking for a way to compile from SVN and still use xbmc live.

I had a quick look at the buildlog and it seems that they are using a more advanced build meganism located on /home/buildd/. Would be very nice to have a more detailed look at this!

( http://launchpadlibrarian.net/33181822/b...ILT.txt.gz )
I just went though the last few pages. I want to downgrade to 22528. I run Ubunti minimal with XBMC (may) updated to 23422. In 23422 video_ts playback is broken, and I need a newer version than may to run mediastream redux.

I saw two posts, first this:
Code:
wget [url]https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-skin-pm3-hd_9.04.3+svn22528-jaunty2_i386.deb[/url]
wget [url]https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-web-pm3_9.04.3+svn22528-jaunty2_i386.deb[/url]
wget [url]https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc_9.04.3+svn22528-jaunty2_i386.deb[/url]
wget [url]https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-common_9.04.3+svn22528-jaunty2_i386.deb[/url]
wget [url]https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-eventclients-common_9.04.3+svn22528-jaunty2_i386.deb[/url]

sudo dpkg -i xbmc-common_9.04.3+svn22528-jaunty2_i386.deb xbmc_9.04.3+svn22528-jaunty2_i386.deb xbmc-skin-pm3-hd_9.04.3+svn22528-jaunty2_i386.deb xbmc-web-pm3_9.04.3+svn22528-jaunty2_i386.deb xbmc-eventclients-common_9.04.3+svn22528-jaunty2_i386.deb

and then later this:
Code:
wget https://edge.launchpad.net/~team-xbmc-svn/+archive/ppa/+build/1205143/+files/xbmc-live_9.04.3+svn22528-jaunty2_i386.deb
wget https://edge.launchpad.net/~team-xbmc-svn/+archive/ppa/+build/1205143/+files/xbmc-standalone_9.04.3+svn22528-jaunty2_i386.deb
sudo dpkg -i xbmc-standalone_9.04.3+svn22528-jaunty2_i386.deb xbmc-live_9.04.3+svn22528-jaunty2_i386.deb

Do I need to do both, and in this order?
I tried yesterday but got messages/errors about current installed version being newer and dependencies, so I assume I must somehow force this. I'd appreciate a helping hand. Also the xbmc-live in second code part confuses me as I never used xbmc live. It could well be that I shouldn't need to do this.
Hehe if you aren't running xbmc live or XBMCbuntu, then you won't need the second part.

Post your errors here, we might be available to help ya.

However are you sure you will need downgraded packages?, latest svn build is:
9.04.3+svn23539-jaunty1

Hopefully the video_ts problem is gone now?
spozen Wrote:Hehe if you aren't running xbmc live or XBMCbuntu, then you won't need the second part.

Post your errors here, we might be available to help ya.

However are you sure you will need downgraded packages?, latest svn build is:
9.04.3+svn23539-jaunty1

Hopefully the video_ts problem is gone now?

so if i run Xbmc Live (9.04.1) / May 25 2009 (SVN:20654) and want to upgrade.. I typ all lines?
In Xbmc Safe mode?
when i type "sudo dpkg -i xbmc-common_9.04.3+svn22528-jaunty2_i386.deb xbmc_9.04.3+svn22528-jaunty2_i386.deb xbmc-skin-pm3-hd_9.04.3+svn22528-jaunty2_i386.deb xbmc-web-pm3_9.04.3+svn22528-jaunty2_i386.deb xbmc-eventclients-common_9.04.3+svn22528-jaunty2_i386.deb"

this happens...

Code:
(T: XBMCLive)[email protected]:~# sudo dpkg -i xbmc-common_9.04.3+svn22528-jaunty2_i                                                                             386.deb xbmc_9.04.3+svn22528-jaunty2_i386.deb xbmc-skin-pm3-hd_9.04.3+svn22528-j                                                                             aunty2_i386.deb xbmc-web-pm3_9.04.3+svn22528-jaunty2_i386.deb xbmc-eventclients-                                                                             common_9.04.3+svn22528-jaunty2_i386.deb
(Reading database ... 26879 files and directories currently installed.)
Preparing to replace xbmc-common 9.04.1-jaunty1 (using xbmc-common_9.04.3+svn225                                                                             28-jaunty2_i386.deb) ...
Unpacking replacement xbmc-common ...
Preparing to replace xbmc 9.04.1-jaunty1 (using xbmc_9.04.3+svn22528-jaunty2_i38                                                                             6.deb) ...
Unpacking replacement xbmc ...
Preparing to replace xbmc-skin-pm3-hd 9.04.1-jaunty1 (using xbmc-skin-pm3-hd_9.0                                                                             4.3+svn22528-jaunty2_i386.deb) ...
Unpacking replacement xbmc-skin-pm3-hd ...
Preparing to replace xbmc-web-pm3 9.04.1-jaunty1 (using xbmc-web-pm3_9.04.3+svn2                                                                             2528-jaunty2_i386.deb) ...
Unpacking replacement xbmc-web-pm3 ...
Selecting previously deselected package xbmc-eventclients-common.
Unpacking xbmc-eventclients-common (from xbmc-eventclients-common_9.04.3+svn2252                                                                             8-jaunty2_i386.deb) ...
dpkg: dependency problems prevent configuration of xbmc-common:
xbmc-common depends on libvorbisenc2; however:
  Package libvorbisenc2 is not installed.
dpkg: error processing xbmc-common (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc:
xbmc depends on xbmc-common (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-common is not configured yet.
dpkg: error processing xbmc (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc-skin-pm3-hd:
xbmc-skin-pm3-hd depends on xbmc-common (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-common is not configured yet.
dpkg: error processing xbmc-skin-pm3-hd (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc-web-pm3:
xbmc-web-pm3 depends on xbmc-common (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-common is not configured yet.
dpkg: error processing xbmc-web-pm3 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc-eventclients-common:
xbmc-eventclients-common depends on libbluetooth3; however:
  Package libbluetooth3 is not installed.
dpkg: error processing xbmc-eventclients-common (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
xbmc-common
xbmc
xbmc-skin-pm3-hd
xbmc-web-pm3
xbmc-eventclients-common
(T: XBMCLive)[email protected]:~#

when....

Code:
(T: XBMCLive)[email protected]:~# sudo dpkg -i xbmc-standalone_9.04.3+svn22528-jaunty2_i386.deb xbmc-live_9.04.3+svn22528-jaunty2_i386.deb
(Reading database ... 26932 files and directories currently installed.)
Preparing to replace xbmc-standalone 9.04.1-jaunty1 (using xbmc-standalone_9.04.3+svn22528-jaunty2_i386.deb) ...
Unpacking replacement xbmc-standalone ...
Preparing to replace xbmc-live 9.04.1-jaunty1 (using xbmc-live_9.04.3+svn22528-jaunty2_i386.deb) ...
Xorg: no process killed
xbmc: no process killed
Unpacking replacement xbmc-live ...
dpkg: dependency problems prevent configuration of xbmc-standalone:
xbmc-standalone depends on xbmc-common (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-common is not configured yet.
xbmc-standalone depends on xbmc-skin-pm3-hd (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-skin-pm3-hd is not configured yet.
xbmc-standalone depends on xbmc-web-pm3 (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-web-pm3 is not configured yet.
dpkg: error processing xbmc-standalone (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc-live:
xbmc-live depends on xbmc-standalone (= 9.04.3+svn22528-jaunty2); however:
  Package xbmc-standalone is not configured yet.
dpkg: error processing xbmc-live (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
xbmc-standalone
xbmc-live

The i Pkill Xbmc and Pkill Xorg... but that did not help




EDIT:

Now o i did
Apt-get updte
Apt-get upgrade
Apt-get -f install
apt-get install xmbc

and now i have a svn from 6 sep. and Unknown SNV ver. =)
So I figure it is working now? Eek

Anyway I can't understand why you people don't wanna run the latest SVN. I just installed it and i have no problems with it, at all. Big Grin
Doesn't the latest SVN still have some issues?

I really like some of the other skins and some of the new features (like additional VDPAU settings etc.) but am looking for somethign stable (the wife has to be able to use it without complaint).
Hi,

the only issue I still have is broken/garbled subtitles (SSA/ASS ones) with VDPAU (often use in animes).

I'm running svn version from october the 10th on jaunty minimal ubuntu install (no gnome/KDE).

See http://forum.xbmc.org/showthread.php?p=4...post416398 for more info.

regards,
Typhoe
spozen Wrote:So I figure it is working now? Eek

Anyway I can't understand why you people don't wanna run the latest SVN. I just installed it and i have no problems with it, at all. Big Grin


working and working Huh !!! hummm...Confused

I dont know what svn ver i have but....

I want i good stable that runs Showmix perfect.... and they say it svn: 22516

so i want to downgrade to that !!!!
I managed to downgrade finally. Collected bits and piece everywhere from the forum and forced an install., I gues probably some steps are not required, but it worked. This is what I did:

Code:
pkill xbmc
pkill xorg

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install xbmc

wget https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-skin-pm3-hd_9.04.3+svn22528-jaunty2_i386.deb
wget https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-web-pm3_9.04.3+svn22528-jaunty2_i386.deb
wget https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc_9.04.3+svn22528-jaunty2_i386.deb
wget https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-common_9.04.3+svn22528-jaunty2_i386.deb
wget https://launchpad.net/~team-xbmc-svn/+archive/ppa/+files/xbmc-eventclients-common_9.04.3+svn22528-jaunty2_i386.deb

sudo dpkg -i --force-all xbmc-common_9.04.3+svn22528-jaunty2_i386.deb xbmc_9.04.3+svn22528-jaunty2_i386.deb xbmc-skin-pm3-hd_9.04.3+svn22528-jaunty2_i386.deb xbmc-web-pm3_9.04.3+svn22528-jaunty2_i386.deb xbmc-eventclients-common_9.04.3+svn22528-jaunty2_i386.deb
I know what you mean guys, XBMC crashes a bit too often these days.. But some older SVN versions are even more unstable then the latest one. After all you can't expect the SVN versions to be completly stable.

kees667, i did exactly like you except i used apt-get remove xbmc instead of install.... wierd huh...
At least it works :-) Wanted to post here in case someone else could use it.

Now running 22528 but an ISO file doesn't work. I need r23534. I am a little confused with all the versions. I saw this guide here: http://forum.xbmc.org/showthread.php?tid=54350 which uses

Code:
deb http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu jaunty main

will that get me a recent build like 23534 ?