Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
just updated from SVN, is that a problem?

Quote:Setting up xbmc-live (1:10.08~svn31415-lucid1) ...
update-rc.d: warning: /etc/init.d/xbmc-live missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
Just updated to svn 31415 (from a week older svn). XBMC does not start any longer.

Code:
$ xbmc
*** glibc detected *** /usr/lib/xbmc/xbmc.bin: corrupted double-linked list: 0xb57004a8 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(+0x6b591)[0x3433591]
/lib/tls/i686/cmov/libc.so.6(+0x6b9ea)[0x34339ea]
/lib/tls/i686/cmov/libc.so.6(+0x6dafd)[0x3435afd]
/lib/tls/i686/cmov/libc.so.6(__libc_malloc+0x5c)[0x3437f9c]
/usr/lib/libsqlite3.so.0(+0x1b8bb)[0x6358bb]
/usr/lib/libsqlite3.so.0(+0x5956)[0x61f956]
/usr/lib/libsqlite3.so.0(+0x5a40)[0x61fa40]
/usr/lib/libsqlite3.so.0(+0x5e08)[0x61fe08]

Full crashlog @ http://paste.ubuntu.com/455580/
Now another error when starting:

Code:
[email protected]:~$ xbmc
xbmc.bin: malloc.c:3096: sYSMALLOc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins[((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)' failed.
I have to add, despite the error message I quoted above, 31415 is running just fine here (with the exception of the recentlyadded python script error of course...)

novin, you already tried to purge and reinstall?
total noob, not really sure whats going on. i'm using debian lenny. i've added the repos and the key.

Code:
[email protected]:~$ sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xbmc: Depends: xbmc-data (= 1:9.11-lucid2) but it is not going to be installed
        Depends: xbmc-skin-confluence (= 1:9.11-lucid2) but it is not going to be installed or
                 xbmc-skin-pm3-hd (= 1:9.11-lucid2) but it is not going to be installed
        Depends: xbmc-web-pm3 (= 1:9.11-lucid2) but it is not going to be installed
E: Broken packages

is there any other information that i can give you? pls halp!
tried apt-get -f install xbmc ?
travnewmatic Wrote:total noob, not really sure whats going on. i'm using debian lenny. i've added the repos and the key.

Code:
[email protected]:~$ sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xbmc: Depends: xbmc-data (= 1:9.11-lucid2) but it is not going to be installed
        Depends: xbmc-skin-confluence (= 1:9.11-lucid2) but it is not going to be installed or
                 xbmc-skin-pm3-hd (= 1:9.11-lucid2) but it is not going to be installed
        Depends: xbmc-web-pm3 (= 1:9.11-lucid2) but it is not going to be installed
E: Broken packages

is there any other information that i can give you? pls halp!

Have you added the nvidia vdapu ppa?
Quote:Have you added the nvidia vdapu ppa?
How would that fix the problem?

I am no linux expert but if the repositories he have added is for Lucid and he is using lenny this might be worth thinking about?
damn, I completely missed that part! travnematic, either install ubuntu according to the XBMCbuntu guide or make yourself familiar with compiling from SVN, a good start may be this here:
http://forum.xbmc.org/showthread.php?tid=41582
by the way, about this "packages have been kept back" and unmet dependencies (?) problem some of us are experiencing with newer xbmc SVN builds:

every time this error occurs it helps when I purge the repository and directly afterwards do an apt-add-repository again. can't find out what exactly causes these package problems... for the noobs, please google the exact commands to do this kinda stuff in ubuntu. it's not that difficult.

btw I'm doing this on a XBMCbuntu installation of lucid 64bit. a little annoying but that's what you pay for staying up-to-date Wink
Not able to update

added repos and vdpau repos I get this far


Code:
previously deselected package libvdpau1.
(Reading database ... 41192 files and directories currently installed.)
Unpacking libvdpau1 (from .../libvdpau1_0.4-2~karmic~nvidiavdpauppa4_i386.deb) ...
Preparing to replace xbmc-live 1:9.11+svn28256-hardy1 (using .../xbmc-live_1%3a10.08~svn31718-hardy1_all.deb) ...
Unpacking replacement xbmc-live ...
Preparing to replace xbmc-standalone 1:9.11+svn28256-hardy1 (using .../xbmc-standalone_1%3a10.08~svn31718-hardy1_all.deb) ...
Unpacking replacement xbmc-standalone ...
Preparing to replace xbmc-web 1:9.11+svn28256-hardy1 (using .../xbmc-web_1%3a10.08~svn31718-hardy1_all.deb) ...
Unpacking replacement xbmc-web ...
Preparing to replace xbmc-skin-confluence 1:9.11+svn28256-hardy1 (using .../xbmc-skin-confluence_1%3a10.08~svn31718-hardy1_all.deb) ...
Unpacking replacement xbmc-skin-confluence ...
Preparing to replace xbmc-data 1:9.11+svn28256-hardy1 (using .../xbmc-data_1%3a10.08~svn31718-hardy1_all.deb) ...
Unpacking replacement xbmc-data ...
dpkg: error processing /var/cache/apt/archives/xbmc-data_1%3a10.08~svn31718-hardy1_all.deb (--unpack):
trying to overwrite `/usr/share/xbmc/system/python/python24.zip', which is also in package xbmc-bin
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace xbmc-bin 1:9.11+svn28256-hardy1 (using .../xbmc-bin_1%3a10.08~svn31718-hardy1_i386.deb) ...
Unpacking replacement xbmc-bin ...
Selecting previously deselected package xbmc.
Unpacking xbmc (from .../xbmc_1%3a10.08~svn31718-hardy1_all.deb) ...
Errors were encountered while processing:
/var/cache/apt/archives/xbmc-data_1%3a10.08~svn31718-hardy1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~/.xbmc/userdata$ sudo apt-get install xbmc-bin
Reading package lists... Done
Building dependency tree      
Reading state information... Done
xbmc-bin is already the newest version.
xbmc-bin set to manually installed.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  xbmc: Depends: xbmc-data (= 1:10.08~svn31718-hardy1) but 1:9.11+svn28256-hardy1 is to be installed
  xbmc-data: Depends: xbmc-bin (< 1:9.11+svn28256-hardy1.1~) but 1:10.08~svn31718-hardy1 is to be installed
  xbmc-skin-confluence: Depends: xbmc-data (= 1:10.08~svn31718-hardy1) but 1:9.11+svn28256-hardy1 is to be installed
  xbmc-standalone: Depends: xbmc-data (= 1:10.08~svn31718-hardy1) but 1:9.11+svn28256-hardy1 is to be installed
  xbmc-web: Depends: xbmc-data (= 1:10.08~svn31718-hardy1) but 1:9.11+svn28256-hardy1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[email protected]:~/.xbmc/userdata$ xbmc
Error: unable to open display
XBMC needs hardware accelerated OpenGL rendering.
Install an appropriate graphics driver.

Please consult XBMC Wiki for supported hardware
http://wiki.xbmc.org/?title=Supported_hardware
[email protected]:~/.xbmc/userdata$

any suggestions

Thanks

Craig
Try the commands below:
Code:
sudo dpkg -i --force-all /var/cache/apt/archives/xbmc-data_1%3a10.08~svn31718-hardy1_all.deb
sudo apt-get install -f

I have similar problems in Lucid, it seems that there are some files packaged in more than one of the xbmc ppa packages.
Is there currently a problem with the SVN PPA?

I have tried to update, butg up as nothing is coming up as available and am still stuck on the 31718 build from 12/7, but looking at the ppa info the latest build is from today and is 31819
tdw197 Wrote:Is there currently a problem with the SVN PPA?

I have tried to update, butg up as nothing is coming up as available and am still stuck on the 31718 build from 12/7, but looking at the ppa info the latest build is from today and is 31819

When it says "Waiting to Build", there probably isn't a build. You need to drill down by clicking "Package Details" to see exactly which builds have or have not been built.

Yes, it appears that something is wrong with the PPA.
i'm trying to update my xbmc camelot box to an svn box however i'm getting dependency issues .. also its trying to install 31718 and i'd prefer to get something over 31783 (as that fixes a bug i'd like to avoid) .. guess i have to wait a day or 2 for svn to get fixed ?