Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
pletopia Wrote:i'm trying to update my xbmc camelot box to an svn box however i'm getting dependency issues .. also its trying to install 31718 and i'd prefer to get something over 31783 (as that fixes a bug i'd like to avoid) .. guess i have to wait a day or 2 for svn to get fixed ?

To get over the depndencies issue you need to completely remove xbmc and the install from the svn ppa, there's an odd bug when trying to upgrade, but reinstall works fine.

Don't know about the 31718 issue though...
xanadu1979 Wrote:Yes, it appears that something is wrong with the PPA.

Ah great.. I have the same issue here.. Was wondering what might be wrong with my machine..
are the ppa's actually getting built ??

i took a look at launchpad and its listing 1:10.08~svn31846-karmic1 .. yesterday i forget what revision it showed but it was definately higher then 31718 however thats the rev it tried to install when i ran apt-get upgrade xbmc

both yesterday and today the www list's "waiting to build"
pletopia Wrote:are the ppa's actually getting built ??

i took a look at launchpad and its listing 1:10.08~svn31846-karmic1 .. yesterday i forget what revision it showed but it was definately higher then 31718 however thats the rev it tried to install when i ran apt-get upgrade xbmc

both yesterday and today the www list's "waiting to build"

It was showing 31819 y'day. I guess they are not getting built.

We will need the OP to confirm really.
tdw197 Wrote:It was showing 31819 y'day. I guess they are not getting built.
yeah, that looks familiar .. but like today's .. even late last night it was still listed as "Waiting to build"
I've been force to switch to the SVN as I need AAC transcodeing support. it appears broken at the moment.

[email protected]:~/downloads$ sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbmc: Depends: xbmc-data (= 1:9.11+svn28256-jaunty1) but it is not going to be installed
Depends: xbmc-skin-confluence (= 1:9.11+svn28256-jaunty1) but it is not going to be installed or
xbmc-skin-pm3-hd (= 1:9.11+svn28256-jaunty1) but it is not going to be installed
Depends: xbmc-web (= 1:9.11+svn28256-jaunty1) but it is not going to be installed
E: Broken packages

If I then try
[email protected]:~/downloads$ sudo apt-get install xbmc-data xbmc-bin xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbmc-bin: Depends: libmicrohttpd5 (>= 0.4.0) but it is not installable
E: Broken packages


so it looks like the package libmicrohttpd5 is missing, should i log a ticket for this?
redstorm, please have a look at the last few pages of this thread, there's a lot of talk about purging the SVN PPA completely and afterwards re-adding it, which seems to help in every case
I managed to get the svn to install but it only installed 28256, looking at the ppa its been failing to build the i386 package for i386 jaunty for quite some time.

please can one of the packagers needs to have a look at i386 for jaunty and fix the build issues.
redstorm Wrote:I managed to get the svn to install but it only installed 28256, looking at the ppa its been failing to build the i386 package for i386 jaunty for quite some time.

please can one of the packagers needs to have a look at i386 for jaunty and fix the build issues.

Having the same issue for months now. I finally decided to look at why my XBMC is not upgrading even though it's on the nightly PPA and found this. Thanks redstorm!

Please can one of the builders fix the Jaunty i386 (very popular build i would imagine) in the PPA?

Many thanks,

Ariel.
At the moment the svn is only building for amd64 when wil it starten building i386 again?
Does SVN not working has anything to do with this post about the Dharma branch?:
http://xbmc.org/theuni/2010/07/18/dharma-branched/
I got desperate last night and compiled the SVN, i confirmed it fixed my issue with playing AAC encoded files. but I lost VDPAU support as I could not install the dependancies. So i had to back it out to 26018.

It looks like the nvidia ppa is giving karmic binaries even though is set to jaunty in my sources. whats up with that?

sudo apt-get build-dep xbmc

Get:1 http://ppa.launchpad.net jaunty/main libvdpau1 0.4-2~karmic~nvidiavdpauppa4 [24.9kB]
Get:2 http://us.archive.ubuntu.com jaunty/main libtasn1-3-dev 1.5-1 [358kB]
Get:3 http://ppa.launchpad.net jaunty/main libvdpau-dev 0.4-2~karmic~nvidiavdpauppa4 [42.3kB]
Get:4 http://us.archive.ubuntu.com jaunty-updates/main libgnutls-dev 2.4.2-6ubuntu0.1 [402kB]
Get:5 http://us.archive.ubuntu.com jaunty-updates/main libcurl4-gnutls-dev 7.18.2-8ubuntu4.1 [900kB]


Errors were encountered while processing:
/var/cache/apt/archives/libvdpau1_0.4-2~karmic~nvidiavdpauppa4_i386.deb
/var/cache/apt/archives/libvdpau-dev_0.4-2~karmic~nvidiavdpauppa4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
E: Failed to process build dependencies

I'm not supprised it errors as im running Jaunty not karmic.

Not sure what to do now, with the PPA busted for i386 and being unable to install the build dependancies for jaunty for vdpau im backed into a corner...

Great work though , when the packages are working life is easy...
I looked into the build logs for i386 - it looks like there is an error in compiling ffmpg:

--------------------------------------------------------------------

CC libavcodec/x86/dsputil_mmx.o
libavcodec/x86/h264dsp_mmx.c: In function 'h264_h_loop_filter_luma_mmx2':
libavcodec/x86/dsputil_mmx.c:731: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
libavcodec/x86/dsputil_mmx.c:731: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/h264dsp_mmx.c:634: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/h264dsp_mmx.c:634: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
libavcodec/x86/dsputil_mmx.c:731: error: 'asm' operand has impossible constraints
make[3]: *** [libavcodec/x86/dsputil_mmx.o] Error 1
make[3]: Leaving directory `/build/buildd/xbmc-10.08~svn31938/xbmc/cores/dvdplayer/Codecs/ffmpeg'
make[2]: *** [ffmpeg] Error 2
make[2]: Leaving directory `/build/buildd/xbmc-10.08~svn31938/xbmc/cores/dvdplayer/Codecs'
make[1]: *** [dvdpcodecs] Error 2
make[1]: Leaving directory `/build/buildd/xbmc-10.08~svn31938'
dh_auto_build: make returned exit code 2
make: *** [build] Error 1
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20100718-0832
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/xbmc-10.08~svn31938

-------------------------------------------------

According to another forum post this was a known bug, and USE=-pic solves the problem.

That's if you know what that actually means Wink
it looks to me like this change was supposed to fix things:
http://trac.xbmc.org/changeset/31853

but for some reason it didn't? maybe we just need to wait a couple of days until it's picked up?
This seems to be what's killing the PPA now. I grabbed this from the SVN PPA build log.

Code:
checking for libcrystalhd/libcrystalhd_if.h... yes
checking for libcrystalhd soname... no
configure: error: Unable to determine soname of libcrystalhd library
make[1]: *** [override_dh_auto_configure] Error 1
make[1]: Leaving directory `/build/buildd/xbmc-10.08~svn31996'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20100720-0830
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/xbmc-10.08~svn31996