Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Zemy Wrote:Here:
[email protected]:~$ apt-cache policy xbmc
xbmc:
Installed: 2:10.0~svn32789~deb1-1~0lucid1
Candidate: 2:10.0~svn32789~deb1-1~0lucid1
Version table:
*** 2:10.0~svn32789~deb1-1~0lucid1 0
100 /var/lib/dpkg/status
1:10.08~svn33040-lucid1 0
500 http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu/ lucid/main Packages
1:9.11-lucid3 0
500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ lucid/main Packages

Br, Zemy
Your XBMC version starts with 2:10.0 so you must follow the steps explained by X3lectric:
X3lectric Wrote:this choppy video playback complaining & moaning, have you tested the files in question from local hdd as comparing same file over smb or your protocol of choice, does it still happen?

@zemmy if your xbmc installed version starts with 2:10.08 then you need to purge it, apt-get clean, apt-get update and install xbmc manually.
don't flame to bad here,

but I notice I have 1:10.08 and zemy has 2:10.0

is one a stable vs nightly build?

-=Jason=-

EDIT:
Code:
[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  xbmc xbmc-bin xbmc-data xbmc-live xbmc-skin-confluence xbmc-standalone
  xbmc-web xserver-xorg-video-intel
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
[email protected]:~$

EDIT EDIT:
I had to upgrade my dist for some odd reason

all is working right meow


-=Jason=-
Zemy Wrote:Here:
[email protected]:~$ apt-cache policy xbmc
xbmc:
Installed: 2:10.0~svn32789~deb1-1~0lucid1
Candidate: 2:10.0~svn32789~deb1-1~0lucid1
Version table:
*** 2:10.0~svn32789~deb1-1~0lucid1 0
100 /var/lib/dpkg/status
1:10.08~svn33040-lucid1 0
500 http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu/ lucid/main Packages
1:9.11-lucid3 0
500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ lucid/main Packages

Br, Zemy

Ya you need to purge 2:10.0~svn32789 and install 1:10.08~svn33040 after this it should be ok.

@Flomaster

the 2:10.0~svn32789 was ceros svn ppa compile he bumped version to use epoch 2 (2:10.0~svn32789) TheUni compiles same xbmc svn ppa with epoch 1 (1:10.08~svn33040) their same svn ppa neither one is more then other, except that the next xbmc stable will be tagged 10.0 not 10.08 or 10.05

either way 2:whatever is higher then 1: whatever you cant upgrade a package of lesser version, period.
Is there any way that as you "edit" your post to keep us up to date that you could add the current svn r that you are sporting in your build? It would be informative and save the time of having to go over and dig it up. Just a thought. Maybe it is there and I missed it.
@ TutAmongUs

who are you asking, for what?
my best guess is that he asks if you could update your thread with the XBMC build number that you are currently hosting on your repo
er its on my signature team iquik ppas and open them and check.

for stable check xbmc-stable for svn check xbmc-svn, it doest require me posting anything else.
well, as I said, I was just guessing Wink

maybe he also asks if wattazoum could edit the first post of the ppa thread to reflect the current build but again, this information is only 1 or 2 clicks away...
Are the official PPA's still down?
X3lectric Wrote:this choppy video playback complaining & moaning, have you tested the files in question from local hdd as comparing same file over smb or your protocol of choice, does it still happen?

@zemmy if your xbmc installed version starts with 2:10.08 then you need to purge it, apt-get clean, apt-get update and install xbmc manually.

Ok, now proceeded the actions an ended to this:

The following packages have unmet dependencies:
xbmc: Depends: xbmc-data (= 1:10.08~svn33078-lucid1) but 2:10.0~svn32789~deb1-1~0lucid1 is to be installed
Depends: xbmc-skin-confluence (= 1:10.08~svn33078-lucid1) but 2:10.0~svn32789~deb1-1~0lucid1 is to be installed
Depends: xbmc-web (= 1:10.08~svn33078-lucid1) but 2:10.0~svn32789~deb1-1~0lucid1 is to be installed
E: Broken packages

Br, Zemy
Zemy Wrote:Ok, now proceeded the actions an ended to this:

The following packages have unmet dependencies:
xbmc: Depends: xbmc-data (= 1:10.08~svn33078-lucid1) but 2:10.0~svn32789~deb1-1~0lucid1 is to be installed
Depends: xbmc-skin-confluence (= 1:10.08~svn33078-lucid1) but 2:10.0~svn32789~deb1-1~0lucid1 is to be installed
Depends: xbmc-web (= 1:10.08~svn33078-lucid1) but 2:10.0~svn32789~deb1-1~0lucid1 is to be installed
E: Broken packages

Br, Zemy

I think I made it. The advice from X3lectric + removing svn entries from /etc/apt/sources.list.d
That removing should be done first I think. Big Thanks X3lectric and other
helpers.

Br, Zemy
Sorry for disturbing again...
Update did well as seen above..but now it boots to
login screen and not to xbmc directly. I am sure that the problem
has been solved here in forum didn't find the right one to help me.
Can someone assist?

Br, Zemy
are you sure you also installed xbmc-live/xbmc-standalone?

test with: xinit xbmc-standalone at command line
Hannes The Hun Wrote:are you sure you also installed xbmc-live/xbmc-standalone?

test with: xinit xbmc-standalone at command line

That must be it. Thanks. I will check. Should only one of those should be
installed also xbmc-live/xbmc-standalone?

Br, Zemy
if you install either one of them, the other one will be installed as well (remember, dependencies Wink )