Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
publicENEMY Wrote:ive setup xbmc dharma rc2 on my windows 7 just fine. i was thinking, could i get the same experience on linux? i was thinking setting up a very low spec pc for my minimal linux installation with xbmc as my htpc. the setup must be able to play hardware accelerated fullhd and hardware accelerated flash media. is this possible? if it is, where can i gather more information? by the way, im thinking of installing myth in order to record/support tv.

Asrock ION HT hands down the easiest and most complete most documented machine with xbmc and it comes with remote.

Its what I have and wouldnt swap it for any other, perhaps a ION2 like the asrock 3d vision 146B.

revos are ok but the acer support is non existent in UK... I know from experience.
Newbie here - got XBMC up and running end of last week, very happy with it. Running on Ubuntu 10.10, having followed the guide to installing XBMC on Ubuntu in the Wiki.

No problems then however.... I'm running XBMC 9.11 r26018. I installed the iPlayer plugin from the SVN installer plugin and it's come up with an error saying that I have an older version of XBMC and should look to update. The plugin itself will stream radio, but for video when I select the programme I want it runs through the dialog boxes and says that it's playing but never actually appears on the screen.

So, off to terminal for sudo apt-get upgrade
(I'm new to linux, so be gentle please!)
I get the following error:
Failed to fetch http://ppa.launchpad.net/team-xmbc/ppa/u...ackages.gz

Trying sudo add-apt-repository ppa:team-xmbc/ppa
Gives me the following error:
Error reading https://launchpad.net/api/1.0/~team-xmbc/+archive/ppa: HTTP Error 404: Not Found

To my beginner brain this looks like the repository that I originally used to get XBMC is for some reason not accessible (feel free to correct Smile)

What or where do I try next?

Thanks in advance
It's case sensitive.
Use that command: sudo add-apt-repository ppa:team-xbmc-svn/ppa
+1 burning sky
If there was an embarassed smiley, I would be using it.

Thank you, much appreciated. I still get the Failed to fetch http://ppa.launchpad.net/team-xmbc/ppa/u...ackages.gz 404 Not Found
when I do update, but I've carried on with upgrade anyway and stuff has happened. I shall now find out if it's solved my problem!

Thank you for taking the time to point me in the right direction, glad it was an easy one! Lesson learned...
Wurls80 Wrote:I still get the Failed to fetch http://ppa.launchpad.net/team-XBMC/ppa/u...ackages.gz 404 Not Found

Remove the wrong team-XBMC*.list in /etc/apt/sources.list.d/
Thanks once again.....

The capital letters really stood out once I saw the post on the screen, time to use the preview button more.

Interestingly I didn't have any team-XBMC in there (with capital letters) but removing the team-XBMC there means I no longer get the error when doing an update.

I've done update and upgrade, but when I start xbmc I'm not finding any difference, or getting any indication that a later version is available.

What basic step have I missed now?

Out of interest, my source.list.d folder contains:

Then all of the above with .save at the end as well.

nvidia one is for the graphics acceleration, I guess team-xbmc is for xbmc and xbmc-svn is for the svn installer add-on? So what is the lucid.partner one (and the .save versions) for? Just out of interest.

Thanks once again - uh, again
you have the stable (still camelot) ppa and the SVN ppa (current dharma builds) added at the same time

you can see build number under system settings or info or wherever that was, please do some searching
Got ya - thank you for the confirmation that I had the right repositories identified and that, as a result, I am running the latest current stable build. I was a little confused because the iPlayer plugin was suggesting that I needed a later version for full functionality, but it would appear that it is suggesting I need to upgrade to one of the dharma builds to do so.

I can confirm from the system settings that I'm running XBMC 9.11 r26018.

Presumably when XBMC is looking for the "latest" version the stable ppa repository takes precedence over the svn ppa one? Is there an option anywhere that I can use to point it at the svn ppa repository, or is my only option to remove the stable one if I want to chance an upgrade to the dharma builds?

Thanks once again, every day's a school day at the moment
Dharma Final ready on team-xbmc-svn ppa.

Thanks to XBMC team for everything.

OMG that's awesome, a final for christmas! gonna try it out tonite
The changelog seems to imply that this has VAAPI support. Does anyone know if this is true for the stable Ubuntu Dharma 10.0 pkg? I've installed it and still don't see the option in my video playback menu.
Are the PPAs no longer being made?
not at the moment I have made a nice guide in how to compile from GIT since XBMC dropped SVN.

I also have ppas going for whoever can find them since they are meant for XCI script users mainly
I am getting a segmentation fault with an xbmc install from the team-xbmc-svn/ppa repository. I have also tried the team-xbmc one, but still the same issue. It's a bit weird though. Except for the GLX window thing, there is no obvious culprit in the log file as far as I can see.

When I try to launch xbmc after the installation is done, the screen flashes black (no splash logo) for an instant and then it reverts back to the regular gnome desktop.

Is this just happening for me, or is it a bug? I can't say that I have found any posts etc mentioning it.

Could anyone please assist? I made a pastebin with the crash log and terminal dump here below:

crash log and terminal dump