Kodi Community Forum

Full Version: Kodi not playing recently added videos - but plays previously added
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all, 

Not sure if this is the right place but i have an issue where your thoughts would be appreciated.  Log file here: ituvipigos (paste)

I have been running Kodi for almost 2 years now, it draws from a Qnap 412 I have set up with my movies/videos across my home network.  All has been going fine until recently.  I downloaded a youtube concert (U2 Apollo), added it to my Qnap and tried playing through Kodi.  But for some reason, Kodi does not want to play it.  The file shows up, but will not play.  It will play all media added previous to this new file.

I wiped my machine, reinstalled Ubuntu and Kodi - but same deal, will play all other media, but not that file.  I can play that file from all machines which connect to the NAS using VLC - but not from the reinstalled Kodi.

I tried downloading some more files and adding movies using the same means as previous, but the same thing happens.  Anything newly added will now not play from Kodi.

Any ideas on what could be the problem??  This is tearing my hair out - Kodi is great, but if i can't add media, whats the point.  My NAS seems fine.

I have scoured the web but can't find anything resembling these symptoms.

Thanks heaps in advance.

Cheers,

Dan
Hello @NZchoppa

It looks like Kodi has no access to the file according to the log lines 642...

    INFO: CNFSFile::Open: Unable to open file : 'Multimedia/Music Videos/U2/U2 Apollo 2018.mkv'  error : 'open call failed with "NFS: ACCESS denied. Required access r--. Allowed access ---"'
ERROR: CVideoPlayer::OpenInputStream - error opening [nfs://10.1.1.7/Multimedia/Music Videos/U2/U2 Apollo 2018.mkv]
Hmm, so could it be that there has been a change in permission settings for files now being added to the NAS?

thanks so much for your time

Cheer

D
Would be interesting to see how your /etc/exports-file looks like.

For me it looks like the user you are using to access the share doesn't have "read"-rights (due to the missing "r--"). If you mount that share locally on your ubuntu machine and do ls -al what kind of rights are given to that file/folder?
Hi Davu, 

Thanks for your query.  In mounting the QNAP locally to the ubuntu box, what would be the best command to do this (apologies for my novice query, i normally figure these out myself but i dont want to wast your time in providing an answer)?

All the permissions for the file seem ok, as compared ones that do work.  However, on the file that doesn't work, the 'allow' permissions are grey, whereas on the files that work, these are solid black.

Cheers,

Dan
righty

i mounted the NAS drive locally on the ubuntu box using: sudo mount -t cifs -o username=admin,password=admin //<QNAP ADDRESS> <LOCAL MOUNT POINT>

dove into a folder where i had a playable file and one that didn't work - did ls -al and both files read: -rwxr-xr-x 1 root root

does this assist things?

its just weird, Kodi sees the file there, but wont do anything with it

cheers

Dan
(2018-07-03, 04:22)Karellen Wrote: [ -> ]error opening [nfs://10.1.1.7/Multimedia/Music Videos/U2/U2 Apollo 2018.mkv]

The share you are using is an NFS share.

By this command:
(2018-07-03, 13:03)NZchoppa Wrote: [ -> ]sudo mount -t cifs -o .......
You are mounting an Samba share. That might be different.

Mounting an nfs share is done by the following command on Ubuntu:

mount <IP_of_NFS_server>:/path/to/share /nedia/mountpoint

To check how the share is named exactly please via: showmount -e <ip_of_nfs_server>

You might have different rights on different protocols. So please mount the NFS share. Then switch to that mounted share by cd /media/<mountpoint> and then get me the output of the ls -alR <U2-foldername>

That will then list the folder and its containing files within the specific rights.

Also still need to see the /etc/exports
thanks mate - i'll do this and get back to you asap

cheers

d
so, the data i have is of another folder (i may have deleted the U2 example),

the output from: ls -alR, is:

.:
total 446108
drwxrwxrwx  3 root root      4096 Jul  3 20:10  .
drwxrwxrwx 10 root root      4096 Jul  2 21:14  ..
-rwxrwx---  1 root root  47889197 Jul  3 20:10 'Brandon Flowers - Still Want You Direct.mp4'
-rwxrwx---  1 root root  47889197 Jul  2 22:15 'Brandon Flowers - Still Want You NW.mp4'
-rw-rwxrw-  1 root root 360995773 May 10  2015 'Brandon Flowers - Vive Latino 2015.mp4'
drwxrwxrwx  3 root root      4096 Jul  3 20:12  [email protected]__thumb

./[email protected]__thumb:
total 252
drwxrwxrwx 3 root root  4096 Jul  3 20:12  .
drwxrwxrwx 3 root root  4096 Jul  3 20:10  ..
lrwxrwxrwx 1 root root   113 Jul  3 20:12 'a100Brandon Flowers - Still Want You Direct.mp4' -> '/share/MD0_DATA/Multimedia/Music Videos/Brandon Flowers/[email protected]__thumb/s100Brandon Flowers - Still Want You Direct.mp4'
lrwxrwxrwx 1 root root   106 Jul  3 13:07 'a100Brandon Flowers - Still Want You NW.mp4' -> '/share/MD0_DATA/Multimedia/Music Videos/Brandon Flowers/[email protected]__thumb/s100Brandon Flowers - Still Want You.mp4'
-rw-rwxrw- 1 root root  3765 May 10  2015 'a100Brandon Flowers - Vive Latino 2015.mp4'
lrwxrwxrwx 1 root root   116 Jul  3 20:12 'adefaultBrandon Flowers - Still Want You Direct.mp4' -> '/share/MD0_DATA/Multimedia/Music Videos/Brandon Flowers/[email protected]__thumb/defaultBrandon Flowers - Still Want You Direct.mp4'
lrwxrwxrwx 1 root root   109 Jul  3 13:07 'adefaultBrandon Flowers - Still Want You NW.mp4' -> '/share/MD0_DATA/Multimedia/Music Videos/Brandon Flowers/[email protected]__thumb/defaultBrandon Flowers - Still Want You.mp4'
-rw-rwxrw- 1 root root 46410 May 10  2015 'adefaultBrandon Flowers - Vive Latino 2015.mp4'
-rw-rw-rw- 1 root root 16038 Jul  3 20:10 'defaultBrandon Flowers - Still Want You Direct.mp4'
-rw-rwxrw- 1 root root 16038 Jul  2 22:15 'defaultBrandon Flowers - Still Want You NW.mp4'
-rw-rwxrw- 1 root root 13194 May 10  2015 'defaultBrandon Flowers - Vive Latino 2015.mp4'
-rw-rw-rw- 1 root root  3483 Jul  3 20:10 's100Brandon Flowers - Still Want You Direct.mp4'
-rw-rwxrw- 1 root root  3483 Jul  2 22:15 's100Brandon Flowers - Still Want You NW.mp4'
-rw-rwxrw- 1 root root  2472 May 10  2015 's100Brandon Flowers - Vive Latino 2015.mp4'
-rw-rw-rw- 1 root root 38636 Jul  3 20:10 's800Brandon Flowers - Still Want You Direct.mp4'
-rw-rwxrw- 1 root root 38636 Jul  2 22:15 's800Brandon Flowers - Still Want You NW.mp4'
-rw-rwxrw- 1 root root 16568 May 10  2015 's800Brandon Flowers - Vive Latino 2015.mp4'
drwxrwxrwx 2 root root  4096 Jul  3 20:07  transcode

./[email protected]__thumb/transcode:
total 16
drwxrwxrwx 2 root root 4096 Jul  3 20:07 .
drwxrwxrwx 3 root root 4096 Jul  3 20:12 ..

Only the 'Vivo Lantino' file plays fine, the Direct and NW versions do not play at all.  

I couldn't find an etc/exports file, where else could i look?

Thanks and cheers,

Dan
(2018-07-08, 15:03)NZchoppa Wrote: [ -> ]-rwxrwx---  1 root root  47889197 Jul  3 20:10 'Brandon Flowers - Still Want You Direct.mp4'
-rwxrwx---  1 root root  47889197 Jul  2 22:15 'Brandon Flowers - Still Want You NW.mp4'
-rw-rwxrw-  1 root root 360995773 May 10  2015 'Brandon Flowers - Vive Latino 2015.mp4'

Only the 'Vivo Lantino' file plays fine, the Direct and NW versions do not play at all.  

Vive is rw-rwxrw-
Direct and NW are rwxrwx---

chmod 666 *.mp4 in that folder should solve it. (Or chmod 664 if you don't need to give write permissions to other.) I have to do this to files I copy to my QNAP from my Mac, as they get copied 770.
Thanks mate, I'll give this a crack,

Cheers,

D
Long shot here, but I have run into odd behaviours on remotely mounted stuff that had spaces in the title. Any chance that only the files you are having issues with have spaces in the titles?