Kodi Community Forum

Full Version: The Movie Db scraper 5.1.3, Kodi 17.6: couldn't connect to remote server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
This has been going on for a while, finally getting around to fixing it. Just updated TMDB a few minutes ago, didn't fix it. 

Found this in my logs but it doesn't seem helpful: 

$ cat .kodi/temp/kodi.log| grep tvdb

20:16:28.505 T:140645031646976   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?na...anguage=en
20:16:28.707 T:140645031646976   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name= redacted|Authorization=Bearer%20eyJhbGciOiJSUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1MzE4ODMzOTIsImlkIjoiS29kaSIsIm9yaWdfaWF0IjoxNTMxNzk2OTkyfQ.sh6MKWApp19MFyeSKXIqZOjD-h30gVOxhX35BABKuWUTVuAQDExjoQrI3dWtm4-KkUFLBr22X2SacsBM78RDVhk69MOinx-73GWPcKUIhpTig2PaO-jK5BEyiGtTfVsSubX1_iKrMrwCw8mjl7VfuMisp0Wq_bR5P4at6oM8aMtf_nRrsddCFFomOcPC34I8E8r5u30AUgxwdaprZJteP1_oNYve_xAvqYIwAjloPp_oORVEkzHxmxJD7mBu12bdjDMq-t8jUZrzo1muB-CqXyezZvr5FIf88Ro-TM7tal5jewyhnBsgHhYrgiD3mAo6BTW-FXhQH1eX1hRmFO-rew&accept-language=en


The error is "Unable to connect to remote server"

I found a thread about this but it involved libreelec and it sounded like I'd need to reinstall the OS -- that sounds off. 

What's next?
We need the full Debug Log thanks.

Also the link to the movie you are trying to scrape. If multiple movies, then just pick one.
https://pastebin.com/6LYZUMaw 

Movie: https://www.themoviedb.org/movie/430043-...anguage=en

Doesn't matter what movie I try to update though.
Thanks but no good. And I need the FULL Log. For some reason you decided to chop the exact bits I needed.

Follow these 4 steps in this exact order.
  1. Enable Debugging mode. Go to Settings>System Settings>Logging and it should be the first option
  2. Restart Kodi
  3. Replicate the problem.
  4. Upload the log to https://paste.ubuntu.com/ manually or use the Kodi Logfile Uploader. With either method post the link back here.
Note: Full logs only. No partial or redacted logs
I didn't redact anything. That's the full output of the log. The movie query is in there. I turned on logging, queried the db for the movie then ran cat on the log file.

I'll do it all again if it'll make you happy.
Turned on debug logging. 

Shutdown computer (there's no restart kodi option from the kodi system menu). 

Queried 3 movies. They all failed. 

Turned off debug logging. 

Log: https://paste.ubuntu.com/p/dS4Tgbrc5x/
Much better.

This is how you have set your folder structure and named your movie...
DEBUG: VideoInfoScanner: No NFO file found. Using title search for '/media/saturn-movies/Bad Day for the Cut (2017)/99c0ba228b343e32125a9e47104f732c tmp/Bad Day for the Cut (2017).mp4'

This is what the scraper is searching for...
DEBUG: FindMovie: Searching for '99c0ba228b343e32125a9e47104f732c tmp' using The Movie Database scraper (path: '/home/media/.kodi/addons/metadata.themoviedb.org', content: 'movies', version: '5.1.3')

Get rid of that tmp folder between the movie folder and the playable file. That should fix the problem.
That didn't fix it. 

Log: https://paste.ubuntu.com/p/Fc5nhs22fX/

Same error. Also I queried two other movies that had previously queried successfully last time and got the same error.

Also when I hit the URL in the log:

https://api.tmdb.org/3/search/movie?api_...anguage=en

I get a response: 

{"page":1,"total_results":1,"total_pages":1,"results":[{"vote_count":34,"id":430043,"video":false,"vote_average":6.6,"title":"Bad Day for the Cut","popularity":4.137,"poster_path":"\/53Jh8cMCfDOI87XnPBCIiTCwN6U.jpg","original_language":"en","original_title":"Bad Day for the Cut","genre_ids":[53],"backdrop_path":"\/yTkPVSqQg4icpkzfO1o4uwkJxj3.jpg","adult":false,"overview":"A middle-aged Irish farmer, who still lives at home with his mother, sets off on a mission of revenge when the old lady is murdered.","release_date":"2017-01-22"}]}

So this looks like a bug in the tool.
As I have stated previously we need the FULL LOG not the bits you feel like giving us. There is nothing scraping related in that link you gave.

Are you exiting Kodi before accessing the log?
Dude I am running `$ cat .kodi/temp/kodi.log` and giving you the output. I don't know why you keep thinking I'm truncating or something. WTF. I am not exiting Kodi.

This: 

Code:
20:49:47.559 T:140107327342976 DEBUG: ------ Window Init (DialogConfirm.xml) ------ 20:49:47.559 T:140107327342976 DEBUG: [Warning] CGUITextureManager::GetTexturePath: could not find texture 'noop' 20:49:48.208 T:140105233671936 DEBUG: Thread VideoInfoDownloader start, auto delete: false 20:49:48.208 T:140105233671936 DEBUG: FindMovie: Searching for 'Bad Day for the Cut' using The Movie Database scraper (path: '/home/media/.kodi/addons/metadata.themoviedb.org', content: 'movies', version: '5.1.3') 20:49:48.221 T:140105233671936 DEBUG: scraper: CreateSearchUrl returned <url>https://api.tmdb.org/3/search/movie?api_key=45ab4cebe57ae11c2ee50c87005ddfe8&amp;query=Bad%20Day%20for%20the%20Cut&amp;year=2017&amp;language=en</url> 20:49:48.221 T:140105233671936 DEBUG: CurlFile::Open(0x6255090) https://api.tmdb.org/3/search/movie?api_...anguage=en 20:49:48.221 T:140105233671936 INFO: easy_aquire - Created session to https://api.tmdb.org 20:49:48.352 T:140105233671936 ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35) 20:49:48.354 T:140105233671936 ERROR: CCurlFile::Open failed with code 0 for https://api.tmdb.org/3/search/movie?api_...anguage=en 20:49:48.359 T:140105233671936 ERROR: Run: Unable to parse web site

is not scraping related? What is going on here?

edit: here, I did it again but this time it got all ~500 lines: https://paste.ubuntu.com/p/YBh6nk24H7/ 

I don't know why it was missing 400 lines last time.
(2018-07-20, 06:58)wcanyon Wrote: [ -> ]is not scraping related? What is going on here?
You can also see why we don't want log snippets plastered into the forum... Smile

(2018-07-20, 06:58)wcanyon Wrote: [ -> ]here, I did it again but this time it got all ~500 lines
Yes, you did it again: somehow Kodi log's header was cut off, beginning with hardware and version details and other stuff... That part is not cut off automatically.
Compare your log to a random other Kodi log file: https://pastebin.com/raw/daFCRZRZ

Your log starts with 20:49:10.197 T:140107327342976 NOTICE: Previous line repeats 1 times.
Sorry, that just doesn't happen by itself, dude.
This is a screenshot of the cat of my log file. I'm not trimming it: https://imgur.com/a/2Mm4mU6

I guess I can try again but I don't see what I'm doing that could be trimming these logs. 

And anyway the portion where it's calling The Movie Database scraper is in there, so isn't that enough? My previous "acceptable" log up above should have my machine info, no?
OK here I started from the top with a restart after turning on debug logging

https://paste.ubuntu.com/p/F2tcmP36kj/ - ~2000 lines, including 

Code:
09:34:35.638 T:140153048213888 NOTICE: Starting Kodi (17.6 Git:20171114-a9a7a20). Platform: Linux x86 64-bit 09:34:35.638 T:140153048213888 NOTICE: Using Release Kodi x64 build 09:34:35.638 T:140153048213888 NOTICE: Kodi compiled Nov 4 2012 by GCC 5.4.0 for Linux x86 64-bit version 4.4.90 (263258) 09:34:35.638 T:140153048213888 NOTICE: Running on Linux Mint 18, kernel: Linux x86 64-bit version 4.4.0-21-generic

The movie I queried was Tokyo Godfathers. 

The search url is https://api.tmdb.org/3/search/movie?api_...anguage=en -- which does return a valid result. 

However the on-screen message is "Unable to connect to remote server" when I refresh this movie's info.
The problem seems to be related to CCurl and SSL error 35. It is not the scraper add-on as it is working fine elsewhere and you have the correct version installed.
09:34:47.452 T:140152564582144   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
09:34:47.452 T:140152564582144 ERROR: CCurlFile::Open failed with code 0 for https://api.thetvdb.com/login|Content-Ty...ation/json
09:34:47.454 T:140152564582144 ERROR: Run: Unable to parse web site

Nobody else is reporting this problem, so I am guessing it is something to do with Running on Linux Mint 18, kernel: Linux x86 64-bit version 4.4.0-21-generic, but I don't know enough about linux to confirm.

Maybe @Milhouse or @fritsch might know.
You state that you are having trouble with TheMovieDB scraper v5.1.3. As far as I can see, you are not having trouble with it. You are having trouble with TheTVDB scraper. Even in the code quote in your first post it states TVDB.

You don't have the current TVDB scraper installed. Update to v3.0.7

https://forum.kodi.tv/showthread.php?tid...pid2752541
Pages: 1 2