Kodi Community Forum

Full Version: Can't see network share
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all
I have just purchased an xbox x and some of that decision was based on hearing it had Kodi available. I have been wanting to ditch my wdtv for ages because of no h265 support etc.
Anyhow I am having trouble getting it connected to my pc or router's usb stick to see movies/images on them etc. I installed the media player from the windows store and it sees my computer and any shares straight away. I tried a few other media players and they do too. What is the correct process to get connected to my computer or router's usb that I'm missing? 
Is the Smb option the preferred method or using upnp or nfs? None of the media players required me to logon or do anything, is or will Kodi be this easy to setup?
Thank you
Cheers
(2018-08-04, 07:37)o0spyder0o Wrote: [ -> ]Is the Smb option the preferred method or using upnp or nfs?
Personally I'd say NFS. For SMB, version 2 and up is recommended security-wise, although not every router is that quick and happy to upgrade from the old SMBv1 protocol. Windows 1803 (and presumably Xbox, I don't have one) have by now upgraded to SMBv2 in the wake of the worldwide WannaCry outbreak.
How do we even use SMB? I signed up for the test builds but they aren't being released anymore, and the Beta 1 still doesn't support SMB.
You have Beta 1? Why do you think then new test builds aren't released any more, as that version was submitted yesterday.

Have you enabled the SMB support addon at Settings > Add-ons > My add-ons > Virtual Filesystem?
Ok so I've tried smb and still not getting any connection. Yet the store's media player and vlc see my computer and any other network connected devices without my having to configure anything. 
What am I missing still?
I'm using the alpha 3 from the store, is this the cause or should the network side be working in this release?
(2018-08-08, 14:31)o0spyder0o Wrote: [ -> ]What am I missing still?

You are missing supported the version of SMB protocol. Kodi uses SMB2/3 while vlc uses SMBv1 (at least in the last time I have checked this). You have to enable SMBv2 at your server.
(2018-08-09, 09:29)o0spyder0o Wrote: [ -> ]I'm using the alpha 3 from the store, is this the cause or should the network side be working in this release?

SMB2 addon was added in Alpha1, so yes Alpha3 supports SMB
Thanks for the clarification. So is it possible to use smb v1 with kodi via an addon? I can't change my network to use smb v2/3.
Not possible with the Windows Store version.
And let´s don´t forget.

Using SMB1 shouldn´t be the way to go. If your router only supports SMB1 (as FritzBoxes or ASUS routers do), then its NAS functionality shouldn´t be used at all. SMB1 is vulnerable, hence it was disabled for Windows by default per update. And the USB3 plug on those FritzBoxes isn´t worth to be named USB3 at all. If you search through different forums you will notice that those USB3 connections are a bottleneck. Miight probably work for low-quality video files. But I doubt you will have much fun with videos in higher quality.
If windows disabled v1 how do I see my usb stick in the router still? I haven't enabled v1 and have windows up to date,
Also if kodi will only work with smb 2 or 3, can anyone recommend what brand of modem/router I can buy that supports these variants? I can't seem to get much info from the modems I've looked at, they never mention the smb version they use. Seems most are sticking to smb v1 even on the newer usb 3 shares.
cheers
(2018-08-11, 03:46)o0spyder0o Wrote: [ -> ]If windows disabled v1 how do I see my usb stick in the router still? I haven't enabled v1 and have windows up to date,
(2018-08-10, 06:16)o0spyder0o Wrote: [ -> ]I can't change my network to use smb v2/3.
So I assumed you already changed your network to use SMBv1

Check your Windows features if SMBv1 is in use or not:

https://social.technet.microsoft.com/For...progeneral

Anyway, I might have been wrong in my wordings. Probably Windows didn't disabled SMBv1 via an update, but SMBv1 won't be installed per default anymore:

https://support.microsoft.com/en-us/help...in-windows

In the end, the recommendation to not use SMBv1 won't change. If you set your network to use SMBv1 we can only recommend to not do that. There are cases where users don't have a choice (Sonos users for example...Sonos uses SMBv1 as well). In case of sharing some thumb drive via your router I have to say that there are better solutions to share files over a network instead of using your router.
I agree that it's simple and generally a pretty cool feature those routers provide. But for the reason the manufactors don't seem to care about to update their devices and for the other reason SMBv1 is disabled by default with fresh windows installations, I would really recommend to use something else. It's a shame that AVM (which is the most common used router in the country I live in) doesn't even spend a thought about updating that. So yeah...best thing is to simply avoid the usage of that function if you are able to do so. Sharing a thumbdrive is not a case which can't be changed easily.
Ok I checked and smb v1 for the client side is checked, probably was like that pre 1803. What would you suggest the best option for sharing a drive over my network then? It seems most routers harping on about sharing are still smb 1 and only the really expensive ones have done much about it.
As in with Kodi as my network's media player, sharing is ok at the moment except for kodi requiring smb v2/3.
thanks