Kodi Community Forum

Full Version: Kodi 18 - Live TV De-interlacing and Progress Bar Issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I've been having an ongoing issue with Kodi 18 and the NextPVR Addon which I'm hoping to assist in troubleshooting. I've raised a separate issue for Timeshift already so I'll take that out of this discussion.

In essence, whenever I watch LiveTV, after about 5 Seconds I seem to lose de-interlacing (screen flickers and then its de-interlaced) and I get frequent "Kodi Progress Bar" pop-ups as well (Buffering?). As per my Timeshift issue, If I rollback to 17.6, its stable,
but I'm keen to assist in seeing if this is my hardware configuration or something else.

I'm in Australia so using NextPVR on a ML10v2 HP Micrsoserver with an SSD for the Timeshift Folder.

I've got 3 different Systems,
2 x Phenom 9750 AMD Quads with AMD R7 250 Video Cards (500GB SSDs) and
1 x Intel NUC (5xxx Series, so a bit older)

I've tried each Alpha Release along with multiple Nightlies to no avail.

I'm aware there is a NextPVR sub-thread but curious to see if other PVR Addons with Kodi 18 are experiencing similar symptoms.

Please let me know how I can assist.

Thanks!
Debug log at the link below:
https://paste.ubuntu.com/p/wVzt4Gg4rv/

Essentially, the following occurs
1. I select a channel via the Guide, it shows a playing icon at the top right of the screen, but no buffering status in Kodi.
2. After about 5 or 6 seconds, the channel plays for about 3 or 4 seconds, then the resolution changes from [email protected], to [email protected] (AU Free to Air Tv).
3. The TV Feed buffers for a few seconds, then continues to play, but then the buffering status keeps showing at random intervals while watching the channel, and I seem to lose de-interlacing after the first buffering status as well.

Again, I don't have this issue when I use Kodi 17.6.

Also, with Kodi 17.6, when I select a channel via the Guide, I get a buffering status straight away in Kodi before the channel is presented, vs Kodi 18 where I get the playing Icon in the top right, but no buffering status.
So nobody else is having this issue?

Close this out then I guess.

I'll raise another job for Live TV hanging on Nvidia Shield with Oreo.
You are not alone. I'm also seeing the deinterlacing problem in v18 under Windows 10 on two different PCs with both NVidia cards. It works fine on v17.6 but in v18 it spams the log with many errors like:

Code:
Debug Print: DXVA::CProcessorHD::InitProcessor: supported deinterlace methods: blend:yes, bob:yes, adaptive:yes, mocomp:no.
Exception thrown at 0x75CFDDC2 in kodi.exe: Microsoft C++ exception: _com_error at memory location 0x1483F1F8.
Debug Print: CWinRenderer::UpdateVideoFilter: chosen scaling method 1 is not supported by renderer
Debug Print: CRenderBuffer::GetResource: unable to open d3d11va resource.
Debug Print: DXVA::CProcessorHD::GetInputView: cannot create processor input view.
Debug Print: DXVA::CProcessorHD::Render: incomplete views set.
Debug Print: CDVDVideoCodecFFmpeg::CDropControl: calculated diff time: 40000
Debug Print: CRenderBuffer::GetResource: unable to open d3d11va resource.
Debug Print: DXVA::CProcessorHD::GetInputView: cannot create processor input view.
Debug Print: DXVA::CProcessorHD::Render: incomplete views set.
Debug Print: CRenderBuffer::GetResource: unable to open d3d11va resource.

I'm using the MediaPortal PVR addon, but the same problem is also visible via direct playback of a recording in the Video section.
I got the same issue too on the released v18, but do not have such issue on v17.6 (I use Media Portal v2.2 and Windows 10).

When you start new Live TV or switch channel, you press play backward once (play 1 to 2 second behind the Live time).  This problem will disappear until you switch to a new channel again.  It seems to be problem on time-shifting handing.