Kodi Community Forum

Full Version: Kodi 18 Beta 2 on Xbox One suddenly broken - no text visible on any screen
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
A few days ago, Kodi 18 (which had been working fine for weeks) suddenly stopped working.  When I start it, the screens display all of the expected graphics and icons, but NO TEXT is visible anywhere on any screen.

When I try to play any video (most of mine are .mkv in h.264 form), the screen suddenly shoots to "quadruple size" meaning that I can only see the upper-left corner of a vastly oversized imaged.

If I stop the video, the screen stays in the super large form, but suddenly the text is visible again.  If I kill the app and start over, I get the same general behavior from scratch.  Same if I reboot the xbox.  

I even tried uninstalling and reinstalling.  It appeared to work correctly for a short time, but then suddenly surfaced the same issues again.

Setup:  Xbox One X configured thru an HDMI amp to a 4K TV.  Videos on a Drobo 5N NAS shared over the LAN.  The Xbox is part of the "Insider's Preview Program".

What's up with this?

This surfaced one other big complaint - I could not get backup of all settings to work, so when I reinstall from scratch, it takes me forever to reconfigure all my settings again!  Please get export and import of settings working reliably!

Thank you!
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
Also check when your Xbox last updated (Settings -> System from memory)
I'm pretty sure that my Xbox One (also in one of the Insider rings) got an OS update in the last few days and that might have been what triggered the issue for you.
I've got a very similar setup, Kodi 18-BETA3 Git:20181001-22af87ccac, Xbox One X & 4k TV (resolution is set to 3840×2160, refresh rate 59.94 which is recognised by TV as 60) and I experience the same issues as it was explained by menkalos, no text then it appears again when a video is played but a display switches to "quadruple size". The temporary workaround, which works for me, is to change the resolution to 1080p instead of 2160p, so it could be something with scaling I guess.
This literally just happened to me as well. It’s completely broken
i have the same. if you manage to switch resolution text will reappear. you can then switch back to 4k and it will still be there. not a fun bug though.
same happened to me
I'm guessing it was the 10/12 XBOX update
I can't figure out how to change kodi resolution with no text
I tried changing the xbox resolution to 1080p, but it didnt fix it.
Hey guys, I had a system update on Oct 12th recently on my XBOX ONE X and Kodi stop working after that. Anyone know what happen? Thanks
When launch
Image
Image
Final step
Image
Xbox One X issues
For whatever it's worth, I guess I can also confirm this issue. If you uninstall and reinstall Kodi, it will work for the first run, but every time after that you end up with no text, on an Xbox One X. Hopefully it's something the Kodi devs can fix so we don't need to wait for a new dashboard update from Microsoft, who likely won't be pushing a new one out until the new year. Can others confirm it's unique to the Xbox One X? I'll be traveling in the not too distant future, and have a "fat" Xbox One where I'll be going that I was hoping to use with Kodi as a makeshift media center for a week or so.
I also have an Xbox One X
I have the same issue, thanks to everyone for posting about it, I thought I had some weird unique issue.

For those of you using Kodi 18 that are currently having the issue:
  1. With Kodi up and running and using the default skin, goto the settings(the gear besides the power button).
  2. Once at the Settings screen, go into the System Settings, it's the gear with the screwdriver.
  3. Once at the Systems Settings screen, the focus will be on the first item on the list, the Display Settings(which you won't be able to read).  Click once to enter and the focus will shift to the right pane.
  4. Go down one item, this will be the Resolution, and select it.  This will spawn a popup window.
  5. In the Resolution popup window, go up one item from where the focus is initially and select it.  You should be able to see the UI text again.
Hope this helps, and thank you to the Kodi team for all the years of viewing pleasure!
Pages: 1 2 3 4 5