Kodi Community Forum

Full Version: Movie scraper not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi, every time when I add new movies, the universal movie scraper does not recognize them and I have to manually add them to my movie library by using the 'scan item to library' option for each individual movie. I've gone through all the existing threads on this, but I cannot figure it out.
Are you sure you have a the latest version of the scraper add-on?
Also provide a log file via our Kodi Paste Site, perhaps something will stand out.
I'm currently using v4.1.11 of the universal movie scraper. I'll add a log of one library scan.
Okay, I've pasted the log in https://paste.kodi.tv/upegozatag.kodi.
I left out some irrelevant info.

I see that you ran an Update Library, but no new movies were found, so there was nothing to see.

What is the name of a problem movie, and try adding it to the library. Make sure it is not in the library already.
Hi, what you describe is the issue. Every time when I add a new movie, the movie scraper does not recognize it as a new movie even despite the fact that it's not in the library. I then have to manually add it to the library. It's with every new movie.
Do you want me to manually add the movie to the library and then show you the log again?
Ok, if that is the case, what movie should I be looking for in the previous log?

If you don't remember, then create a new log and add the new movie and tell me the name of the movie.

In the new log, run the Update Library option. If that does not work then navigate to Videos>Files and press the Information button.
Well, I guess it's pretty hard for the scraper to find something which is named "recycle" Wink

14:56:39.703 T:204608705776 WARNING: No information found for item 'nfs:// Shows/#recycle/', it won't be added to the library.

Be aware, that if you want to scrape TV shows only 2 subfolders are recommended. So let's say you have:

/volume1/TV Shows/ <- and "TV Shows" is your source you added to Kodi, you should place the TV show directly under that source, like:

/volume1/TV Shows/Homeland/ <- that's the path to the TV show itself and the first subfolder of the source. That folder could also contain subfolders for each season, like:

/volume1/TV Shows/Homeland/Season_1/ <- that's the season folder and also the 2nd subfolder of the source which should contain the episodes as playable files, such as:

/volume1/TV Shows/Homeland/Season_1/S01E01.mkv <- that's the path to the file which should be played then.


if you have an additional folder, like:

/volume1/TV Shows/recycle  <- and then "TV Shows" is still the source and you place TV shows under "recycle" like:

/volume1/TV Shows/recycle/Homeland/Season_1/S01E01.mkv <- then you have 3 subfolders under that source and the scraper will look for a TV show called "recycle" which, ofc, can't be found Wink

Hope that this will help.
Hi, I've created a new log for which I added a movie. The same result happens that the movie universal scraper does not even recognize that a new file/movie has been added, but if I add it manually it does work. I prefer to send this log by email to a Kodi support member.
I just found a problem

If Kodi search for new movie, i.e. Harry Potter, scrapper says "Nothing Found" but if I create a simple .txt file with the same name and extension, scrapper runs ok and ask me about which harry potter movie is? It is the same with a full name, i.e. The son of bigfoot (2017)

Is not happen all times, but a lot of since a few weeks. It is very annoying. Anyone sees this behavior before?

Maybe a problem with samba? All movies are stored in a samba share (the same for 5 years !!) and sometimes scrap runs correctly.

I just tried with several scrappers and works in the same way, fail and works if a I put a fake file.

You will need to provide a debug log. Full instructions are in my signature below, but here is a quick guide...

  1. Enable Debugging mode. Go to Settings>System Settings>Logging and it should be the first option or press ctrl-shift-d on a keyboard
  2. Restart Kodi
  3. Replicate the problem. Scrape the Harry Potter movie.
  4. Upload the log using either the:
    a. Manual method to Kodi Paste Site. Log location is detailed here... Log_file/Advanced#Location (wiki), or
    b. Add-on method using the Kodi Logfile Uploader. (wiki) With either method post the address link in the address bar in a new post here.
Note: Full logs only. No partial or redacted logs

Log is uploaded here: https://paste.kodi.tv/dakitizisu.kodi

Why did you give me a log with a few lines? Full logs only, thanks

Anyway, I'll take a clueless guess... Go to Settings>Media>Videos and Disable the setting Use Video Tags

Let me know if that setting was enabled please, otherwise follow this for further assistance... https://forum.kodi.tv/showthread.php?tid=336969
Sorry for the short log, next time I'll post the full one. But you are right about your clueless guess 

Thank you very much.

Do you know what is the problem?
Pages: 1 2