Kodi Community Forum

Full Version: 2018 - Amazon Fire TV Stick 4K
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2020-03-07, 09:19)blizzardreign Wrote: [ -> ]
(2020-03-05, 19:24)Kodroid Wrote: [ -> ]
(2020-03-05, 09:05)blizzardreign Wrote: [ -> ]Ahh OK I understand. Is there any way I will be able to obtain those builds? 
http://mirrors.kodi.tv/test-builds/android/arm/ 

Thank you. Will the 64 bit version work for Firestick 4k?

Could someone shed light on whether I can get higher than 100mbps using the UGREEN USB 3.0 adapter with an OTG cable? 

No - it's 64 bit chip, but 32 bit firmware. No advantages anyways -> Use 32 bit ARM.
(2020-03-07, 11:47)fritsch Wrote: [ -> ]
(2020-03-07, 09:19)blizzardreign Wrote: [ -> ]
(2020-03-05, 19:24)Kodroid Wrote: [ -> ]http://mirrors.kodi.tv/test-builds/android/arm/ 

Thank you. Will the 64 bit version work for Firestick 4k?

Could someone shed light on whether I can get higher than 100mbps using the UGREEN USB 3.0 adapter with an OTG cable? 

No - it's 64 bit chip, but 32 bit firmware. No advantages anyways -> Use 32 bit ARM.

Thank you for the reply. I would really appreciate it if you can help me with the network speed please.
(2020-03-04, 16:36)blizzardreign Wrote: [ -> ]
(2020-03-03, 20:14)fritsch Wrote: [ -> ]
(2020-03-03, 15:50)Kodroid Wrote: [ -> ]Thanks fritsch! Do you expect the fritschfiretv fixes to make it to v19? 
Everything is already in, besides the RAW vs. IEC selection possibility. Still stuck on review. 

Hi Fritsch. Do you mean that the audio mapping for the channels is now correct? That means the rear channels work correctly when on 7.1pcm audio?

Also, I'm using the UGREEN gigabit adapter with an otg cable. Is it true that the Firestick 4k is still limited to 100mbps even in this case? 
From my understanding you won't get gigabit speeds due to the usb2 bottleneck.
Should get way above 100Mb/s though, closer to 480Mb/s theoretically.

I could be wrong, i'm sure someone will correct me if so.
(2020-03-07, 08:36)fritsch Wrote: [ -> ]Don't cut logfiles. No one can help you.

On my FireTV 4k with a Denon X1300W I can switch to 24p nicely.

Sorry, here is a debug log: wekatikume.kodi (paste)
Yeah - only one mode available for you. For me it shows all available modes TV / AVR have.
(2020-03-07, 22:21)fritsch Wrote: [ -> ]Yeah - only one mode available for you. For me it shows all available modes TV / AVR have.

So that seems to be an issue between my Fire TV and my AVR that I'll have to find a solution for, or give up and go with Rpi4. 

Any ideas about the issue of 2.40 aspect ratio trailers being stretched vertically to 16:9? I can't think of a reason for that since 2.40 aspect ratio full movies display correctly. And this, too, happens only with my Leia installation on Fire TV 4k and not my Leia installation on Rpi3/Librelec, running the same version of Cinemavision add-on and plugged into the same AVR and displays.
Are you running my latest version? Same issue with 18.6?
(2020-03-07, 22:24)jubilex Wrote: [ -> ]
(2020-03-07, 22:21)fritsch Wrote: [ -> ]Yeah - only one mode available for you. For me it shows all available modes TV / AVR have.

So that seems to be an issue between my Fire TV and my AVR that I'll have to find a solution for, or give up and go with Rpi4. 

Any ideas about the issue of 2.40 aspect ratio trailers being stretched vertically to 16:9?  
That was an issue that other Android apps like Nova Video Player had with the Fire Stick 4K but they fixed it https://github.com/nova-video-player/aos-AVP/issues/259

However, it does not happen with Kodi, either the original 18.6 or Fritsch's builds on our Fire Stick 4K.
(2020-03-07, 11:47)fritsch Wrote: [ -> ]Yes. There was a race when stopping  video. How long is the freeze for you? And please post a Debug Log.

one minute or so, did not time accurately.
As it's fixed already, do you need the debug log anyway?
(2020-03-08, 10:58)Kodroid Wrote: [ -> ]
(2020-03-07, 22:24)jubilex Wrote: [ -> ]
(2020-03-07, 22:21)fritsch Wrote: [ -> ]Yeah - only one mode available for you. For me it shows all available modes TV / AVR have.

So that seems to be an issue between my Fire TV and my AVR that I'll have to find a solution for, or give up and go with Rpi4. 

Any ideas about the issue of 2.40 aspect ratio trailers being stretched vertically to 16:9?   
That was an issue that other Android apps like Nova Video Player had with the Fire Stick 4K but they fixed it https://github.com/nova-video-player/aos-AVP/issues/259

However, it does not happen with Kodi, either the original 18.6 or Fritsch's builds on our Fire Stick 4K. 

I fixed the very same in 18.6, meaning: max-width and max-height are set properly. Funny that I see my samples in that other bugreport ... my poor DSL.
See:  https://github.com/xbmc/xbmc/commit/4b95...5819a960cb - so that is in, in 18.6 and in latest fritschfiretv build
(2020-03-07, 22:24)jubilex Wrote: [ -> ]
(2020-03-07, 22:21)fritsch Wrote: [ -> ]Yeah - only one mode available for you. For me it shows all available modes TV / AVR have.

So that seems to be an issue between my Fire TV and my AVR that I'll have to find a solution for, or give up and go with Rpi4. 

Any ideas about the issue of 2.40 aspect ratio trailers being stretched vertically to 16:9? I can't think of a reason for that since 2.40 aspect ratio full movies display correctly. And this, too, happens only with my Leia installation on Fire TV 4k and not my Leia installation on Rpi3/Librelec, running the same version of Cinemavision add-on and plugged into the same AVR and displays. 

Please verify that in FireTV Screen Settings you have:
- Screen resolution automatic
- Color Mode automatic
- Switch to original refreshrate enabled

(translated from german, might actually be named differently)

Start kodi, turn on debug logging, turn off kodi, start it again and post a Debug Log, please.
(2020-03-07, 20:34)gb160 Wrote: [ -> ]
(2020-03-04, 16:36)blizzardreign Wrote: [ -> ]
(2020-03-03, 20:14)fritsch Wrote: [ -> ]Everything is already in, besides the RAW vs. IEC selection possibility. Still stuck on review. 

Hi Fritsch. Do you mean that the audio mapping for the channels is now correct? That means the rear channels work correctly when on 7.1pcm audio?

Also, I'm using the UGREEN gigabit adapter with an otg cable. Is it true that the Firestick 4k is still limited to 100mbps even in this case? 
From my understanding you won't get gigabit speeds due to the usb2 bottleneck.
Should get way above 100Mb/s though, closer to 480Mb/s theoretically.

I could be wrong, i'm sure someone will correct me if so.

Thank you for the reply. I don't understand why my question got ignored three times, but oh well. I can't seem to get a decent speed above 100 or so mbps when using it, so that's why I was wondering.
(2020-03-07, 22:24)jubilex Wrote: [ -> ]So that seems to be an issue between my Fire TV and my AVR that I'll have to find a solution for, or give up and go with Rpi4. 

The same situation happens with me sometimes. Check under settings of your Firestick 4k, under Display- Video Resolution--Auto. Click through all the way to Auto, and see if there's a message on the right about how the input isn't HDCP or something like that.

If I see that message, I restart both my display and my soundbar which my Firestick 4k is connected directly to. After that, the different resolutions and modes are available to be seen in Kodi. And the display settings do not display that error message either.

I have attached some pics to explain.

Image
Image
(2020-03-08, 15:00)fritsch Wrote: [ -> ]
(2020-03-07, 22:24)jubilex Wrote: [ -> ]
(2020-03-07, 22:21)fritsch Wrote: [ -> ]Yeah - only one mode available for you. For me it shows all available modes TV / AVR have.

So that seems to be an issue between my Fire TV and my AVR that I'll have to find a solution for, or give up and go with Rpi4. 

Any ideas about the issue of 2.40 aspect ratio trailers being stretched vertically to 16:9? I can't think of a reason for that since 2.40 aspect ratio full movies display correctly. And this, too, happens only with my Leia installation on Fire TV 4k and not my Leia installation on Rpi3/Librelec, running the same version of Cinemavision add-on and plugged into the same AVR and displays.  

Please verify that in FireTV Screen Settings you have:
- Screen resolution automatic
- Color Mode automatic
- Switch to original refreshrate enabled

(translated from german, might actually be named differently)

Start kodi, turn on debug logging, turn off kodi, start it again and post a Debug Log, please. 


Thank you for your help. I had not been aware of your Fire specifc version, I have downloaded the latest one now and will report back later after installing. The above settings match what I have.