Kodi Community Forum

Full Version: 2018 - Amazon Fire TV Stick 4K
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Does anyone know about if there is an existing issue where playing Disney or Netflix addon it detects DV , though once it matches original frame rate 24p it loses DV and colours are wrong. As workaround I had to set directly 24p in the Kodi settings, however the UI is not smooth, but in this case problem does not happen .
Currently only experiencing issue when playing Disney addon , where for example with some shows as mandalorian frame rate switches to 24p then 25p and again to 24p, tv loses dv signal and plays with wrong colours.

I have some logs :
https://paste.kodi.tv/zomasacudo

As workaround if I de whitelist 25p and 50p it plays fine 24p.
Hey @fritsch, any chance we could get an updated FireTV build re-based on the 18.7 final release that was posted today?  Either way, I really appreciate all of your efforts.  You've turned my Fire TV Stick 4K into my primary Kodi device.
Already done, you find it at the usual location. Changes: nothing, besides the version in comparison to the last one.
Periodic Video Freeze Problem and Resolution (not a Kodi Problem)

Over the past few days, SD, HD, and 4K videos have Stopped playing for several seconds and then resume.  After troubleshooting for a bit (Network, Storage) I discovered that the Sling TV app had been running in the background and force killing the app made the problem 'go away'.

I guess that makes Sling TV a bad neighbor for Kodi.  I didn't manage to pull up any references when searching and thought this might be a useful breadcrumb for future video freeze and stuttering troubleshooters.
(2020-05-21, 22:33)fritsch Wrote: [ -> ]Already done, you find it at the usual location. Changes: nothing, besides the version in comparison to the last one.

Thank you.  You're a gentleman and a scholar.
(2020-05-23, 03:49)88keyz Wrote: [ -> ]
(2020-05-21, 22:33)fritsch Wrote: [ -> ]Already done, you find it at the usual location. Changes: nothing, besides the version in comparison to the last one.

Thank you.  You're a gentleman and a scholar. 
Lol :-) I am not - but I am trying very hard ;-)
Hi!

I just bought a Firestick TV 4K in the hope of using it as a front end / client for my NextPVR TV server (which happily serves TV to all the other devices in my house so I know it works OK)

I was easily able to install Leia 18.7 using the 'Downloader' app on the Firestick and also easily installed the next-pvr Addon.
Unfortunately whilst live TV seems to stream OK, whenever I try and play TV I have recorded the stream might play a few seconds or buffer and then crash or crash immediately.

I don't *think* it is network speed related as I have a pretty decent 11ac wireless signal in the room.  Other devices in the same spot e.g. my chromecast running Libreelec work fine.

I spoke to the guys across on the NextPVR forums and based on their advice tried updating my server and reverted to Kodi 18.6, unfortunately I am still getting the same issue.

I uploaded my logs here : https://paste.kodi.tv/okohiviyaf

I have had a look at them, but can't really understand it tbh, has anyone got any advice on how to get this working or any settings I can try to get recordings to play back?

Thanks in advance

Jolltax
(2020-05-26, 20:26)Jolltax Wrote: [ -> ]Hi!

I just bought a Firestick TV 4K in the hope of using it as a front end / client for my NextPVR TV server (which happily serves TV to all the other devices in my house so I know it works OK)

I was easily able to install Leia 18.7 using the 'Downloader' app on the Firestick and also easily installed the next-pvr Addon.
Unfortunately whilst live TV seems to stream OK, whenever I try and play TV I have recorded the stream might play a few seconds or buffer and then crash or crash immediately.

I don't *think* it is network speed related as I have a pretty decent 11ac wireless signal in the room.  Other devices in the same spot e.g. my chromecast running Libreelec work fine.

I spoke to the guys across on the NextPVR forums and based on their advice tried updating my server and reverted to Kodi 18.6, unfortunately I am still getting the same issue.

I uploaded my logs here : https://paste.kodi.tv/okohiviyaf

I have had a look at them, but can't really understand it tbh, has anyone got any advice on how to get this working or any settings I can try to get recordings to play back?

Thanks in advance

Jolltax
If it's high bitrate stuff ya streaming ya might need Ethernet adapter Check out the first post in this thread. Also I would be running fritschfiretv kodi build which is available for download, link is in first post. It fixes audio sync problems.
(2020-05-26, 20:26)Jolltax Wrote: [ -> ][snip]
I was easily able to install Leia 18.7 using the 'Downloader' app on the Firestick and also easily installed the next-pvr Addon.
Unfortunately whilst live TV seems to stream OK, whenever I try and play TV I have recorded the stream might play a few seconds or buffer and then crash or crash immediately.
[snip]
I concur with the ugreen 1GigE adapter with an OTG cable.  I play 4k UHD content using this adapter.

I'm curious what the content of the TV stream you are attempting.  Anything interlaced (MPEG2, MPEG4) has caused me problems with hardware decoding on the AFTV - i solved my issues with transcoding to remove the interlacing and setting DVD's to software decoding.  I'm not familiar with the PVR stuff at all, but I do have a recollection that a lot of folks had problems with interlaced content from OTA recordings.

Hope this helps.
(2020-05-26, 21:17)thefrog Wrote: [ -> ]
(2020-05-26, 20:26)Jolltax Wrote: [ -> ][snip]
I was easily able to install Leia 18.7 using the 'Downloader' app on the Firestick and also easily installed the next-pvr Addon.
Unfortunately whilst live TV seems to stream OK, whenever I try and play TV I have recorded the stream might play a few seconds or buffer and then crash or crash immediately.
[snip]
I concur with the ugreen 1GigE adapter with an OTG cable.  I play 4k UHD content using this adapter.

I'm curious what the content of the TV stream you are attempting.  Anything interlaced (MPEG2, MPEG4) has caused me problems with hardware decoding on the AFTV - i solved my issues with transcoding to remove the interlacing and setting DVD's to software decoding.  I'm not familiar with the PVR stuff at all, but I do have a recollection that a lot of folks had problems with interlaced content from OTA recordings.

Hope this helps.   
The files are .TS files from my TV Server, they are recorded from Freeview DVB-T2 in the UK, here is what VLC says about them :

Image

Thanks to Martin who identified I had not uploaded a full debug log, here it is : http://paste.kodi.tv/soqevejide
Here is a log of Kodi 18.6 showing first playback by streaming as a file, secondly crashing whilst playing the same file as a TV Recording: http://paste.kodi.tv/esucerixaw

I have put a sample video clip here : www.zen101388.zen.co.uk/Breakfast/Breakfast_20200527_06000900.ts

I also took the liberty of making a brief video recording on my phone of what the issues actually look like : 

www.zen101388.zen.co.uk/Breakfast/KodiShizzle.mp4

Cheers

Jolltax
One thing that may, or may not, be relevant is that Freeview-HD in the UK on the PSB-3 / BBC-B mux - which carries BBC One HD, BBC Two HD, CBBC HD, ITV HD, C4 HD and C5 HD - uses on-the-fly dynamic progressive / interlaced encoder switching which can confuse some decoders (though why this would work for live TV but not for recorded TV is then a question I guess).

These channels dynamically switch the broadcast encoders between 1080p25 and 1080i25 (i.e. actually switch the encoder from progressive to interlaced) on a GOP-by-GOP basis, rather than just staying permanently in 1080i25 (and using MBAFF to handle static/native progressive content).  This increases the decoder efficiency - but has caused issues in the past for both consumer TVs (Sony TVs used to flash the on-screen banner and/or audio glitch on a format change - and you could have format changes every couple of seconds on some content...)

The interlaced/progressive switching isn't handled on a show-by-show basis (with playout metadata) - it's handled by the encoder itself, with the encoder deciding whether the content should be encoded as interlaced or progressive.
What is everyone doing about the limited space on the Firestick? I get constant low storage warnings and poor performance as a result.

I have nothing installed but unremovable system apps and Kodi.

I've tried moving Kodi to external thumb drive, but then Kodi's performance is just terrible.
(2020-05-27, 17:20)jubilex Wrote: [ -> ]What is everyone doing about the limited space on the Firestick? I get constant low storage warnings and poor performance as a result.

I have nothing installed but unremovable system apps and Kodi.

I've tried moving Kodi to external thumb drive, but then Kodi's performance is just terrible.
You might want to try a high performance SSD based flash drive like the SanDisk Extreme PRO USB 3.1 or the Transcend Jetflash 910.  That or a cheap portable SSD.
(2020-05-26, 21:35)Jolltax Wrote: [ -> ]I have put a sample video clip here : www.zen101388.zen.co.uk/Breakfast/Breakfast_20200527_06000900.ts

I also took the liberty of making a brief video recording on my phone of what the issues actually look like : 

www.zen101388.zen.co.uk/Breakfast/KodiShizzle.mp4
  
OK.  I played this file across the CIFS/NAS share.  It played fine for about 2 minutes, then locked up Kodi so hard, that I couldn't stop it.  Upon hitting the 'HOME' button on the remote, I was unable to make YouTube video play.   I tried to play Amazon Prime video, but it showed the kodi screen and then eventually seemed to reset the video to allow an amazon video to play.

I returned to Kodi and played the video again from the beginning.  Hard to tell if the voices and the video are synced due to the broadcaster using internet video and not showing the live hosts faces while they talked (i found this odd).  2:24 video freeze 2:30 audio freeze.   Timer continued past the end of the 3:24 of available video until i stopped it at 4:00 minutes.  Then, it locked up again and I played Amazon Video to reset it.

I suppose i should get a debug log on this this but I recently did a fresh install of 18.6 (because I couldn't force a downgrade to 18.6 from 18.7 with ADB.. donno why).  I'll work on this tomorrow.

Have Processing: Allow hardware accelearation - MediaCodec (Surface) and MediaCodec enabled.  


Maybe a debug log and further analysis tomorrow.