Kodi Community Forum

Full Version: SONY AF9 w/ AndroidTV Oreo - Installation via Play Store fails with Error Code -506
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
Hello Everyone!

I'm trying to install Kodi on my SONY AF9 w/ Oreo via Play Store, but the installation fails with error -506. Interestingly enough, if I then restart the TV, Kodi appears under "Apps", but can't be started. 
I've tried a complete Factory Reset and then install Kodi 17.6 immediately after OOBE, but fails with the same error code.

I also tried installing the current nightlies, but these failed as well.

What could be going wrong?

Greetings.

Onbekend
You will need to contact Sony for this. They have a habit of breaking things without notifying people.
If there is an opportunity to RMA your Sony TV and buy a different TV brand, please do so.
Well, Sony says: "Contact developer of Kodi app, it's not official app from Sony."
It seems to me that Kodi has some unknown issue with Android Oreo on Sony AF9 TV (on Sony AF8 with Android Nougat works Kodi normally).
I don't know if on the market is any other Android TV with Andoid Oreo, but it's possible that it's generic issue not specific to Sony, but to all new TVs with upcoming Android Oreo.
Is there any way how can I help to diagnose and solve this error "-506"?
Guess you got the standard answer from Sony "Not our problem" as usual. We will certainly not do anything (or know what to do) cause Kodi works just fine on any other device out there except Sony. You can take one guess where the problem lies.

Also since Sony was too cheap to even give us a TV to develop on and we would just need to buy one ourselves it you can understand the reluctance of us even to want to lift one finger for them
On Sony Kodi works normally (on Android Nougat), I have no issue with Kodi on previous Sony models. Are you sure that Kodi has no problem on any other TV running Android Oreo (if there's any)?
Kodi works on a NVIDIA SHIELD which is also Oreo. If Kodi doesn't work on a Sony TV then Sony fucked it up.
Android remains Android on whatever device it runs. It's just the driver layer underneath that's different.
It's perfect to hear that Kodi is so generic piece of software which runs on every device at the world running Android without any adaptation.  Big Grin
did you find a solution to this problem. I have they same problem with the same error code
I think Sony blocked Kodi's package id.
Me and some users tested, both Kodi 18 64bit and 32bit cannot be installed.

I compiled Kodo 32bit, changed it's package id to com.amazon.aiv.eu .
Kodi get installed and runs just fine.
How sneaky Sony is!!!
Switch to another app like mrmc, emby....
(2018-10-25, 09:00)chrisyu Wrote: [ -> ]I think Sony blocked Kodi's package id.
Me and some users tested, both Kodi 18 64bit and 32bit cannot be installed.

I compiled Kodo 32bit, changed it's package id to com.amazon.aiv.eu .
Kodi get installed and runs just fine.

Can you upload your Kodi please.
I try to change the id but not working.

Thanks
(2018-10-26, 19:42)Rossi40 Wrote: [ -> ]
(2018-10-25, 09:00)chrisyu Wrote: [ -> ]I think Sony blocked Kodi's package id.
Me and some users tested, both Kodi 18 64bit and 32bit cannot be installed.

I compiled Kodo 32bit, changed it's package id to com.amazon.aiv.eu .
Kodi get installed and runs just fine.

Can you upload your Kodi please.
I try to change the id but not working.

Thanks    
I uploaded it here, you can give it a try. 
Good luck.

https://mega.nz/#!wNUyzSDa!N3ZhqXysKprPpzmdOl-L97mq0bLrXnOaNX4a_alHdj0
https://app.box.com/v/kodi4sonytv
Thank you.
Now its working but only 1080p.
Is yours the same

Thanks
Great!
GUI resolution is locked at 1080p, but 4K videos are not down scaled. 
Check this thread for more info 335556 (thread)
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14