Kodi Community Forum

Full Version: "Could not connect to repository" after fresh install
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I can't figure out why I can't connect to Kodi repository. Tried while Windows defender and Eset are disabled but no results. Log-file is here.
Just installed a fresh W10 64 bit and Kodi b17B4 (same error on official B3 version). It seems to be related to the computer on which I installed it, on another one I can select addons. I have looked into firewall settings, copied kodi settings but still no succes. Can anyone point me in the right direction?

Error lines:
GetDirectory(addons://all/xbmc.addon.video) failed
CCurlFile::FillBuffer - Failed: SSL connect error(35)
CRepository: http://mirrors.kodi.tv/addons/leia/addons.xml.gz index has wrong digest
Please provide the full, unedited version of the debug log (wiki). We prefer to have all the information, and not just the part(s) that you find interesting. Errors can start at any moment. Smile

ESET has no history on my Windows machine as far as internet access for Kodi goes. Are you having a DNS problem with your ISP perhaps?
Here you go, thx for looking into it and your help Smile. No problems with DNS, although I am using OpenDNS 208.67.222.222/220.
Why not try 1.1.1.1 or Google's 8.8.8.8 ?
Not having any problems with those here, downloading for example http://mirrors.kodi.tv/addons/leia/addons.xml.gz
Changed to 1.1.1.1 and 8.8.8.8 but no difference. Downloading the file directly is OK but it is meant to work through Kodi (I think?).
DNS is probably not the problem, another computer on the local network is connecting fine after a fresh Kodi-install and DNS is changed on the router. So it has someting to do on the new computer. But what?

181105: problem solved in Kodi v18 beta 5. Amazing to hear that the problem was caused by processor (using Intel NUC)
Install Kodi 32bit
@Martijn 
(android) something seems to be wrong with repo and its on a some day old state. actually cant find the input_stream addon anymore in the repo and pvr.vuplus is not on the latest version (about 6 days old) - this results poeple get an old version that has a bug that was discussed here https://github.com/kodi-pvr/pvr.vuplus/issues/111
and for windows i cant see any of the binary addons with latest build
Installing Kodi 32 solves the problem. So I will stick to that version and try now and then the 64-bit.
Users have reported that my change fixed it at 334283 (thread).
My fix is in Kodi 18.0 Beta 5 and in last nightly (KodiSetup-20181103-*).