Kodi Community Forum

Full Version: Help adding share in Kodi 18 on Xbox
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

Hoping someone out there can help me with this dilemma. I have a NAS drive (Western Digital My Cloud NAS) with a separate HDD connected and also a hard drive connected to my TP-LINK router via the USB 3 connector. So I've basically got three shares in total with my media library on.

Just installed Kodi on my Xbox One (didn't know it was available on Xbox as have been using an Android box which I can't update) I had to enable SMB on the Xbox One version of Kodi 18.0-Beta5 as it wasn't already enabled. Anyway, have managed to add the WDMYCLOUD internal drive and the separate share on the HDD attached to it and can see my media on those two drives but when it comes to the HDD connected to the USB 3.0 connecter on the TP-Link router it just keeps saying that it can't connect due to the network not being connected and do I want to add it anyway.

Xbox is connected to same router with HDD connected. May I also just add that the share IS working, can see it on this laptop (looking now) and also I've added it to two android Kodi boxes previously and they can still see it.

I've tried Add network location and selecting SMB as the protocol. Let's call the share "MY-TPSHARE" and username "MyName" with password "MyPassword"

In server name I've tried "MY-TPSHARE" I left the Shared folder field blank and put username in username field and password in password field. Result: Unable to connect.

I've tried the IP of the router in the Server name and the MY-TPSHARE in the Shared Folder field. Again Username in username field and password in password field. Result: Unable to connect.

All I'm given by the router is the share name (which I can set myselfto anything) and username/password. It doesn't give me any IP address to use. In Windows I normally just do \\<name> then it'll prompt for username and password (which I enter and click 'Remember') and that's it I can just access the share. But how on earth do I add this share via Kodi 18.0 Beta 5 as for the life of me it doesn't seem to want to connect to it with any combination that I enter in Add Network Location.

Cheers Smile
i dint think kodi can read directly from your router because the router probably uses an internal file server to serve the media to your device via dlna or something similar
But it works on Kodi on the two android box(es) However, on them (Kodi V 16.1 and 17.4) there's an additional option in kodi for Android which is missing from the Kodi one Xbox One. Possibly a network wizard that I've not enabledHuh Where the 'Add network location' is in Kodi there's another option: "Windows network (SMB)" I've got the same skin installed (confluence)

When you select that it then shows 'Homegroup' I select this and then I can see my shares (including the MY-TPSHARE). I click on "MY-TPSHARE" and it then just prompts for username & password and connects the share.

However, I don't seem to be able to duplicate this in the manual 'Add network location'

Any cluesHuh