Kodi Community Forum

Full Version: [WINDOWS] HOW-TO get Sony PS3 Bluetooth Remote Control working using EventGhost
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
I have started using the ps3 remote using this guide without any problems up to now. Recently once the remote has gone into slep mode it refuses to wake up. I have either restart event ghost or the pc to get it to work again.

Any ideas?
just got this working in windows 7 rc 64 bit. very happy to have a working ps3 remote in windows with power saving built in. all I need to do now is figure out how to set a button to launch xbmc. also to get volume down working
edit: woot, I figured out how to map keys and to launch programs, switch programs and also I fixed the mapping for volume down.

ok I uploaded a new xml. the only changes I made.. fixed volume down in xbmc. red button launches c:\program files(x86)\xbmc\xbmc.exe -fs and green launches boxee in similar type dir. yellow launches the new alt tab from windows 7.. the one that pops up when you hold control alt tab. then you just press right and left to move then enter to choose which program to switch to.


has anyone figured out a way to get autorepeat working? I tried adding the autorepeat in eventghost but it doesn't seem to be working

I noticed that eventghost comes with the ps3 3.0.0 plugin.. should we instead be using magou's updated 3.0.1 from this other thread?
I noticed that although the plugin version is 3.00 in the latest eventghost, the description mentions the power saving stuff that I think magou added in 3.0.1. so I think the newest plugin comes with the newest eventghost already..

I also found this page that will install the widcomm bluetooth stack for you if you have a broadcom chip based bluetooth adapter. Widcomm stack is necessary for the power saving modes in the plugin to work. This isn't the 5.1 recommended in the plugin description it seems to be a newer 6.x version

edit 7/01/09 added new version of script with fixed mapping of the view button to info in xbmc. also mapped pop-up/menu button to bring up the context menu in xbmc
Hi guys,

Anyone experienced any pairing problems? I can't pair the sony BD remote...
The PC finds the BD Remote Control bluetooth device but when I click pair and leave the pin code empty, the Pairing error occurs...

Any ideas?
Just found out.. you have to use Microsoft bluetooth stack. I've had the HP Broadcomm's and it wont pair with the bluetooth device withoud the pin code.
I'm using the HP NC6400 notebook which came with preinstalled bluetooth drivers.

In case anyone has the same problem, here is how to remove the HP Broadcomm stack and install Microsoft:

that's really strange.. did you try updating to the newest broadcom? I think you need because it includes the widcomm stack for power saving
Power saving? To support wake up from sleep with the BD remote?
no, power saving as in the remote going into lower power sniff mode. otherwise it eats batteries
Uncola, thanks for info, I didnt know that! I will try to install the latest widcomm stack and see if it works..
Ok 2 questions here...

Im on windows 7 build 7600.

i paired the remote with the bluetooth doggle and when i right click on the device in the bluetooth window and goto services... nothing is in the box. Traditionaly you have to select HID keys but now there is nothing in the window.

Second question is when I run Eventghost and add the PS3 plugin, it only gives me the option to select the old 3.0.0 version of it even though I have the newer 3.0.1 in the directory in the plugins folder.

How do you select the newer plugin when it only shows the old plugin?

there should be stuff listed in services.. I don't think your remote is properly paired if there's nothing there...

what bluetooth stack are you using? try updating to the widcomm I linked earlier in the thread.

also I think the plugin that comes with eventghost is the newest even though it only says 3.0
i asked someone else that was in win7 using the same remote that has it working in eventhghost and they also say nothing is shown in services when you look in properties.
heres the latest updated from me..

I have 3 BT doggles...
1. Rocketfish
2. Kensington
3. Mogo

Pairing using the Kensington and Mogo do absolutly nothing in Win7. In Vista it recognizes it just fine.

The Rocketfish pairs fine in Win7 however I have 2 problems.

If I use the default BT Driver in Win7 then it pairs, but Eventghost doesnt see it in the ps3 plugin.

If I use the Rocketfish driver or a newer driver in general then Eventghost sees the Broadcom BlueTooth Remote.

The only issue at that point is that even though I selected the Broadcom remote in the PS3 plugin... I can press the buttons on the remote and nothing happens as in no actions at all. When I am pressing the buttons, the bluetooth doggle itself blinks acknowledging that it is recognizing the buttons pressed.

Perhaps these 3 doggles just don't cut it for quality eh?

BTW I used 2 versions of Eventghost.. _0.3.7.r1076 and

What is a good reputable doggle that is a for sure in Windows 7?
might be an obvious question, but did you map any of the buttons in eventghost? you can try loading my events.. I posted my script in an earlier post
edit: also, I am in win7 64 rc and when the remote is correctly paired, it shows the services.. you might have to press ab utton on the remote to wake it up. I'm using an msi star key 2.0 100m usb dongle.. with the newest broadcom/widcomm update
Im using the mapped buttons from the profile ive been using for awhile. The only different thing in all this is the compatibility of these damn doggles in Win7 vs Vista since 2 of the ones I listed won't even pair themselves at all with the remote and the Rocketfish will but, it doesnt show any services for the remote when I right click on the remote. Yes I am using the latest broadcom/widcomm update since all three so happen to use 'Microsoft Bluetooth Enumerator' which shows in the device manager under Bluetooth Radios.

There is also the issue of how to get Eventghost to recognize the newer PS3 plugins since it will only show 3.0.0 and nothing newer even though i overwritten the ps3 plugin with the newer one. How do I get EG to recognize the newer PS3 plugin?
Last time I checked, the latest broadcom stack was missing the widcomm SDK. Eventghost will also display an error regarding the driver complaining about this too.

It will work, but it won't park or sniff.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17