Kodi Community Forum

Full Version: Kodi Xbox one cant connect QNAP (SMB/NFS)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello fellow Kodis,

i am using Kodi on my Amazon Fire TV and connect via SMB to my QNAP NAS without any Problems.

When i try to setup Kodi on my XBOX one with the exact some settings i fail miserably...

After reading through all threads i could find regarding the matter i tried the following

-installed SMB add on
-tried connecting to the exact same share as on ATV -> cant connect to server
-tried to connect via NFS -> i could see my NAS IP and could select it, then i see my different shares on the NAS when i select one of them KODI stops responding
-reviewed the NFS settings in the QNAP NAS and NFS for that particular share is set to GUESTS have full rights.

So seems to me that SMB is definately working differently on the XBOX ONE version than on good ole Android.

What other chances do i have to solve this Problem ? I never played around with FTP regarding KODI.

The NAS is my good old QNAP 209 Dinasour....old and rusty but a steady and reliable rock.

Any help would be appreciated.

try sftp i think it has something to do with smb been so old not 100%

you mean ftp ?

Never heard about sftp....


i guess the old NAS does not support SMB 2/3 so i still hope they add SMB 1.0 Support to Kodi XBOX ONE, since it works flawless on the ATV Version.

On the other hand i dont understand why the NFS access leads to KODI freezing (seems to be an issue for a lot of People).

I somehow doubt that FTP will solve the Problem, but might give it a try...

(2018-12-10, 15:08)Landario Wrote: [ -> ]i still hope they add SMB 1.0 Support to Kodi XBOX ONE

no SMB1 support will be added.

so what is your suggestion to solve the Problem :-)

(2018-12-11, 00:30)Landario Wrote: [ -> ]so what is your suggestion to solve the Problem :-)

using modern software on NAS
Hi there
My NAS (a 419P II Dinosaur) runs NFS v2 and v3 and could even support v4.
Still the Beta 18 Kodi does not work - I have the same problem as the OP. 
Are there any other solution suggestions out there?
Support much appreciate!
Just found that I can download smb support in the add-on center (need to go to Addons / ALL and then scroll to "smb plugin").
I had to activate this plugin and now I can connect to my NAS via SMB (which is the same way I use on my raspberry Pi, my iPhone, Android tablet and my appleTV).
Forgot to mention: It works, but I can still not browse. I need to type in the network path to Movies or TV shows by hand.
I am not using a leading "/" or a "/" behind the expression.
Just typing in
and it works