Kodi Community Forum

Full Version: Is mirrors.kodi.tv down for everyone else as well?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I'm doing a new Kodi install because i couldn't download any of the addons from the official repository, then tried to reach the mirror.kodi.tv but i can reach it intermittently, i also use some web tools to check the page and it does seem to not respond properly even there, but i can ping it fine, is there a maintenance going on? Is the connection to the repository spotty for everyone else or is it an isolated issue?
There is no maintenance, but I have seen one or two other posts this morning stating they had trouble connecting, but they eventually got through.

Can you provide the link to the web page tools you used so we can see. Also which country are you in, or do you know which server you are connecting to?

Maybe @Kib might have more information when sunrise comes to his part of the world.
I have also seen alot of other posts about trouble downloading from the official and the mirror links and could not connect to repository. Im not able to open the official Kodi repository to install add-ons getting could not connect to repository. It was working fine last night. Thanks Team Kodi for all your hard work greatly appreciate it.
I was using 




it is working right now, but it wasn't just few minutes ago, it's been spotty since last night, i'm in China, but i have access do different proxy from usa russia japan and others, all having same trouble, and i have no idea how to check which server i'm connecting to...
Thanks @grandixximo

Just so I can make sure I replicate what you are seeing, in the webpagetest.org, what are you entering for Website URL and Test Location?
First, I apologize if I write this on the wrong section (I don't know where to post this).

Today I've try to install Kodi 18 RC from playstore to my Mi TV, and found that I can't install or update any addons on my system (there always says couldn't connect to repo)

I can't verify if the server is down or maintenance (I don't know how do that) or there is a problem on the app.

Btw if it can help, I'm from South East Asia region (in any case the problem occurred from the server mirror from my region).

Thanks before.
Hello @flawlite,

There have been other members that have stated they are having problems with the repo and one stated he was from Asia. But we are not conducting any maintenance, and it is night time for our Server Administrator so he won't see any reports until his morning time.

Shortly I will merge your post with the other thread on this topic.
Ok, the mirrors issue is affecting me to. Seems like mirrors.kodi.tv is down.
Trying to update to Leia RC2 for the past couple days and it appears that mirrors.kodi.tv is down.  
I attempted the current stable build and got the same results.  http://www.isitdownrightnow.com shows that it's unresponsive as well.

Any word on when we'll be able to download updates?
Hello @Arcanthur

The problem has just recently appeared. It seems sporadic and if you try a few times you will get lucky and the download will start. It is night time for our Server Admin, so might be a few hours before anyone can look at it.

I'll merge your post into the growing thread regarding this issue Wink
Good morning,
mirrors.kodi.tv is still down and unreachable. when it will be online again? Smile
Don't know @skybird1980. I'll merge your post, and read my post directly above yours.
Just wanted to chime in say I am experiencing the same issues since last night (around 12 hours ago) and have noticed it comes online occasionally but unfortunately not long enough for me to be able to start a download.
Hello, confirmation from central europe (Czech rep.) tried to use 3 different connection provider but mirrors.kodi.tv wont work. Response for ping is OK, but no content available
Pages: 1 2