Kodi Community Forum

Full Version: Unable to Connect to PC from KODI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So... had a few scraping issues this week with OpenElec and was made aware that OpenElec is well, gone. So I backed up my files last night, and this afternoon I formatted my C:\ drive and installed LibreElec. 

I have a 32GB SSD drive for the OS, and then a 3TB drive for Movies, and a 3TB drive for TV_Series. I have the Movies and TV_Series drives linked on my Win10 PC as network drives under My Computer.

As soon as it was installed, my Win10 desktop PC network drive connections worked. I didn't have to re-add them or anything, I click Movies and my movie files list, same as TV_Series.

On the HTPC however... and I had this issue once before that just self-corrected so no idea what the fix was... I can't add a folder from my Win10 PC.

On Win10 I have my Downloads folder shared. I was able to click Videos on the main screen of Kodi, see Downloads folder listed, click it and I could see the files I had for testing/viewing. The Win10 system hasn't changed. I was able to see and use the folder this morning before I switched to LibreElec. Plus, on Win10 when I click to view the network, I can't see the HTPC listed. My mapped drives work so Win10 can connect... but doesn't show... ?

Tried a few tutorials, going to Add Network Location, and trying to add the folder manually, but just getting Operation not Permitted, and connection couldn't be established errors.

Do I need an error log? or are there a few basic things I should try first?

Again... Win10 PC should be setup and ready. Been using that shared folder for 2yrs now with OpenElec. I did check and made sure both systems are WORKGROUP, I went into Turn Windows Features On/Off and made sure the SMB option was on. Tried multiple reboots. At this point I'm just repeating the same stuff in a different order.
The problem with the older OpenELEC is, that is uses SMB1 as a protocol to connect to Windows shares. LibreELEC, by default, is not set up to use SMB1 anymore as that protocol is vulnerable and we decided to use SMB2 instead.

That means, you have to share your drives differently at the Windows side of things. Shares now need a username and a password. Anonymous browsing was a SMB1 feature and (AFAIK) there's no equivalent to SMB2. So you have 2 options now:

- Create new Windows shares with usernames and passwords (recommended)
- setup LibreELEC to use SMB1 (not recommended)
At about 2AM I think I stumbled on that... I saw that the settings said minimum SMB2, max SMB3 and remembered on the PC something about SMB1 in the turn features on/off so set it to SMB1 for minimum, which gave me errors, rebooted and was able to add the PC with the IP, still couldn't just browse to it.

So, Win10 I just installed this year and setup the share... why would it not be SMB2 or SMB3? If I create new shares, won't they be the same as the ones I created 8 months ago? (SMB1)?

Do I need to download some sort of Win10 update to SMB3?
You need to create new shares for SMB2, because that needs a username and a password.

Also network browsing for shares won't be possible anymore with SMB2 (that was a SMB1 feature and there's no equivalent for SMB2). It will probably list the available hosts, but not the shares those hosts have. So you have to know how the share is called or what the path to it is. To list available shares from a windows 10 machine, open the console window and enter net share. That will list all available shares with their name and their specific paths.

You could probably do that from LE via SSH as well. The linux command for that is: smbclient -l <ip_of_server_here>

At LibreELEC and inside Kodi, you need to add the SMB2 share via "Files" -> "Add videos" -> "Browse" -> "Add network location", then select "Windows network (SMB)", then fill out the dialog:

- specify the server IP
- add the path to the share
- enter a username and a password

After that is done and you did it correct, the containing files/folders should be listed at the upcoming window. At this point you are able to select either the folder you are currently at, or some underlying folder as a source.
Hmm.... my shares already had a username/password

I enabled using SMB1 as the minimum instead of SMB2, then added the information you listed above (IP, location,name, pass) and it worked. But when I did that with SMB2 as the minimum it didn't work.

So, my share was already setup with a username/password, should that not mean it was SMB2? That's where I'm getting lost... because if I create a new share account, it'll be the same as what I have now unless there's a checkbox somewhere in the process for choosing which SMB to use.
Using LibreELEC here I set it up with min SMB2 and max SMB3 and it works here. But my samba server is not windows in that case and I also made sure, the server supportes the same as LibreELEC does. Not sure how to configure that Windows-wise
If you enabled Windows to be able to do SMB1 your experience might be different. My server currently doesn't support SMB1 at all
Now I have a new issue. Upgraded the PC in the TV room with libreElec, was expecting to be able to browse and find the htpc server but no luck there either.

Not sure why people prefer this Linux/Unix stuff... For me, when I used Windows it all worked. Smile
(2018-12-23, 07:19)THRobinson Wrote: [ -> ]was expecting to be able to browse and find the htpc server but no luck there either.
Network browsing is no longer supported as from SMBv2. Use the "Add a network location.." option and add your network source(s).

(2018-12-23, 07:19)THRobinson Wrote: [ -> ]Not sure why people prefer this Linux/Unix stuff... For me, when I used Windows it all worked.
This has nothing to do with "this Linux/Unix stuff". Linux has its own challenges with NFS. Windows' SMB worked for everyone because Microsoft simply didn't put locks on its SMBv1 doors, and everyone could walk in and out your computer freely. And look what happened (=> Google for 'WannaCry'). Then Microsoft went putting band-aids all over the SMB protocol which didn't help for clarity.
(2018-12-23, 07:19)THRobinson Wrote: [ -> ]Upgraded the PC in the TV room with libreElec, was expecting to be able to browse and find the htpc server but no luck there either

The same reason I mentioned above. Network browsing is not possible anymore.

Follow this video to connect to the samba shares LibreELEC provides: https://www.youtube.com/watch?v=oBlHCuGGrJ8
Just an update... Got my htpc connected, as well as my remote htpc in the living room. Same deal for both, I had to manually put in the IP and share name etc, browse doesn't work. I installed kodi to my Android tablet and browsing to add a source worked totally fine.

So... Browsing is still possible, which makes sense or else why have the option? Just seems to not work from LibreElec.