Kodi Community Forum

Full Version: Kodi crashes when trying to update library
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've read through the forums and have tried updating the addons and from what I can tell they are the latest version.

First log I did library update and clicked yes through several connection problem notifications. Eventually Kodi completely crashes.
https://paste.kodi.tv/ixibiqepuz.kodi

Then I relaunched and checked my addons for IMDB connection and disabled if I saw it. I also disabled the video tag option and then tried to update the library. It crashed almost immediately.
https://paste.kodi.tv/wavusejila.kodi

I do seem to be able to scan a folder directly to the library though. Any thoughts on what is going on?
Sorry, no I have no idea what is going on. Your first log is a mess so definitely keep Video Tags setting Disabled.

You have lots of searches for part torrent files, so you should remove them...
Searching for '~uTorrentPartFile 1D2143451D' using The Movie Database scraper

Lots of log spam from the scraper, which I haven't seen in a while but you are using a relatively current nightly so don't know why that is happening. Maybe recent changes by @scudlee ?

Your second log is much cleaner, probably due to Video Tags being disabled (keep it disabled), but ends up crashing around a cURL entry.

Can you redo your second log, but this time also enable Component Logging (same place where you enable debug mode) and select Verbose logging for the libcURL library.... Lets see what that shows.
Okay... I followed your instructions to activate the Component Logging and libcURL. I then went to the Movies section and it crashed before I could even click update library.
https://paste.kodi.tv/vimutekida.kodi
I updated to the newest nightly build and ran the same scenario. Kodi crashed as soon as entered the Movies section and before I could click Update Library.

https://paste.kodi.tv/ehepijucuv.kodi
I don't really know what the problem is, but I see the following errors at the end of your log...
08:22:50.077 T:9904   ERROR: ffmpeg[26B0]: [matroska,webm] Read error at pos. 1 (0x1)
08:22:50.077 T:9904 ERROR: ffmpeg[26B0]: [matroska,webm] EBML header parsing failed
08:22:50.077 T:9904 ERROR: CDVDDemuxFFmpeg::Open - Error, could not open file M:\Movie Packs\KEANU_REEVES_720p_MEGAPACK\The.Matrix.Revolutions.2003.720p.BluRay.x264-CtrlHD.mkv

It's probably too hard to remove the Source from your library due to the crashing, so if you exit Kodi then go to
1. C:\Users\Jacob\AppData\Roaming and rename the Kodi folder to KodiOld
2. Restart Kodi, and Kodi will re-create the folder with fresh settings.
3. Can you use Kodi without crashing?
4. Once you confirm it does not crash, add back that Movie Packs Source and see if it starts crashing again. If it does, then your problem is the movies which is not something we can help you with.
Go to developer settings on the Shield and increase the buffer logger to e.g. maximum.
That‘s it!
All my befor changings in Windows, SMB, LAN/Ethernet, Firewall, Registry adjustments were for nothing; roll them back.
Since I increased the buffer logger value in the Shield, I had no crashes with Kodi.
I get the tip in an other forum.